summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2008-12-22 19:09:31 +0000
committerNed Ludd <solar@gentoo.org>2008-12-22 19:09:31 +0000
commita9f0314790a97e3ed26cf1d9d57bff38bc957044 (patch)
tree28f81356235246e49a5519c970b827b784cabe6a /sys-devel
parent- start getting eclass ready for gcc:4 (diff)
downloadgentoo-2-a9f0314790a97e3ed26cf1d9d57bff38bc957044.tar.gz
gentoo-2-a9f0314790a97e3ed26cf1d9d57bff38bc957044.tar.bz2
gentoo-2-a9f0314790a97e3ed26cf1d9d57bff38bc957044.zip
- prep initial work for pie patches. thanks to kevq,zorry,psm and many others
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog5
-rw-r--r--sys-devel/gcc/gcc-4.3.2.ebuild14
2 files changed, 17 insertions, 2 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 05dab9f612dd..73cd225a698e 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.667 2008/12/07 19:06:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.668 2008/12/22 19:09:31 solar Exp $
+
+ 22 Dec 2008; <solar@gentoo.org> gcc-4.3.2.ebuild:
+ - prep initial work for pie patches. thanks to kevq,zorry,psm and many others
07 Dec 2008; Mike Frysinger <vapier@gentoo.org> gcc-4.3.2.ebuild:
Fix by Chi-Thanh Christopher Nguyen to pull in
diff --git a/sys-devel/gcc/gcc-4.3.2.ebuild b/sys-devel/gcc/gcc-4.3.2.ebuild
index bfe98d39883c..aa4b493643ef 100644
--- a/sys-devel/gcc/gcc-4.3.2.ebuild
+++ b/sys-devel/gcc/gcc-4.3.2.ebuild
@@ -1,12 +1,24 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.2.ebuild,v 1.7 2008/12/07 19:06:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.2.ebuild,v 1.8 2008/12/22 19:09:31 solar Exp $
PATCH_VER="1.2"
UCLIBC_VER="1.0"
ETYPE="gcc-compiler"
+# Hardened gcc 4 stuff
+PIE_VER="10.1.2"
+PIE_GCC_VER="4.3.2"
+#SPECS_VER="0.9.0"
+#SPECS_GCC_VER="4.3.2"
+
+# arch/libc configurations known to be stable or untested with {PIE,SSP,FORTIFY}-by-default
+PIE_STABLE="x86 amd64 ~ppc ~ppc64 ~arm ~sparc"
+PIE_UCLIBC_STABLE="x86 arm"
+#SSP_STABLE="amd64 x86 ppc ppc64 ~arm ~sparc"
+#SSP_UCLIBC_STABLE=""
+
# whether we should split out specs files for multiple {PIE,SSP}-by-default
# and vanilla configurations.
SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed