summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-11 07:49:45 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-11 07:49:45 +0000
commitc1bd9bef94928bb689fff4ade3b050a3109902eb (patch)
tree2384cea7e8ef312e7dc5e505ed1a9908f0ec5f8f /sys-devel
parentNew package: dev-ruby/delayer (diff)
downloadgentoo-2-c1bd9bef94928bb689fff4ade3b050a3109902eb.tar.gz
gentoo-2-c1bd9bef94928bb689fff4ade3b050a3109902eb.tar.bz2
gentoo-2-c1bd9bef94928bb689fff4ade3b050a3109902eb.zip
Always use built-in ConfigParser to work-around issues with configparser-3.2, bug #500856.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog8
-rw-r--r--sys-devel/llvm/files/llvm-3.4-cmake-configparser.patch35
-rw-r--r--sys-devel/llvm/llvm-3.4-r2.ebuild5
-rw-r--r--sys-devel/llvm/llvm-3.4.1-r1.ebuild5
4 files changed, 50 insertions, 3 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index e632eee3e4a6..9a680741bd2d 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.197 2014/05/11 11:17:08 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.198 2014/06/11 07:49:45 mgorny Exp $
+
+ 11 Jun 2014; Michał Górny <mgorny@gentoo.org>
+ +files/llvm-3.4-cmake-configparser.patch, llvm-3.4-r2.ebuild,
+ llvm-3.4.1-r1.ebuild:
+ Always use built-in ConfigParser to work-around issues with configparser-3.2,
+ bug #500856.
11 May 2014; Michał Górny <mgorny@gentoo.org> -llvm-3.3-r1.ebuild,
-llvm-3.4-r1.ebuild, -llvm-3.4.ebuild:
diff --git a/sys-devel/llvm/files/llvm-3.4-cmake-configparser.patch b/sys-devel/llvm/files/llvm-3.4-cmake-configparser.patch
new file mode 100644
index 000000000000..cda8bdc4e1ab
--- /dev/null
+++ b/sys-devel/llvm/files/llvm-3.4-cmake-configparser.patch
@@ -0,0 +1,35 @@
+From 773560acfad511769017e971991c0305dbc0323d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 11 Jun 2014 09:40:26 +0200
+Subject: [PATCH] Avoid using external configparser in favor of built-in
+ ConfigParser.
+
+We only support Python 2 anyway, and configparser-3.2 is known to break
+the build. Since some packages actually force version 3.2, and we do not
+to pull in extra dependencies, forcing built-in seems to be the best
+option.
+
+Fixes: https://bugs.gentoo.org/show_bug.cgi?id=500856
+---
+ utils/llvm-build/llvmbuild/componentinfo.py | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/utils/llvm-build/llvmbuild/componentinfo.py b/utils/llvm-build/llvmbuild/componentinfo.py
+index eda3a48..c963ef1 100644
+--- a/utils/llvm-build/llvmbuild/componentinfo.py
++++ b/utils/llvm-build/llvmbuild/componentinfo.py
+@@ -3,10 +3,7 @@ Descriptor objects for entities that are part of the LLVM project.
+ """
+
+ from __future__ import absolute_import
+-try:
+- import configparser
+-except:
+- import ConfigParser as configparser
++import ConfigParser as configparser
+ import sys
+
+ from llvmbuild.util import *
+--
+2.0.0
+
diff --git a/sys-devel/llvm/llvm-3.4-r2.ebuild b/sys-devel/llvm/llvm-3.4-r2.ebuild
index 6fba4cede180..5ea1f7a324d4 100644
--- a/sys-devel/llvm/llvm-3.4-r2.ebuild
+++ b/sys-devel/llvm/llvm-3.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4-r2.ebuild,v 1.4 2014/05/01 15:09:30 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4-r2.ebuild,v 1.5 2014/06/11 07:49:45 mgorny Exp $
EAPI=5
@@ -167,6 +167,9 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-3.4-gentoo-install.patch
# Hack cmake search path for Gentoo, bug #496480
epatch "${FILESDIR}"/${PN}-3.3-cmake-modulepath.patch
+ # Use built-in ConfigParser to avoid failures with configparser-3.2
+ # https://bugs.gentoo.org/show_bug.cgi?id=500856
+ epatch "${FILESDIR}"/${PN}-3.4-cmake-configparser.patch
if use clang; then
# Automatically select active system GCC's libraries, bugs #406163 and #417913
diff --git a/sys-devel/llvm/llvm-3.4.1-r1.ebuild b/sys-devel/llvm/llvm-3.4.1-r1.ebuild
index 0881ad16c441..8cb1ea0a4fb5 100644
--- a/sys-devel/llvm/llvm-3.4.1-r1.ebuild
+++ b/sys-devel/llvm/llvm-3.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.1-r1.ebuild,v 1.1 2014/05/10 22:32:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.1-r1.ebuild,v 1.2 2014/06/11 07:49:45 mgorny Exp $
EAPI=5
@@ -170,6 +170,9 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-3.4-gentoo-install.patch
# Hack cmake search path for Gentoo, bug #496480
epatch "${FILESDIR}"/${PN}-3.3-cmake-modulepath.patch
+ # Use built-in ConfigParser to avoid failures with configparser-3.2
+ # https://bugs.gentoo.org/show_bug.cgi?id=500856
+ epatch "${FILESDIR}"/${PN}-3.4-cmake-configparser.patch
if use clang; then
# Automatically select active system GCC's libraries, bugs #406163 and #417913