summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-10 16:00:11 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-10 16:00:11 +0000
commitdd37661e31e981441bf363d837eff66e9a458aaf (patch)
treec56823f3c61d4aac1c61d2a38764e82b69d74ece /sys-devel
parentAdded localedata (diff)
downloadgentoo-2-dd37661e31e981441bf363d837eff66e9a458aaf.tar.gz
gentoo-2-dd37661e31e981441bf363d837eff66e9a458aaf.tar.bz2
gentoo-2-dd37661e31e981441bf363d837eff66e9a458aaf.zip
Dependencies and glibc update
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/binutils-2.10.0.33.ebuild64
-rw-r--r--sys-devel/binutils/binutils-glibc-2_1_97-sdk-2.10.0.33.ebuild68
-rw-r--r--sys-devel/gcc/gcc-glibc-2_1_97-sdk-2.96.20000731-r1.ebuild16
3 files changed, 100 insertions, 48 deletions
diff --git a/sys-devel/binutils/binutils-2.10.0.33.ebuild b/sys-devel/binutils/binutils-2.10.0.33.ebuild
new file mode 100644
index 000000000000..1d890c9013a1
--- /dev/null
+++ b/sys-devel/binutils/binutils-2.10.0.33.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.10.0.33.ebuild,v 1.1 2000/11/10 16:00:11 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools necessary to build programs"
+SRC_URI="ftp://ftp.varesearch.com/pub/support/hjl/binutils/${A}"
+
+src_compile() {
+ try ./configure --prefix=/usr --host=${CHOST}
+ try make
+}
+
+src_install() {
+ #I'm sure this can be simplified with a "try make PREFIX=${D}/usr install"
+ #one of these days...
+ into /usr
+ doman binutils/*.1 gas/doc/as.1 gprof/gprof.1
+ insinto /usr/lib
+ doins bfd/libbfd.la bfd/libbfd.a opcodes/libopcodes.a opcodes/libopcodes.la libiberty/libiberty.a
+ insinto /usr/include
+ doins bfd/bfd.h include/ansidecl.h include/bfdlink.h
+ cp binutils/nm-new binutils/nm
+ cp binutils/strip-new binutils/strip
+ cp gas/as-new gas/as
+ cp gas/gasp-new gas/gasp
+ cp ld/ld-new ld/ld
+ cd binutils
+ dobin addr2line ar cxxfilt nm objcopy objdump ranlib readelf size strings strip
+ cd ..
+ dobin ld/ld gprof/gprof gas/as gas/gasp
+ dodir /usr/${CHOST}/bin
+ for i in nm strip ar ranlib as ld
+ do
+ dosym /usr/bin/${i} /usr/${CHOST}/bin/${i}
+ done
+ insinto /usr/${CHOST}/lib/ldscripts
+ doins ld/ldscripts/*
+ dodoc COPYING* README* ChangeLog* mpw-README
+ docinto bfd
+ dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
+ docinto binutils
+ dodoc binutils/MAINTAINERS binutils/NEWS binutils/README
+ docinto gas
+ dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/MAINTAINERS gas/NEWS gas/README*
+ docinto gprof
+ dodoc gprof/ChangeLog* gprof/MAINTAINERS gprof/NOTES gprof/TEST gprof/TODO
+ docinto include
+ dodoc include/ChangeLog* include/COPYING include/MAINTAINERS
+ docinto intl
+ dodoc intl/ChangeLog
+ docinto ld
+ dodoc ld/ChangeLog* ld/MAINTAINERS ld/README ld/NEWS ld/TODO
+ docinto libiberty
+ dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
+ docinto opcodes
+ dodoc opcodes/ChangeLog* opcodes/MAINTAINERS
+
+}
+
+
+
diff --git a/sys-devel/binutils/binutils-glibc-2_1_97-sdk-2.10.0.33.ebuild b/sys-devel/binutils/binutils-glibc-2_1_97-sdk-2.10.0.33.ebuild
index 19ed048da16c..c3e0c49d217c 100644
--- a/sys-devel/binutils/binutils-glibc-2_1_97-sdk-2.10.0.33.ebuild
+++ b/sys-devel/binutils/binutils-glibc-2_1_97-sdk-2.10.0.33.ebuild
@@ -1,63 +1,43 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-glibc-2_1_97-sdk-2.10.0.33.ebuild,v 1.1 2000/11/07 13:23:52 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-glibc-2_1_97-sdk-2.10.0.33.ebuild,v 1.2 2000/11/10 16:00:11 achim Exp $
-GLIBCV="2.1.97"
+export GLIBCV="2.1.97"
+export TCPU="i686"
+export THOST="${TCPU}-glibc${GLIBCV}-linux"
+
A=binutils-2.10.0.33.tar.gz
S=${WORKDIR}/binutils-2.10.0.33
DESCRIPTION="Tools necessary to build programs"
SRC_URI="ftp://ftp.varesearch.com/pub/support/hjl/binutils/${A}"
-src_compile() {
- try ./configure --prefix=/opt/glibc-${GLIBCV}-sdk --host=${CHOST} \
- --target=${CHOST}
- cd ld
- cp Makefile Makefile.orig
- sed -e "s:^tdir_elf_i386=${CHOST}:tdir_elf_i386=i686-linux-glibc-${GLIBCV}:" \
- Makefile.orig > Makefile
- cd ..
- try make target_alias=i686-linux-glibc-${GLIBCV}
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --target=${THOST} \
+ --prefix=/usr/${TALIAS}
+# cd ld
+# cp Makefile Makefile.orig
+# sed -e "s:^tdir_elf_i386=${CHOST}:tdir_elf_i386=${THOST}:" \
+# Makefile.orig > Makefile
+# cd ..
+ try make
}
src_install() {
#I'm sure this can be simplified with a "try make PREFIX=${D}/usr install"
#one of these days...
- try make target_alias=i686-linux-glibc-${GLIBCV} prefix=${D}/opt/glibc-${GLIBCV}-sdk install
-
- cd ${D}/opt/glibc-${GLIBCV}-sdk/${CHOST}/lib/ldscripts
-
- for i in *
- do
- cp $i $i.orig
- sed -e "s:^SEARCH_DIR.*:SEARCH_DIR(/opt/glibc-${GLIBCV}-sdk/lib); SEARCH_DIR(/opt/glibc-${GLIBCV}-sdk/i686-linux-glibc-${GLIBCV}/lib); SERACH_DIR(/lib); SEARCH_DIR(/usr/lib); SEARCH_DIR(/usr/local/lib);:" $i.orig > $i
- rm $i.orig
- done
- cd ${S}
- rm -r bin include lib man share
- mv ${CHOST}/* .
- rm -r ${CHOST}
- dodoc COPYING* README* ChangeLog* mpw-README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/MAINTAINERS binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/MAINTAINERS gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/MAINTAINERS gprof/NOTES gprof/TEST gprof/TODO
- docinto include
- dodoc include/ChangeLog* include/COPYING include/MAINTAINERS
- docinto intl
- dodoc intl/ChangeLog
- docinto ld
- dodoc ld/ChangeLog* ld/MAINTAINERS ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog* opcodes/MAINTAINERS
+ try make prefix=${D}/usr/${THOST} install
+
+# cd ${D}/usr/${THOST}/${THOST}/lib/ldscripts
+# for i in *
+# do
+# cp $i $i.orig
+# sed -e "s:^ *SEARCH_DIR.*:SEARCH_DIR(/usr/${THOST}/lib); SEARCH_DIR(/usr/${THOST}/${THOST}/lib); SERACH_DIR(/lib); SEARCH_DIR(/usr/lib); SEARCH_DIR(/usr/local/lib);:g" $i.orig > $i
+# rm $i.orig
+# done
}
diff --git a/sys-devel/gcc/gcc-glibc-2_1_97-sdk-2.96.20000731-r1.ebuild b/sys-devel/gcc/gcc-glibc-2_1_97-sdk-2.96.20000731-r1.ebuild
index 0bacb71714c5..740dee870527 100644
--- a/sys-devel/gcc/gcc-glibc-2_1_97-sdk-2.96.20000731-r1.ebuild
+++ b/sys-devel/gcc/gcc-glibc-2_1_97-sdk-2.96.20000731-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-glibc-2_1_97-sdk-2.96.20000731-r1.ebuild,v 1.2 2000/11/09 13:37:01 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-glibc-2_1_97-sdk-2.96.20000731-r1.ebuild,v 1.3 2000/11/10 16:00:11 achim Exp $
P=gcc-2.96.20000731
A="gcc-2.96-20000731.tar.bz2 libg++-2.8.1.3.tar.gz libg++-2.8.1.3-20000914.diff.gz"
@@ -31,7 +31,7 @@ src_unpack() {
# rm -rf texinfo
# mv ../libg++-2.8.1.3/* .
# rmdir ../libg++-2.8.1.3
- cd ${FILESDIR}/libioP.h ${S}/libio
+ cp ${FILESDIR}/libioP.h ${S}/libio
}
src_compile() {
@@ -47,13 +47,21 @@ src_compile() {
--with-gxx-include-dir=${T}/include/g++ \
--oldincludedir=${T}/${THOST}/include
- try make
+ try make LANGUAGE="c"
+ cd gcc
+ try make stage1
+ cd stage1
+ cp specs specs.orig
+ sed -e "s:-dynamic-linker /lib/ld-linux.so.2:-dynamic-linker ${T}/${THOST}/lib/ld-linux.so.2 -rpath ${T}/${THOST}/lib:" specs.orig > specs
+ cd ../..
+ try make CC=\"stage1/xgcc -Bstage1/\" CFLAGS=\"${CFLAGS}\" LIBGCC1="libgcc1.a" OLDCC="./xgcc"
}
src_install() {
export PATH=${T}/bin:${PATH}
try make install prefix=${D}/${T} mandir=${D}${T}/man \
- gxx_include_dir=${D}${T}/include/g++
+ gxx_include_dir=${D}${T}/include/g++ \
+ CC="stage1/xgcc -Bstage1/" CFLAGS="$CFLAGS"
FULLPATH=${D}${T}/lib/gcc-lib/${THOST}/${PV}
cd ${FULLPATH}