summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-11-15 06:42:33 +0000
committerMike Frysinger <vapier@gentoo.org>2014-11-15 06:42:33 +0000
commitf4d6523da71d1113e42820c4a7624be87d02cac3 (patch)
tree890be0e1e8c164d567b8c2d9bbee42f84fde4996 /sys-devel
parentBackport fix from upstream for warnings with perl-5.16+ #424453 by Alexander ... (diff)
downloadgentoo-2-f4d6523da71d1113e42820c4a7624be87d02cac3.tar.gz
gentoo-2-f4d6523da71d1113e42820c4a7624be87d02cac3.tar.bz2
gentoo-2-f4d6523da71d1113e42820c4a7624be87d02cac3.zip
Fix perl syntax to work with latest versions
(Portage version: 2.2.14/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/automake/ChangeLog8
-rw-r--r--sys-devel/automake/automake-1.4_p6-r2.ebuild (renamed from sys-devel/automake/automake-1.4_p6-r1.ebuild)3
-rw-r--r--sys-devel/automake/files/automake-1.4-perl-dyn-call.patch23
3 files changed, 32 insertions, 2 deletions
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index c97a5a7ce643..a4df437d4c6d 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/automake
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.216 2014/11/15 06:30:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.217 2014/11/15 06:42:33 vapier Exp $
+
+*automake-1.4_p6-r2 (15 Nov 2014)
+
+ 15 Nov 2014; Mike Frysinger <vapier@gentoo.org> +automake-1.4_p6-r2.ebuild,
+ +files/automake-1.4-perl-dyn-call.patch, -automake-1.4_p6-r1.ebuild:
+ Fix perl syntax to work with latest versions
*automake-1.10.3-r1 (15 Nov 2014)
*automake-1.11.6-r1 (15 Nov 2014)
diff --git a/sys-devel/automake/automake-1.4_p6-r1.ebuild b/sys-devel/automake/automake-1.4_p6-r2.ebuild
index cf96aaeb4b1a..f5bd9b6279b0 100644
--- a/sys-devel/automake/automake-1.4_p6-r1.ebuild
+++ b/sys-devel/automake/automake-1.4_p6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.4_p6-r1.ebuild,v 1.13 2014/11/15 06:21:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.4_p6-r2.ebuild,v 1.1 2014/11/15 06:42:33 vapier Exp $
EAPI="4"
@@ -33,6 +33,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.4-ansi2knr-stdlib.patch
epatch "${FILESDIR}"/${PN}-1.4-CVE-2009-4029.patch #295357
epatch "${FILESDIR}"/${PN}-1.4-perl-5.11.patch
+ epatch "${FILESDIR}"/${PN}-1.4-perl-dyn-call.patch
sed -i 's:error\.test::' tests/Makefile.in #79529
}
diff --git a/sys-devel/automake/files/automake-1.4-perl-dyn-call.patch b/sys-devel/automake/files/automake-1.4-perl-dyn-call.patch
new file mode 100644
index 000000000000..9a140aa50510
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.4-perl-dyn-call.patch
@@ -0,0 +1,23 @@
+at some point, a perl update broke this syntax. use a newer style that works
+with at least perl-5.16.
+
+--- a/automake.in
++++ b/automake.in
+@@ -983,7 +983,7 @@ sub finish_languages
+
+ # Compute the function name of the finisher and then call it.
+ $name = 'lang_' . $lang . '_finish';
+- do $name ();
++ &$name ();
+ }
+
+ # If the project is entirely C++ or entirely Fortran 77, don't
+@@ -1144,7 +1144,7 @@ sub handle_single_transform_list
+ # Found the language, so see what it says.
+ local ($subr) = 'lang_' . $lang . '_rewrite';
+ # Note: computed subr call.
+- local ($r) = do $subr ($base, $extension);
++ local ($r) = &$subr ($base, $extension);
+ # Skip this entry if we were asked not to process it.
+ next if ! $r;
+