summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-03-03 14:34:49 +0000
committerSimon Stelling <blubb@gentoo.org>2006-03-03 14:34:49 +0000
commitfa55e19c4b2af0f5db4a7619a4a318163543f179 (patch)
tree3e5b90135ec06899ac785cf81f2a70a1620d37d0 /sys-devel
parentadd placeholder for old eclass, #124789 (diff)
downloadgentoo-2-fa55e19c4b2af0f5db4a7619a4a318163543f179.tar.gz
gentoo-2-fa55e19c4b2af0f5db4a7619a4a318163543f179.tar.bz2
gentoo-2-fa55e19c4b2af0f5db4a7619a4a318163543f179.zip
remove code that never gets executed, as well as the patch applied by this code (use multilib && use amd64 == nono)
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/gcc331_use_multilib.amd64.patch11
-rw-r--r--sys-devel/gcc/gcc-3.3.2-r7.ebuild61
-rw-r--r--sys-devel/gcc/gcc-3.4.1-r3.ebuild53
4 files changed, 21 insertions, 112 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index eb1ca3c284cc..ffce6fdb94e2 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.503 2006/03/03 02:24:32 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.504 2006/03/03 14:34:49 blubb Exp $
+
+ 03 Mar 2006; Simon Stelling <blubb@gentoo.org>
+ -files/gcc331_use_multilib.amd64.patch, gcc-3.3.2-r7.ebuild,
+ gcc-3.4.1-r3.ebuild:
+ remove code that never gets executed, as well as the patch applied by this
+ code (use multilib && use amd64 == nono)
*gcc-4.1.0 (03 Mar 2006)
diff --git a/sys-devel/gcc/files/gcc331_use_multilib.amd64.patch b/sys-devel/gcc/files/gcc331_use_multilib.amd64.patch
deleted file mode 100644
index 4ba45d19bc5f..000000000000
--- a/sys-devel/gcc/files/gcc331_use_multilib.amd64.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- gcc/config/i386/t-linux64.orig 2003-06-28 00:19:59.000000000 +0000
-+++ gcc/config/i386/t-linux64 2003-06-28 00:20:07.000000000 +0000
-@@ -6,7 +6,7 @@
-
- MULTILIB_OPTIONS = m64/m32
- MULTILIB_DIRNAMES = 64 32
--MULTILIB_OSDIRNAMES = ../lib64 ../lib
-+MULTILIB_OSDIRNAMES = ../lib64 ../lib32
-
- LIBGCC = stmp-multilib
- INSTALL_LIBGCC = install-multilib
diff --git a/sys-devel/gcc/gcc-3.3.2-r7.ebuild b/sys-devel/gcc/gcc-3.3.2-r7.ebuild
index 93142391f1ea..353d5c7ffcf1 100644
--- a/sys-devel/gcc/gcc-3.3.2-r7.ebuild
+++ b/sys-devel/gcc/gcc-3.3.2-r7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r7.ebuild,v 1.24 2005/10/07 02:01:56 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r7.ebuild,v 1.25 2006/03/03 14:34:49 blubb Exp $
IUSE="static nls bootstrap java build X multilib gcj emul-linux-x86"
@@ -122,7 +122,6 @@ DEPEND="virtual/libc
>=sys-devel/binutils-2.14.90.0.6-r1
>=sys-devel/bison-1.875
|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.1 )
- amd64? ( multilib? ( >=app-emulation/emul-linux-x86-baselibs-1.0 ) )
!build? ( >=sys-libs/ncurses-5.2-r2
nls? ( sys-devel/gettext ) )"
@@ -286,13 +285,6 @@ src_unpack() {
# mv -f ${WORKDIR}/patch/{40,41}* ${WORKDIR}/patch/exclude/
mv -f ${WORKDIR}/patch/41* ${WORKDIR}/patch/exclude/
- if use multilib && [ "${ARCH}" = "amd64" ]
- then
- mv -f ${WORKDIR}/patch/06* ${WORKDIR}/patch/exclude/
- bzip2 -c ${FILESDIR}/gcc331_use_multilib.amd64.patch > \
- ${WORKDIR}/patch/06_amd64_gcc331-use-multilib.patch.bz2
- fi
-
epatch ${WORKDIR}/patch
fi
@@ -370,18 +362,12 @@ src_compile() {
myconf="${myconf} --enable-interpreter --enable-java-awt=xlib --with-x"
fi
- # Multilib not yet supported
- if use multilib && [ "${ARCH}" = "amd64" ]
+ if [ "${ARCH}" = "amd64" ]
then
- einfo "WARNING: Multilib support enabled. This is still experimental."
- myconf="${myconf} --enable-multilib"
- else
- if [ "${ARCH}" = "amd64" ]
- then
- einfo "WARNING: Multilib not enabled. You will not be able to build 32bit binaries."
- fi
- myconf="${myconf} --disable-multilib"
+ einfo "WARNING: Multilib not enabled. You will not be able to build 32bit binaries."
fi
+ myconf="${myconf} --disable-multilib"
+
# Fix linking problem with c++ apps which where linkedi
# agains a 3.2.2 libgcc
@@ -497,14 +483,7 @@ src_install() {
dodir /etc/env.d/gcc
echo "PATH=\"${BINPATH}\"" > ${D}/etc/env.d/gcc/${CCHOST}-${GCC_RELEASE_VER}
echo "ROOTPATH=\"${BINPATH}\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${GCC_RELEASE_VER}
- if use multilib && [ "${ARCH}" = "amd64" ]
- then
- # amd64 is a bit unique because of multilib. Add some other paths
- echo "LDPATH=\"${LIBPATH}:${LIBPATH}/32:${LIBPATH}/../lib64:${LIBPATH}/../lib32\"" >> \
- ${D}/etc/env.d/gcc/${CCHOST}-${GCC_RELEASE_VER}
- else
- echo "LDPATH=\"${LIBPATH}\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${GCC_RELEASE_VER}
- fi
+ echo "LDPATH=\"${LIBPATH}\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${GCC_RELEASE_VER}
echo "MANPATH=\"${DATAPATH}/man\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${GCC_RELEASE_VER}
echo "INFOPATH=\"${DATAPATH}/info\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${GCC_RELEASE_VER}
echo "STDCXX_INCDIR=\"${STDCXX_INCDIR##*/}\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${GCC_RELEASE_VER}
@@ -655,16 +634,6 @@ src_install() {
doins ${FILESDIR}/awk/fixlafiles.awk
exeinto /sbin
doexe ${FILESDIR}/fix_libtool_files.sh
-
- if use multilib && [ "${ARCH}" = "amd64" ]
- then
- # If using multilib, GCC has a bug, where it doesn't know where to find
- # -lgcc_s when linking while compiling with g++ . ${LIBPATH} is in
- # it's path though, so ln the 64bit and 32bit versions of -lgcc_s
- # to that directory.
- ln -sf ${LIBPATH}/../lib64/libgcc_s.so ${D}/${LIBPATH}/libgcc_s.so
- ln -sf ${LIBPATH}/../lib32/libgcc_s_32.so ${D}/${LIBPATH}/libgcc_s_32.so
- fi
}
pkg_preinst() {
@@ -676,25 +645,13 @@ pkg_preinst() {
# Make again sure that the linker "should" be able to locate
# libstdc++.so ...
- if use multilib && [ "${ARCH}" = "amd64" ]
- then
- # Can't always find libgcc_s.so.1, make it find it
- export LD_LIBRARY_PATH="${LIBPATH}:${LIBPATH}/../lib64:${LIBPATH}/../lib32:${LD_LIBRARY_PATH}"
- else
- export LD_LIBRARY_PATH="${LIBPATH}:${LD_LIBRARY_PATH}"
- fi
+ export LD_LIBRARY_PATH="${LIBPATH}:${LD_LIBRARY_PATH}"
${ROOT}/sbin/ldconfig
}
pkg_postinst() {
- if use multilib && [ "${ARCH}" = "amd64" ]
- then
- # Can't always find libgcc_s.so.1, make it find it
- export LD_LIBRARY_PATH="${LIBPATH}:${LIBPATH}/../lib64:${LIBPATH}/../lib32:${LD_LIBRARY_PATH}"
- else
- export LD_LIBRARY_PATH="${LIBPATH}:${LD_LIBRARY_PATH}"
- fi
+ export LD_LIBRARY_PATH="${LIBPATH}:${LD_LIBRARY_PATH}"
if [ "${ROOT}" = "/" -a "${CHOST}" = "${CCHOST}" ]
then
gcc-config --use-portage-chost ${CCHOST}-${GCC_RELEASE_VER}
diff --git a/sys-devel/gcc/gcc-3.4.1-r3.ebuild b/sys-devel/gcc/gcc-3.4.1-r3.ebuild
index 048018739653..50d3e015554f 100644
--- a/sys-devel/gcc/gcc-3.4.1-r3.ebuild
+++ b/sys-devel/gcc/gcc-3.4.1-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r3.ebuild,v 1.20 2005/10/07 02:01:56 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r3.ebuild,v 1.21 2006/03/03 14:34:49 blubb Exp $
IUSE="static nls bootstrap build multilib gcj gtk fortran objc hardened n32 n64 emul-linux-x86"
@@ -27,7 +27,6 @@ DEPEND="virtual/libc
amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )
>=sys-devel/bison-1.875
|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.1 )
- amd64? ( multilib? ( >=app-emulation/emul-linux-x86-baselibs-1.0 ) )
!build? (
gcj? (
gtk? ( >=x11-libs/gtk+-2.2 )
@@ -362,13 +361,6 @@ do_patch_tarball() {
cp ${S}/gcc/config/sh/t-sh64 ${S}/gcc/config/sh/t-sh64-uclibc || \
die "can't copy sh/t-sh64"
- if use multilib && [ "${ARCH}" = "amd64" ]
- then
- mv -f ${WORKDIR}/patch/06* ${WORKDIR}/patch/exclude/
- bzip2 -c ${FILESDIR}/gcc331_use_multilib.amd64.patch > \
- ${WORKDIR}/patch/06_amd64_gcc331-use-multilib.patch.bz2
- fi
-
epatch ${WORKDIR}/patch
# the uclibc patches need autoconf to be run
@@ -376,10 +368,6 @@ do_patch_tarball() {
use build || ( cd ${S}/libstdc++-v3; autoconf; cd ${S} )
#use build && use elibc_uclibc && ewarn "uclibc in build stage is not supported yet" && exit 1
- elif use multilib && [ "${ARCH}" = "amd64" ]
- then
- # We need this even if there isnt a patchset
- epatch ${FILESDIR}/gcc331_use_multilib.amd64.patch
fi
}
@@ -511,15 +499,6 @@ src_unpack() {
fi
fi
- if use amd64 && use multilib ; then
- # this should hack around the GCC_NO_EXECUTABLES bug
- epatch ${FILESDIR}/3.4.1/gcc-3.4.1-glibc-is-native.patch
- cd ${S}/libstdc++-v3
- einfo "running autoreconf..."
- autoreconf
- cd ${S}
- fi
-
# Misdesign in libstdc++ (Redhat)
cp -a ${S}/libstdc++-v3/config/cpu/i{4,3}86/atomicity.h
@@ -577,10 +556,6 @@ src_compile() {
einfo "Multilib support enabled. This is still experimental."
myconf="${myconf} --enable-multilib"
else
- if [ "${ARCH}" = "amd64" ]
- then
- einfo "WARNING: Multilib not enabled. You will not be able to build 32bit binaries."
- fi
myconf="${myconf} --disable-multilib"
fi
@@ -741,13 +716,7 @@ src_install() {
# The LDPATH stuff is kinda iffy now that we need to provide compatibility
# with older versions of GCC for binary apps.
- if use multilib && [ "${ARCH}" = "amd64" ]
- then
- # amd64 is a bit unique because of multilib. Add some other paths
- LDPATH="${LIBPATH}:${LIBPATH}/32:${LIBPATH}/../lib64:${LIBPATH}/../lib32"
- else
- LDPATH="${LIBPATH}"
- fi
+ LDPATH="${LIBPATH}"
if [ "${BULIB}" != "" ]
then
LDPATH="${LDPATH}:${LOC}/lib/gcc-lib/${CCHOST}/${BULIB}"
@@ -939,25 +908,13 @@ pkg_preinst() {
# Make again sure that the linker "should" be able to locate
# libstdc++.so ...
- if use multilib && [ "${ARCH}" = "amd64" ]
- then
- # Can't always find libgcc_s.so.1, make it find it
- export LD_LIBRARY_PATH="${LIBPATH}:${LIBPATH}/../lib64:${LIBPATH}/../lib32:${LD_LIBRARY_PATH}"
- else
- export LD_LIBRARY_PATH="${LIBPATH}:${LD_LIBRARY_PATH}"
- fi
+ export LD_LIBRARY_PATH="${LIBPATH}:${LD_LIBRARY_PATH}"
${ROOT}/sbin/ldconfig
}
pkg_postinst() {
- if use multilib && [ "${ARCH}" = "amd64" ]
- then
- # Can't always find libgcc_s.so.1, make it find it
- export LD_LIBRARY_PATH="${LIBPATH}:${LIBPATH}/../lib64:${LIBPATH}/../lib32:${LD_LIBRARY_PATH}"
- else
- export LD_LIBRARY_PATH="${LIBPATH}:${LD_LIBRARY_PATH}"
- fi
+ export LD_LIBRARY_PATH="${LIBPATH}:${LD_LIBRARY_PATH}"
if [ "${ROOT}" = "/" -a "${CHOST}" = "${CCHOST}" ]
then
gcc-config --use-portage-chost ${CCHOST}-${GCC_RELEASE_VER}