summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-05-29 09:24:43 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-05-29 09:24:43 +0000
commitfb747495d63d14792fa9a34cbb364b7076697a7a (patch)
treeb2e260b6320656295c44aaea0db7bda8f223fae1 /sys-devel
parentremove old (diff)
downloadgentoo-2-fb747495d63d14792fa9a34cbb364b7076697a7a.tar.gz
gentoo-2-fb747495d63d14792fa9a34cbb364b7076697a7a.tar.bz2
gentoo-2-fb747495d63d14792fa9a34cbb364b7076697a7a.zip
Revert accidental commit on live ebuild, should fix #550608 and #550682
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 00F7AB331B0F097F)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog5
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild16
2 files changed, 15 insertions, 6 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 2eb0ea9c89e9..b0cadcc1879e 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.240 2015/05/27 11:58:56 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.241 2015/05/29 09:24:43 voyageur Exp $
+
+ 29 May 2015; Bernard Cafarelli <voyageur@gentoo.org> llvm-9999.ebuild:
+ Revert accidental commit on live ebuild, should fix #550608 and #550682
*llvm-3.6.1 (27 May 2015)
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index f74b1aad8dee..ffbe8e876010 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.106 2015/05/27 11:58:56 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.107 2015/05/29 09:24:43 voyageur Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 pypy )
-inherit eutils cmake-utils flag-o-matic git-r3 multibuild multilib \
+inherit eutils flag-o-matic git-r3 multibuild multilib \
multilib-minimal python-r1 toolchain-funcs pax-utils check-reqs
DESCRIPTION="Low Level Virtual Machine"
@@ -19,7 +19,8 @@ LICENSE="UoI-NCSA"
SLOT="0/${PV}"
KEYWORDS=""
IUSE="clang debug doc gold libedit +libffi multitarget ncurses ocaml python
- +static-analyzer test xml video_cards_radeon kernel_Darwin"
+ +static-analyzer test xml video_cards_radeon
+ kernel_Darwin"
COMMON_DEPEND="
sys-libs/zlib:0=
@@ -43,6 +44,10 @@ DEPEND="${COMMON_DEPEND}
>=sys-devel/make-3.81
>=sys-devel/flex-2.5.4
>=sys-devel/bison-1.875d
+ || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1
+ ( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
+ )
+ || ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )
clang? ( xml? ( virtual/pkgconfig ) )
libffi? ( virtual/pkgconfig )
!!<dev-python/configparser-3.3.0.2
@@ -233,8 +238,7 @@ multilib_src_configure() {
tc-export CC CXX
ECONF_SOURCE=${S} \
- cmake-utils_src_configure
- #econf "${conf_flags[@]}"
+ econf "${conf_flags[@]}"
}
set_makeargs() {
@@ -466,6 +470,7 @@ multilib_src_install_all() {
insinto /usr/share/vim/vimfiles/${dir}
doins ${dir}/*.vim
done
+ popd >/dev/null || die
if use clang; then
pushd tools/clang >/dev/null || die
@@ -506,5 +511,6 @@ multilib_src_install_all() {
python_doscript "${S}"/projects/compiler-rt/lib/asan/scripts/asan_symbolize.py
}
python_foreach_impl python_inst
+ popd >/dev/null || die
fi
}