summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-01-25 04:48:53 +0000
committerMark Wright <gienah@gentoo.org>2014-01-25 04:48:53 +0000
commit416b4ed2d4284acc0073ecb4d4bb87903bf400ee (patch)
tree7fee3e7c772cdceed2bdbbe830c6f7e6ba8726b9 /sys-firmware/iwl7260-ucode
parentSaves external GL folder from removal (diff)
downloadgentoo-2-416b4ed2d4284acc0073ecb4d4bb87903bf400ee.tar.gz
gentoo-2-416b4ed2d4284acc0073ecb4d4bb87903bf400ee.tar.bz2
gentoo-2-416b4ed2d4284acc0073ecb4d4bb87903bf400ee.zip
Add bluetooth use flag to pull in sys-firmware/iwl3160-7260-bt-ucode for the Intel Wireless Bluetooth 3160 and Intel Wireless Bluetooth 7260 devices. Part of bug #489714, thanks to Thomas Kear for reporting, testing and initial ebuilds.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sys-firmware/iwl7260-ucode')
-rw-r--r--sys-firmware/iwl7260-ucode/ChangeLog13
-rw-r--r--sys-firmware/iwl7260-ucode/iwl7260-ucode-22.1.7.0-r1.ebuild40
-rw-r--r--sys-firmware/iwl7260-ucode/iwl7260-ucode-22.15.8.0-r1.ebuild41
-rw-r--r--sys-firmware/iwl7260-ucode/metadata.xml3
4 files changed, 96 insertions, 1 deletions
diff --git a/sys-firmware/iwl7260-ucode/ChangeLog b/sys-firmware/iwl7260-ucode/ChangeLog
index 0e69ae02164c..a6742b9c6b03 100644
--- a/sys-firmware/iwl7260-ucode/ChangeLog
+++ b/sys-firmware/iwl7260-ucode/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-firmware/iwl7260-ucode
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl7260-ucode/ChangeLog,v 1.3 2014/01/23 22:43:40 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl7260-ucode/ChangeLog,v 1.4 2014/01/25 04:48:53 gienah Exp $
+
+*iwl7260-ucode-22.15.8.0-r1 (25 Jan 2014)
+*iwl7260-ucode-22.1.7.0-r1 (25 Jan 2014)
+
+ 25 Jan 2014; Mark Wright <gienah@gentoo.org>
+ +iwl7260-ucode-22.1.7.0-r1.ebuild, +iwl7260-ucode-22.15.8.0-r1.ebuild,
+ metadata.xml:
+ Add bluetooth use flag to pull in sys-firmware/iwl3160-7260-bt-ucode for the
+ Intel Wireless Bluetooth 3160 and Intel Wireless Bluetooth 7260 devices. Part
+ of bug #489714, thanks to Thomas Kear for reporting, testing and initial
+ ebuilds.
23 Jan 2014; Mark Wright <gienah@gentoo.org> iwl7260-ucode-22.15.8.0.ebuild:
Thanks to Thomas Kear for testing and this fix (for my copy-paste bug): sys-
diff --git a/sys-firmware/iwl7260-ucode/iwl7260-ucode-22.1.7.0-r1.ebuild b/sys-firmware/iwl7260-ucode/iwl7260-ucode-22.1.7.0-r1.ebuild
new file mode 100644
index 000000000000..e5db5a2f202d
--- /dev/null
+++ b/sys-firmware/iwl7260-ucode/iwl7260-ucode-22.1.7.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl7260-ucode/iwl7260-ucode-22.1.7.0-r1.ebuild,v 1.1 2014/01/25 04:48:53 gienah Exp $
+
+EAPI=5
+inherit linux-info
+
+DEV_N="${PN:3:4}"
+MY_PN="iwlwifi-${DEV_N}-ucode"
+
+DESCRIPTION="Firmware for Intel (R) Dual Band Wireless-AC ${DEV_N}"
+HOMEPAGE="http://wireless.kernel.org/en/users/Drivers/iwlwifi"
+SRC_URI="http://wireless.kernel.org/en/users/Drivers/iwlwifi?action=AttachFile&do=get&target=${MY_PN}-${PV}.tgz -> ${P}.tgz"
+
+LICENSE="ipw3945"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+DEPEND=""
+RDEPEND="bluetooth? ( sys-firmware/iwl3160-7260-bt-ucode )
+ !sys-kernel/linux-firmware[-savedconfig]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+CONFIG_CHECK="IWLMVM"
+ERROR_IWLMVM="CONFIG_IWLMVM is required to be enabled in /usr/src/linux/.config for the kernel to be able to load the ${DEV_N} firmware"
+
+pkg_pretend() {
+ if kernel_is lt 3 10 0; then
+ ewarn "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}."
+ ewarn "This microcode image requires a kernel >= 3.10.0."
+ fi
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins "${S}/iwlwifi-${DEV_N}-7.ucode"
+ dodoc README*
+}
diff --git a/sys-firmware/iwl7260-ucode/iwl7260-ucode-22.15.8.0-r1.ebuild b/sys-firmware/iwl7260-ucode/iwl7260-ucode-22.15.8.0-r1.ebuild
new file mode 100644
index 000000000000..73ad2a5f3d79
--- /dev/null
+++ b/sys-firmware/iwl7260-ucode/iwl7260-ucode-22.15.8.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl7260-ucode/iwl7260-ucode-22.15.8.0-r1.ebuild,v 1.1 2014/01/25 04:48:53 gienah Exp $
+
+EAPI=5
+inherit linux-info
+
+DEV_N="${PN:3:4}"
+MY_PN="iwlwifi-${DEV_N}-ucode"
+
+DESCRIPTION="Firmware for Intel (R) Dual Band Wireless-AC ${DEV_N}"
+HOMEPAGE="http://wireless.kernel.org/en/users/Drivers/iwlwifi"
+SRC_URI="http://wireless.kernel.org/en/users/Drivers/iwlwifi?action=AttachFile&do=get&target=${MY_PN}-${PV}.tgz -> ${P}.tgz"
+
+LICENSE="ipw3945"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+DEPEND=""
+RDEPEND="bluetooth? ( sys-firmware/iwl3160-7260-bt-ucode )
+ !sys-kernel/linux-firmware[-savedconfig]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+CONFIG_CHECK="IWLMVM"
+ERROR_IWLMVM="CONFIG_IWLMVM is required to be enabled in /usr/src/linux/.config for the kernel to be able to load the ${DEV_N} firmware"
+
+pkg_pretend() {
+ if kernel_is lt 3 13 0; then
+ ewarn "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}."
+ ewarn "This microcode image requires a kernel >= 3.13.0."
+ ewarn "For kernel versions < 3.10.13, you may install older SLOTS"
+ fi
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins "${S}/iwlwifi-${DEV_N}-8.ucode"
+ dodoc README*
+}
diff --git a/sys-firmware/iwl7260-ucode/metadata.xml b/sys-firmware/iwl7260-ucode/metadata.xml
index 37e19dad162a..d4caf1eba71e 100644
--- a/sys-firmware/iwl7260-ucode/metadata.xml
+++ b/sys-firmware/iwl7260-ucode/metadata.xml
@@ -3,5 +3,8 @@
<pkgmetadata>
<maintainer>
<email>gienah@gentoo.org</email>
+ <description>Feel free to bump and add yourself to the maintainer list,
+ please bump sys-firmware/iwl3160-ucode and maybe
+ sys-firmware/iwl3160-7260-bt-ucode as well.</description>
</maintainer>
</pkgmetadata>