summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-03-16 18:49:47 +0000
committerMike Frysinger <vapier@gentoo.org>2015-03-16 18:49:47 +0000
commitb5b19ed6bc3e9f0567a6c719112a644d20a6d2e3 (patch)
treea9eb6921142b638e6c4cbb8023a85bf77585b795 /sys-firmware
parentHandle renamed opengl configure flag #543386 by Chase Rayfield. (diff)
downloadgentoo-2-b5b19ed6bc3e9f0567a6c719112a644d20a6d2e3.tar.gz
gentoo-2-b5b19ed6bc3e9f0567a6c719112a644d20a6d2e3.tar.bz2
gentoo-2-b5b19ed6bc3e9f0567a6c719112a644d20a6d2e3.zip
Fix building when the source is not a git repo (but a higher dir is) #482804 by Florian Schmaus.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/ipxe/ChangeLog9
-rw-r--r--sys-firmware/ipxe/files/ipxe-1.0.0_p20130925-git-version.patch38
-rw-r--r--sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild8
3 files changed, 50 insertions, 5 deletions
diff --git a/sys-firmware/ipxe/ChangeLog b/sys-firmware/ipxe/ChangeLog
index 3dc8dbd2247b..3771258f60f9 100644
--- a/sys-firmware/ipxe/ChangeLog
+++ b/sys-firmware/ipxe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-firmware/ipxe
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ChangeLog,v 1.17 2014/10/20 07:02:24 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ChangeLog,v 1.18 2015/03/16 18:49:47 vapier Exp $
+
+ 16 Mar 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/ipxe-1.0.0_p20130925-git-version.patch, ipxe-1.0.0_p20130925.ebuild:
+ Fix building when the source is not a git repo (but a higher dir is) #482804
+ by Florian Schmaus.
20 Oct 2014; Agostino Sarubbo <ago@gentoo.org> ipxe-1.0.0_p20130925.ebuild:
Stable for x86, wrt bug #523788
diff --git a/sys-firmware/ipxe/files/ipxe-1.0.0_p20130925-git-version.patch b/sys-firmware/ipxe/files/ipxe-1.0.0_p20130925-git-version.patch
new file mode 100644
index 000000000000..a981abdd892e
--- /dev/null
+++ b/sys-firmware/ipxe/files/ipxe-1.0.0_p20130925-git-version.patch
@@ -0,0 +1,38 @@
+From 6153c09c41034250408f3596555fcaae715da46c Mon Sep 17 00:00:00 2001
+From: Florian Schmaus <flo@geekplace.eu>
+Date: Mon, 28 Jul 2014 16:47:48 +0100
+Subject: [PATCH] [build] Set GITVERSION only if there is a git repository
+
+The $(BIN)/version.%.o target will fail if iPXE is built within a
+non-git repository, e.g. when the user downloaded and extracted an
+archive containing iPXE sources, *and* if any parent directory of the
+iPXE sources is a git repository (or even contains a directory named
+".git"). This is because git will by default ascend the directory
+tree and look for ".git".
+
+The problem typically manifests on source based distributions, see for
+example https://bugs.gentoo.org/show_bug.cgi?id=482804
+
+Modified-by: Michael Brown <mcb30@ipxe.org>
+Signed-off-by: Michael Brown <mcb30@ipxe.org>
+---
+ src/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 22a7335..c6760ee 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -190,8 +190,8 @@ VERSION_PATCH = 0
+ EXTRAVERSION = +
+ MM_VERSION = $(VERSION_MAJOR).$(VERSION_MINOR)
+ VERSION = $(MM_VERSION).$(VERSION_PATCH)$(EXTRAVERSION)
++ifneq ($(wildcard ../.git),)
+ GITVERSION := $(shell git describe --always --abbrev=1 --match "" 2>/dev/null)
+-ifneq ($(GITVERSION),)
+ VERSION += ($(GITVERSION))
+ endif
+ version :
+--
+2.3.2
+
diff --git a/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild b/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild
index a819e401e0a4..8522f068d56b 100644
--- a/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild
+++ b/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild,v 1.3 2014/10/20 07:02:24 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild,v 1.4 2015/03/16 18:49:47 vapier Exp $
EAPI=5
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
GIT_REV="cba22d36b77da53890bd65fdadd0e63925687af0"
GIT_SHORT="cba22d3"
@@ -37,6 +37,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-git-version.patch #482804
+
cat <<-EOF > "${S}"/config/local/general.h
#undef BANNER_TIMEOUT
#define BANNER_TIMEOUT 0