summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-26 04:03:41 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-26 04:03:41 +0000
commitf1d56e5a29625486c8835c90c3509f0856b7a130 (patch)
tree54666f921dac8d17f2f75e5c419f79e3df7755c4 /sys-firmware
parentadded ~x86-macos (diff)
downloadgentoo-2-f1d56e5a29625486c8835c90c3509f0856b7a130.tar.gz
gentoo-2-f1d56e5a29625486c8835c90c3509f0856b7a130.tar.bz2
gentoo-2-f1d56e5a29625486c8835c90c3509f0856b7a130.zip
Add on the new place.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/amd-ucode/ChangeLog25
-rw-r--r--sys-firmware/amd-ucode/amd-ucode-2012.01.17.ebuild76
-rw-r--r--sys-firmware/amd-ucode/metadata.xml8
3 files changed, 109 insertions, 0 deletions
diff --git a/sys-firmware/amd-ucode/ChangeLog b/sys-firmware/amd-ucode/ChangeLog
new file mode 100644
index 000000000000..0c1ea7d06232
--- /dev/null
+++ b/sys-firmware/amd-ucode/ChangeLog
@@ -0,0 +1,25 @@
+# ChangeLog for sys-firmware/amd-ucode
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/amd-ucode/ChangeLog,v 1.1 2012/07/26 04:03:41 flameeyes Exp $
+
+*amd-ucode-2012.01.17 (17 Jan 2012)
+
+ 17 Jan 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +amd-ucode-2012.01.17.ebuild:
+ Version bump.
+
+ 20 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ amd-ucode-2011.01.11.ebuild:
+ Improve postinst message showing information on how to use the microcode for
+ built-in kernels.
+
+ 17 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
+ Add amd64 as co-maintainer for the package.
+
+*amd-ucode-2011.01.11 (16 Jan 2011)
+
+ 16 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +amd-ucode-2011.01.11.ebuild, +metadata.xml:
+ Add an ebuild to install AMD's CPUs microcode which can be loaded directly by
+ the kernel.
+
diff --git a/sys-firmware/amd-ucode/amd-ucode-2012.01.17.ebuild b/sys-firmware/amd-ucode/amd-ucode-2012.01.17.ebuild
new file mode 100644
index 000000000000..b34da03497d0
--- /dev/null
+++ b/sys-firmware/amd-ucode/amd-ucode-2012.01.17.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/amd-ucode/amd-ucode-2012.01.17.ebuild,v 1.1 2012/07/26 04:03:41 flameeyes Exp $
+
+EAPI=4
+
+inherit versionator linux-info
+
+MY_P="${PN}-$(replace_all_version_separators -)"
+
+DESCRIPTION="AMD Family 10h, 11h and 14h microcode patch data"
+HOMEPAGE="http://www.amd64.org/support/microcode.html"
+SRC_URI="http://www.amd64.org/pub/microcode/${MY_P}.tar"
+
+LICENSE="amd-ucode"
+SLOT="0"
+IUSE=""
+
+# only meaningful for x86 and x86-64
+KEYWORDS="-* ~amd64 ~x86"
+
+# The license does not allow us to mirror the content.
+RESTRICT="mirror"
+
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="~MICROCODE_AMD"
+ERROR_MICROCODE_AMD="Your kernel needs to support AMD microcode loading. You're suggested to build it as a module as it doesn't require a reboot to reload the microcode, that way."
+
+src_install() {
+ insinto /lib/firmware/amd-ucode
+ doins microcode_amd.bin microcode_amd_fam15h.bin
+
+ # INSTALL file also has instructions to load it, so install it as
+ # part of the documentation.
+ dodoc README INSTALL
+}
+
+pkg_postinst() {
+ local show_modules_info=yes
+ local show_builtin_info=yes
+
+ if linux_config_exists; then
+ if linux_chkconfig_builtin MICROCODE; then
+ show_modules_info=no
+ elif linux_chkconfig_module MICROCODE; then
+ show_builtin_info=no
+ fi
+ fi
+
+ elog "You have installed the microcode for AMD CPUs. The kernel will load"
+ elog "it the next time the microcode driver will be executed."
+ elog ""
+
+ if test $show_modules_info = yes; then
+ elog "If you built the microcode driver as a module, you can issue the"
+ elog "following command to force a reload:"
+ elog ""
+ elog " modprobe -r microcode && modprobe microcode"
+ elog ""
+ fi
+
+ if test $show_builtin_info = yes; then
+ elog "If you built the microcode driver in the kernel, it won't load"
+ elog "the file as is. To update the microcode you'll have to set the"
+ elog "following configuration in the kernel:"
+ elog ""
+ elog " CONFIG_EXTRA_FIRMWARE=\"amd-ucode/microcode_amd.bin amd-ucode/microcode_amd_fam15h.bin\""
+ elog " CONFIG_EXTRA_FIRMWARE_DIR=/lib/firmware"
+ elog ""
+ elog "Please note that this will build the firmware within the kernel"
+ elog "image, so you'll have to rebuild the kernel after an upgrade"
+ elog "of the ${CATEGORY}/${PN} package."
+ elog ""
+ fi
+}
diff --git a/sys-firmware/amd-ucode/metadata.xml b/sys-firmware/amd-ucode/metadata.xml
new file mode 100644
index 000000000000..b806bb6d0d9a
--- /dev/null
+++ b/sys-firmware/amd-ucode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>amd64</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>