summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-05-22 11:14:47 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-05-22 11:14:47 +0000
commit3b80d5625ff5e638806b9c4e752b5548d2d0fb9c (patch)
tree9d8aa5d9ebd78faaad0bda2b16e0e11b295169fa /sys-freebsd/freebsd-contrib
parentbump to 7.2 (diff)
downloadgentoo-2-3b80d5625ff5e638806b9c4e752b5548d2d0fb9c.tar.gz
gentoo-2-3b80d5625ff5e638806b9c4e752b5548d2d0fb9c.tar.bz2
gentoo-2-3b80d5625ff5e638806b9c4e752b5548d2d0fb9c.zip
bump to 7.2
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd/freebsd-contrib')
-rw-r--r--sys-freebsd/freebsd-contrib/ChangeLog8
-rw-r--r--sys-freebsd/freebsd-contrib/freebsd-contrib-7.2.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/sys-freebsd/freebsd-contrib/ChangeLog b/sys-freebsd/freebsd-contrib/ChangeLog
index a9bd7c532ed2..a3d6802e2a5e 100644
--- a/sys-freebsd/freebsd-contrib/ChangeLog
+++ b/sys-freebsd/freebsd-contrib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-contrib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.24 2009/01/22 21:01:17 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.25 2009/05/22 11:14:47 aballier Exp $
+
+*freebsd-contrib-7.2 (22 May 2009)
+
+ 22 May 2009; Alexis Ballier <aballier@gentoo.org>
+ +freebsd-contrib-7.2.ebuild:
+ bump to 7.2
*freebsd-contrib-7.1 (22 Jan 2009)
diff --git a/sys-freebsd/freebsd-contrib/freebsd-contrib-7.2.ebuild b/sys-freebsd/freebsd-contrib/freebsd-contrib-7.2.ebuild
new file mode 100644
index 000000000000..3446fd7674f4
--- /dev/null
+++ b/sys-freebsd/freebsd-contrib/freebsd-contrib-7.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/freebsd-contrib-7.2.ebuild,v 1.1 2009/05/22 11:14:47 aballier Exp $
+
+inherit bsdmk freebsd flag-o-matic
+
+DESCRIPTION="Contributed sources for FreeBSD."
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+LICENSE="BSD GPL-2 as-is"
+
+IUSE=""
+
+SRC_URI="mirror://gentoo/${GNU}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-sources-${RV}*
+ =sys-freebsd/freebsd-mk-defs-${RV}*"
+
+S="${WORKDIR}/gnu"
+
+src_unpack() {
+ echo ">>> Unpacking needed parts of ${GNU}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${GNU}.tar.bz2" gnu/lib/libdialog gnu/usr.bin/sort gnu/usr.bin/patch
+ echo ">>> Unpacking needed parts of ${CONTRIB}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${CONTRIB}.tar.bz2" contrib/gnu-sort
+
+ freebsd_do_patches
+ freebsd_rename_libraries
+}
+
+src_compile() {
+ cd "${S}/lib/libdialog"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/sort"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/patch"
+ freebsd_src_compile
+}
+
+src_install() {
+ use profile || mymakeopts="${mymakeopts} NO_PROFILE= "
+ mymakeopts="${mymakeopts} NO_MANCOMPRESS= NO_INFOCOMPRESS= "
+
+ cd "${S}/lib/libdialog"
+ mkinstall || die "libdialog install failed"
+
+ cd "${S}/usr.bin/sort"
+ mkinstall DESTDIR="${D}/bin/" || die "libdialog install failed"
+
+ cd "${S}/usr.bin/patch"
+ mkinstall DESTDIR="${D}/usr/bin/" || die "libdialog install failed"
+}