summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-05-25 12:37:04 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-05-25 12:37:04 +0000
commitc0dffbf4e43202a33cb92491ce7a94530157cb0a (patch)
treeeead8a79866976120b3e8dfccc07f18ef036a99c /sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
parentreplace -isystem path by -Ipath as append-flags seems not to like the former ... (diff)
downloadgentoo-2-c0dffbf4e43202a33cb92491ce7a94530157cb0a.tar.gz
gentoo-2-c0dffbf4e43202a33cb92491ce7a94530157cb0a.tar.bz2
gentoo-2-c0dffbf4e43202a33cb92491ce7a94530157cb0a.zip
fix paths I broke by the addition of MAKEOBJDIRPREFIX
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild')
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
index b41859e9114c..e9b19067ef4e 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild,v 1.29 2012/05/25 12:27:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild,v 1.30 2012/05/25 12:37:04 aballier Exp $
EAPI=2
@@ -212,15 +212,15 @@ bootstrap_csu() {
cd "${WORKDIR}/${csudir}" || die "Missing ${csudir}."
freebsd_src_compile
- append-flags "-B ${WORKDIR}/${csudir}"
- append-ldflags "-B ${WORKDIR}/${csudir}"
+ append-flags "-B ${MAKEOBJDIRPREFIX}/${WORKDIR}/${csudir}"
+ append-ldflags "-B ${MAKEOBJDIRPREFIX}/${WORKDIR}/${csudir}"
}
# Compile libssp_nonshared.a and add it's path to LDFLAGS.
bootstrap_libssp_nonshared() {
cd "${WORKDIR}/gnu/lib/libssp/libssp_nonshared/" || die "missing libssp."
freebsd_src_compile
- append-ldflags "-L${WORKDIR}/gnu/lib/libssp/libssp_nonshared/"
+ append-ldflags "-L${MAKEOBJDIRPREFIX}/${WORKDIR}/gnu/lib/libssp/libssp_nonshared/"
export LDADD="-lssp_nonshared"
}
@@ -329,7 +329,7 @@ src_compile() {
CHOST=${CTARGET} tc-export CC LD CXX RANLIB
mymakeopts="${mymakeopts} NLS="
append-flags "-I/usr/${CTARGET}/usr/include"
- append-ldflags "-L${WORKDIR}/lib/libc"
+ append-ldflags "-L${WORKDIR}/${CHOST}/${WORKDIR}/lib/libc"
fi
if is_crosscompile ; then