summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-02-18 17:09:17 +0000
committerMichał Górny <mgorny@gentoo.org>2015-02-18 17:09:17 +0000
commitbdb17b314b51509c51b1f486601289f3fca23276 (patch)
tree940c494bdd11c5a49e747f856ec25218c813590d /sys-freebsd/freebsd-lib
parentVersion bump. (diff)
downloadgentoo-2-bdb17b314b51509c51b1f486601289f3fca23276.tar.gz
gentoo-2-bdb17b314b51509c51b1f486601289f3fca23276.tar.bz2
gentoo-2-bdb17b314b51509c51b1f486601289f3fca23276.zip
Fix SIGABRT failure when compiled with SSP-enabled gcc, bug #511698, patch by Yuta SATOH
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-freebsd/freebsd-lib')
-rw-r--r--sys-freebsd/freebsd-lib/ChangeLog10
-rw-r--r--sys-freebsd/freebsd-lib/files/freebsd-lib-add-nossp-cflags.patch30
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-9.1-r11.ebuild5
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-9.2.ebuild5
4 files changed, 44 insertions, 6 deletions
diff --git a/sys-freebsd/freebsd-lib/ChangeLog b/sys-freebsd/freebsd-lib/ChangeLog
index cee0a6758191..4e8c78c9e0c0 100644
--- a/sys-freebsd/freebsd-lib/ChangeLog
+++ b/sys-freebsd/freebsd-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-lib
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.206 2014/03/24 17:49:33 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.207 2015/02/18 17:09:17 mgorny Exp $
+
+ 18 Feb 2015; Michał Górny <mgorny@gentoo.org>
+ +files/freebsd-lib-add-nossp-cflags.patch, freebsd-lib-9.1-r11.ebuild,
+ freebsd-lib-9.2.ebuild:
+ Fix SIGABRT failure when compiled with SSP-enabled gcc, bug #511698, patch by
+ Yuta SATOH
24 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> freebsd-lib-8.2-r1.ebuild,
freebsd-lib-9.1-r10.ebuild, freebsd-lib-9.1-r11.ebuild,
diff --git a/sys-freebsd/freebsd-lib/files/freebsd-lib-add-nossp-cflags.patch b/sys-freebsd/freebsd-lib/files/freebsd-lib-add-nossp-cflags.patch
new file mode 100644
index 000000000000..00b39f750ec1
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/freebsd-lib-add-nossp-cflags.patch
@@ -0,0 +1,30 @@
+Please do not disable this patch.
+All commands will be non-executable.
+Abort trap: 6 (core dumped) is displayed...
+
+Details see Gentoo Bug #511698.
+https://bugs.gentoo.org/show_bug.cgi?id=511698
+
+diff --git a/lib/libc/Makefile b/lib/libc/Makefile
+index 1cc23b7..7dd458e 100644
+--- a/lib/libc/Makefile
++++ b/lib/libc/Makefile
+@@ -149,6 +149,6 @@ CWARNFLAGS:= ${.IMPSRC:Ngdtoa_*.c:C/^.+$/${CWARNFLAGS}/:C/^$/-w/}
+ # in the future to circumvent this.
+ SSP_CFLAGS:= ${SSP_CFLAGS:S/^-fstack-protector-all$/-fstack-protector/}
+ # Disable stack protection for SSP symbols.
+-SSP_CFLAGS:= ${.IMPSRC:N*/stack_protector.c:C/^.+$/${SSP_CFLAGS}/}
++SSP_CFLAGS:= ${.IMPSRC:N*/stack_protector.c:C/^.+$/${SSP_CFLAGS}/:C/^$/-fno-stack-protector/}
+ # Generate stack unwinding tables for cancellation points
+ CANCELPOINTS_CFLAGS:= ${.IMPSRC:Mcancelpoints_*:C/^.+$/${CANCELPOINTS_CFLAGS}/:C/^$//}
+diff --git a/lib/csu/Makefile.inc b/lib/csu/Makefile.inc
+index f92d87d..7a3a2f3 100644
+--- a/lib/csu/Makefile.inc
++++ b/lib/csu/Makefile.inc
+@@ -1,5 +1,5 @@
+ # $FreeBSD: release/9.1.0/lib/csu/Makefile.inc 204757 2010-03-05 13:29:05Z uqs $
+
+-SSP_CFLAGS=
++SSP_CFLAGS= -fno-stack-protector
+
+ .include "../Makefile.inc"
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r11.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r11.ebuild
index e5e0b57d468f..4084c3174b2f 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r11.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r11.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r11.ebuild,v 1.3 2014/03/24 17:49:33 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r11.ebuild,v 1.4 2015/02/18 17:09:17 mgorny Exp $
EAPI=5
@@ -96,6 +96,7 @@ PATCHES=(
"${FILESDIR}/${PN}-9.0-cve-2010-2632.patch"
"${FILESDIR}/${PN}-9.0-bluetooth.patch"
"${FILESDIR}/${PN}-9.1-.eh_frame_hdr-fix.patch"
+ "${FILESDIR}/${PN}-add-nossp-cflags.patch"
)
# Here we disable and remove source which we don't need or want
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-9.2.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-9.2.ebuild
index cf1d48903c1e..9887e4c2fc44 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-9.2.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-9.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.2.ebuild,v 1.2 2014/03/24 17:49:33 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.2.ebuild,v 1.3 2015/02/18 17:09:17 mgorny Exp $
EAPI=5
@@ -94,6 +94,7 @@ PATCHES=(
"${FILESDIR}/${PN}-9.0-netware.patch"
"${FILESDIR}/${PN}-9.0-bluetooth.patch"
"${FILESDIR}/${PN}-9.1-.eh_frame_hdr-fix.patch"
+ "${FILESDIR}/${PN}-add-nossp-cflags.patch"
)
# Here we disable and remove source which we don't need or want