summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-10-16 08:54:50 +0000
committerRoy Marples <uberlord@gentoo.org>2007-10-16 08:54:50 +0000
commit4af356b7202f3669b67629a245ddfa80c473e910 (patch)
tree533483bf9fa797039aae260adcddbbf3dca8ac51 /sys-freebsd
parentgcc-4 now defines __sparc64__ for us (diff)
downloadgentoo-2-4af356b7202f3669b67629a245ddfa80c473e910.tar.gz
gentoo-2-4af356b7202f3669b67629a245ddfa80c473e910.tar.bz2
gentoo-2-4af356b7202f3669b67629a245ddfa80c473e910.zip
gcc-4 now defines __sparc64__ for us
(Portage version: 2.1.3.13)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-libexec/ChangeLog6
-rw-r--r--sys-freebsd/freebsd-libexec/files/freebsd-libexec-6.2-sparc64.patch34
-rw-r--r--sys-freebsd/freebsd-libexec/freebsd-libexec-6.2-r2.ebuild5
3 files changed, 7 insertions, 38 deletions
diff --git a/sys-freebsd/freebsd-libexec/ChangeLog b/sys-freebsd/freebsd-libexec/ChangeLog
index d1e937c8b559..c5ef69519df5 100644
--- a/sys-freebsd/freebsd-libexec/ChangeLog
+++ b/sys-freebsd/freebsd-libexec/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-freebsd/freebsd-libexec
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/ChangeLog,v 1.26 2007/09/12 00:15:46 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/ChangeLog,v 1.27 2007/10/16 08:54:50 uberlord Exp $
+
+ 16 Oct 2007; Roy Marples <uberlord@gentoo.org>
+ -files/freebsd-libexec-6.2-sparc64.patch, freebsd-libexec-6.2-r2.ebuild:
+ gcc-4 now defines __sparc64__ for us
*freebsd-libexec-6.2-r2 (12 Sep 2007)
diff --git a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-6.2-sparc64.patch b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-6.2-sparc64.patch
deleted file mode 100644
index 3ed300a45863..000000000000
--- a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-6.2-sparc64.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-FreeBSD only works on Sparc64 and freeBSD code relies on the __sparc64__ define.
-gcc only defines __sparc64__ if -mcpu is not used.
-gcc-4 defaults to using -mcpu=ultrasparc on FreeBSD.
-
-This causes us a problem. Infact, FreeBSD developers sent gcc a patch to always
-define __sparc64__ when using -mcpu=ultrasparc, but this was rejected by most
-people including NetBSD developers.
-
-The correct solution is to use __sparc__.
-If platform detection is required, or the code is obviously 64 bit then we can
-use the __arch64__ define as well.
-This combination should be supported by all gcc versions:)
-
-diff -ur libexec.orig/rtld-elf/rtld.c libexec/rtld-elf/rtld.c
---- libexec.orig/rtld-elf/rtld.c 2006-10-10 08:16:56 +0100
-+++ libexec/rtld-elf/rtld.c 2006-10-10 08:19:08 +0100
-@@ -2732,7 +2732,7 @@
-
- #endif
-
--#if defined(__i386__) || defined(__amd64__) || defined(__sparc64__) || \
-+#if defined(__i386__) || defined(__amd64__) || defined(__sparc__) || \
- defined(__arm__)
-
- /*
-@@ -2897,7 +2897,7 @@
- void
- free_tls_offset(Obj_Entry *obj)
- {
--#if defined(__i386__) || defined(__amd64__) || defined(__sparc64__) || \
-+#if defined(__i386__) || defined(__amd64__) || defined(__sparc__) || \
- defined(__arm__)
- /*
- * If we were the last thing to allocate out of the static TLS
diff --git a/sys-freebsd/freebsd-libexec/freebsd-libexec-6.2-r2.ebuild b/sys-freebsd/freebsd-libexec/freebsd-libexec-6.2-r2.ebuild
index 9b53de56ec9b..131bd8e66726 100644
--- a/sys-freebsd/freebsd-libexec/freebsd-libexec-6.2-r2.ebuild
+++ b/sys-freebsd/freebsd-libexec/freebsd-libexec-6.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/freebsd-libexec-6.2-r2.ebuild,v 1.1 2007/09/12 00:15:46 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/freebsd-libexec-6.2-r2.ebuild,v 1.2 2007/10/16 08:54:50 uberlord Exp $
inherit bsdmk freebsd pam
@@ -29,8 +29,7 @@ S="${WORKDIR}/libexec"
PATCHES="${FILESDIR}/${PN}-setXid.patch
${FILESDIR}/${PN}-nossp.patch
${FILESDIR}/${PN}-6.1-libfallback.patch
- ${FILESDIR}/${PN}-6.2-dl_iterate_phdr.patch
- ${FILESDIR}/${PN}-6.2-sparc64.patch"
+ ${FILESDIR}/${PN}-6.2-dl_iterate_phdr.patch"
# Remove sendmail, tcp_wrapper and other useless stuff
REMOVE_SUBDIRS="smrsh mail.local tcpd telnetd rshd rlogind lukemftpd ftpd"