summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-05-18 01:35:07 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-05-18 01:35:07 +0000
commit74f415a17002097f4f4c2d80e496b3ae669039c1 (patch)
tree7bf66192c413982066bd56e789332f84d7a7fc2f /sys-freebsd
parentSet the NOSTRIPFLAG variable only once (diff)
downloadgentoo-2-74f415a17002097f4f4c2d80e496b3ae669039c1.tar.gz
gentoo-2-74f415a17002097f4f4c2d80e496b3ae669039c1.tar.bz2
gentoo-2-74f415a17002097f4f4c2d80e496b3ae669039c1.zip
Factorize some more code and regroup variable assignments.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-lib/ChangeLog5
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild13
2 files changed, 9 insertions, 9 deletions
diff --git a/sys-freebsd/freebsd-lib/ChangeLog b/sys-freebsd/freebsd-lib/ChangeLog
index c4425eaa0df7..873a522048e7 100644
--- a/sys-freebsd/freebsd-lib/ChangeLog
+++ b/sys-freebsd/freebsd-lib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-freebsd/freebsd-lib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.129 2012/05/18 01:31:08 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.130 2012/05/18 01:35:07 aballier Exp $
+
+ 18 May 2012; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.0-r2.ebuild:
+ Factorize some more code and regroup variable assignments.
18 May 2012; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.0-r2.ebuild:
Set the NOSTRIPFLAG variable only once
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
index 07503ed28a0c..4c52cced2a45 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild,v 1.15 2012/05/18 01:31:08 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild,v 1.16 2012/05/18 01:35:07 aballier Exp $
EAPI=2
@@ -245,16 +245,13 @@ src_compile() {
export YACC='yacc -by'
CHOST=${CTARGET} tc-export CC LD CXX RANLIB
mymakeopts="${mymakeopts} NLS="
+ append-flags "-isystem /usr/${CTARGET}/usr/include"
+ append-ldflags "-L${WORKDIR}/lib/libc"
bootstrap_csu
- append-flags "-isystem /usr/${CTARGET}/usr/include"
-
bootstrap_libssp_nonshared
- append-ldflags "-L${WORKDIR}/lib/libc"
- export RAW_LDFLAGS=$(raw-ldflags)
-
SUBDIRS="lib/libc lib/msun gnu/lib/libssp lib/libthr lib/libutil"
else
# Forces to use the local copy of headers as they might be outdated in
@@ -263,11 +260,11 @@ src_compile() {
bootstrap_libssp_nonshared
- export RAW_LDFLAGS=$(raw-ldflags)
-
SUBDIRS="lib gnu/lib/libssp gnu/lib/libregex"
fi
+ export RAW_LDFLAGS=$(raw-ldflags)
+
# Everything is now setup, build it!
for i in ${SUBDIRS} ; do
cd "${WORKDIR}/${i}/" || die "missing ${i}."