summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-09-11 17:02:43 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-09-11 17:02:43 +0000
commita0a315e72da05ba1a15e2823354145b76d0d19c8 (patch)
tree343277cb6237dd965bd7ad5f4d19aa9d1c535110 /sys-freebsd
parentbump to 9.1_rc1 from bsd overlay by Yuta SATOH, bug #426838 (diff)
downloadgentoo-2-a0a315e72da05ba1a15e2823354145b76d0d19c8.tar.gz
gentoo-2-a0a315e72da05ba1a15e2823354145b76d0d19c8.tar.bz2
gentoo-2-a0a315e72da05ba1a15e2823354145b76d0d19c8.zip
bump to 9.1_rc1 from bsd overlay by Yuta SATOH, bug #426838
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-contrib/ChangeLog8
-rw-r--r--sys-freebsd/freebsd-contrib/freebsd-contrib-9.1_rc1.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/sys-freebsd/freebsd-contrib/ChangeLog b/sys-freebsd/freebsd-contrib/ChangeLog
index 2b4007b376c5..93a7f738180a 100644
--- a/sys-freebsd/freebsd-contrib/ChangeLog
+++ b/sys-freebsd/freebsd-contrib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-contrib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.36 2012/05/04 11:36:46 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.37 2012/09/11 17:02:43 aballier Exp $
+
+*freebsd-contrib-9.1_rc1 (11 Sep 2012)
+
+ 11 Sep 2012; Alexis Ballier <aballier@gentoo.org>
+ +freebsd-contrib-9.1_rc1.ebuild:
+ bump to 9.1_rc1 from bsd overlay by Yuta SATOH, bug #426838
04 May 2012; Alexis Ballier <aballier@gentoo.org> freebsd-contrib-9.0.ebuild:
install libodialog in lib64 for amd64
diff --git a/sys-freebsd/freebsd-contrib/freebsd-contrib-9.1_rc1.ebuild b/sys-freebsd/freebsd-contrib/freebsd-contrib-9.1_rc1.ebuild
new file mode 100644
index 000000000000..5f23c3875812
--- /dev/null
+++ b/sys-freebsd/freebsd-contrib/freebsd-contrib-9.1_rc1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/freebsd-contrib-9.1_rc1.ebuild,v 1.1 2012/09/11 17:02:43 aballier Exp $
+
+inherit bsdmk freebsd flag-o-matic multilib
+
+DESCRIPTION="Contributed sources for FreeBSD."
+SLOT="0"
+KEYWORDS="~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+LICENSE="BSD GPL-2 as-is"
+
+IUSE=""
+
+SRC_URI="mirror://gentoo/${GNU}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-sources-${RV}*
+ =sys-freebsd/freebsd-mk-defs-${RV}*"
+
+S="${WORKDIR}/gnu"
+
+src_unpack() {
+ echo ">>> Unpacking needed parts of ${GNU}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${GNU}.tar.bz2" gnu/lib/libodialog gnu/usr.bin/sort gnu/usr.bin/patch
+ echo ">>> Unpacking needed parts of ${CONTRIB}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${CONTRIB}.tar.bz2" contrib/gnu-sort
+
+ freebsd_do_patches
+ freebsd_rename_libraries
+}
+
+src_compile() {
+ cd "${S}/lib/libodialog"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/sort"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/patch"
+ freebsd_src_compile
+}
+
+src_install() {
+ use profile || mymakeopts="${mymakeopts} NO_PROFILE= "
+ mymakeopts="${mymakeopts} NO_MANCOMPRESS= NO_INFOCOMPRESS= "
+
+ cd "${S}/lib/libodialog"
+ mkinstall LIBDIR="/usr/$(get_libdir)" || die "libodialog install failed"
+
+ cd "${S}/usr.bin/sort"
+ mkinstall BINDIR="/bin/" || die "sort install failed"
+
+ cd "${S}/usr.bin/patch"
+ mkinstall BINDIR="/usr/bin/" || die "patch install failed"
+}