summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-28 06:59:11 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-28 06:59:11 +0000
commit0e56e765cc6c3ff843311457d40c8b853e469adc (patch)
tree7ac41623574c78eb2eb403774c0116f2447587f4 /sys-fs/aufs3
parent[bump] dev-perl/Role-Tiny-1.1.1 (diff)
downloadgentoo-2-0e56e765cc6c3ff843311457d40c8b853e469adc.tar.gz
gentoo-2-0e56e765cc6c3ff843311457d40c8b853e469adc.tar.bz2
gentoo-2-0e56e765cc6c3ff843311457d40c8b853e469adc.zip
sys-fs/aufs3: Allow parallel build, patch sent upstream
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/aufs3')
-rw-r--r--sys-fs/aufs3/ChangeLog6
-rw-r--r--sys-fs/aufs3/aufs3-3_p20120402.ebuild4
-rw-r--r--sys-fs/aufs3/files/parallel.patch25
3 files changed, 33 insertions, 2 deletions
diff --git a/sys-fs/aufs3/ChangeLog b/sys-fs/aufs3/ChangeLog
index 9dd06cee5865..c87f8e317c75 100644
--- a/sys-fs/aufs3/ChangeLog
+++ b/sys-fs/aufs3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/aufs3
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.10 2012/04/23 15:47:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.11 2012/04/28 06:59:11 jlec Exp $
+
+ 28 Apr 2012; Justin Lecher <jlec@gentoo.org> aufs3-3_p20120402.ebuild,
+ +files/parallel.patch:
+ Allow parallel build, patch sent upstream
23 Apr 2012; Agostino Sarubbo <ago@gentoo.org> aufs3-3_p20120109.ebuild:
Stable for amd64, wrt bug #407991
diff --git a/sys-fs/aufs3/aufs3-3_p20120402.ebuild b/sys-fs/aufs3/aufs3-3_p20120402.ebuild
index 8081ebf32d2d..b29eeb5bb162 100644
--- a/sys-fs/aufs3/aufs3-3_p20120402.ebuild
+++ b/sys-fs/aufs3/aufs3-3_p20120402.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20120402.ebuild,v 1.1 2012/04/02 07:21:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20120402.ebuild,v 1.2 2012/04/28 06:59:11 jlec Exp $
EAPI=4
@@ -111,6 +111,8 @@ src_prepare() {
sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile || die
sed -i "s:__user::g" include/linux/aufs_type.h || die
+ epatch "${FILESDIR}"/parallel.patch
+
cd "${WORKDIR}"/${PN/3}-util
einfo "Using for utils building branch ${util_branch}"
diff --git a/sys-fs/aufs3/files/parallel.patch b/sys-fs/aufs3/files/parallel.patch
new file mode 100644
index 000000000000..6923ea7ebd37
--- /dev/null
+++ b/sys-fs/aufs3/files/parallel.patch
@@ -0,0 +1,25 @@
+ Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 9031813..94329c0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -18,7 +18,7 @@ export CONFIG_AUFS_FS
+ EXTRA_CFLAGS := -I${CURDIR}/include
+ EXTRA_CFLAGS += ${AUFS_DEF_CONFIG}
+
+-MakeMod = ${MAKE} -C ${KDIR} M=${CURDIR}/fs/aufs EXTRA_CFLAGS="${EXTRA_CFLAGS}"
++MakeMod = -C ${KDIR} M=${CURDIR}/fs/aufs EXTRA_CFLAGS="${EXTRA_CFLAGS}"
+
+ all: aufs.ko usr/include/linux/aufs_type.h
+
+@@ -39,7 +39,7 @@ aufs.ko: fs/aufs/aufs.ko
+
+ fs/aufs/aufs.ko:
+ @echo ${EXTRA_CFLAGS}
+- ${MakeMod} modules
++ ${MAKE} ${MakeMod} modules
+
+ usr/include/linux/aufs_type.h: d = $(shell echo ${CURDIR} | cut -c2-)
+ usr/include/linux/aufs_type.h: