summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-21 13:26:06 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-21 13:26:06 +0000
commit08c34c86c87fde644a8d32e292371adcc072365a (patch)
tree77639e5799a1b66c70fa9bd974f4ca0955ddf0c8 /sys-fs/device-mapper
parentFix building with -Wl,--as-needed wrt #294885 by Kacper Kowalik. (diff)
downloadgentoo-2-08c34c86c87fde644a8d32e292371adcc072365a.tar.gz
gentoo-2-08c34c86c87fde644a8d32e292371adcc072365a.tar.bz2
gentoo-2-08c34c86c87fde644a8d32e292371adcc072365a.zip
Fix building with -Wl,--as-needed wrt #259569 by James C. Georgas.
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/device-mapper')
-rw-r--r--sys-fs/device-mapper/ChangeLog8
-rw-r--r--sys-fs/device-mapper/device-mapper-1.02.28.ebuild8
-rw-r--r--sys-fs/device-mapper/files/device-mapper-1.02.28-asneeded.patch12
3 files changed, 23 insertions, 5 deletions
diff --git a/sys-fs/device-mapper/ChangeLog b/sys-fs/device-mapper/ChangeLog
index 20d4b93cecd3..abefbc4ce924 100644
--- a/sys-fs/device-mapper/ChangeLog
+++ b/sys-fs/device-mapper/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/device-mapper
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/ChangeLog,v 1.123 2008/11/07 21:22:19 robbat2 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/ChangeLog,v 1.124 2009/12/21 13:26:05 ssuominen Exp $
+
+ 21 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
+ device-mapper-1.02.28.ebuild, +files/device-mapper-1.02.28-asneeded.patch:
+ Fix building with -Wl,--as-needed wrt #259569 by James C. Georgas.
*device-mapper-1.02.28 (07 Nov 2008)
diff --git a/sys-fs/device-mapper/device-mapper-1.02.28.ebuild b/sys-fs/device-mapper/device-mapper-1.02.28.ebuild
index 4ff9d3a515b0..7508f548ae4f 100644
--- a/sys-fs/device-mapper/device-mapper-1.02.28.ebuild
+++ b/sys-fs/device-mapper/device-mapper-1.02.28.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/device-mapper-1.02.28.ebuild,v 1.1 2008/11/07 21:22:19 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/device-mapper-1.02.28.ebuild,v 1.2 2009/12/21 13:26:05 ssuominen Exp $
inherit eutils multilib toolchain-funcs
@@ -22,7 +22,9 @@ S="${WORKDIR}/${PN}.${PV}"
src_unpack() {
unpack ${A}
- EPATCH_OPTS="-p1 -d${S}" epatch "${FILESDIR}"/device-mapper-1.02.27-export-format.diff
+ EPATCH_OPTS="-p1 -d${S}" epatch \
+ "${FILESDIR}"/device-mapper-1.02.27-export-format.diff \
+ "${FILESDIR}"/${P}-asneeded.patch
}
src_compile() {
diff --git a/sys-fs/device-mapper/files/device-mapper-1.02.28-asneeded.patch b/sys-fs/device-mapper/files/device-mapper-1.02.28-asneeded.patch
new file mode 100644
index 000000000000..c5615eaf68ed
--- /dev/null
+++ b/sys-fs/device-mapper/files/device-mapper-1.02.28-asneeded.patch
@@ -0,0 +1,12 @@
+--- device-mapper.1.02.28.orig/dmeventd/Makefile.in 2008-06-27 09:36:51.000000000 -0600
++++ device-mapper.1.02.28/dmeventd/Makefile.in 2009-02-19 00:21:18.000000000 -0700
+@@ -31,8 +31,7 @@
+
+ include ../make.tmpl
+
+-LDFLAGS += -ldl -ldevmapper -lpthread
+-CLDFLAGS += -ldl -ldevmapper -lpthread
++LIBS += -ldl -ldevmapper -lpthread
+
+ dmeventd: $(LIB_SHARED) $(VERSIONED_SHLIB) dmeventd.o
+ $(CC) -o $@ dmeventd.o $(CFLAGS) $(LDFLAGS) \