summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-11-06 20:55:33 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-11-06 20:55:33 +0000
commit28cfb5ea6e426c68285cbea4d0e23a80b761ee4e (patch)
tree1fece8e937dc5316537047befafb262b6cdfad34 /sys-fs/e4rat
parentVersion bump, bug 442098 (diff)
downloadgentoo-2-28cfb5ea6e426c68285cbea4d0e23a80b761ee4e.tar.gz
gentoo-2-28cfb5ea6e426c68285cbea4d0e23a80b761ee4e.tar.bz2
gentoo-2-28cfb5ea6e426c68285cbea4d0e23a80b761ee4e.zip
Apply patch to fix building with boost >= 1.50. Bug #425422, Thanks to Olivier Huber <oli.huber@gmail.com>
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'sys-fs/e4rat')
-rw-r--r--sys-fs/e4rat/ChangeLog10
-rw-r--r--sys-fs/e4rat/e4rat-0.2.3-r1.ebuild57
-rw-r--r--sys-fs/e4rat/files/e4rat-0.2.3-boostfsv3.patch86
3 files changed, 151 insertions, 2 deletions
diff --git a/sys-fs/e4rat/ChangeLog b/sys-fs/e4rat/ChangeLog
index 3e9f414ed052..79b2257ef1a2 100644
--- a/sys-fs/e4rat/ChangeLog
+++ b/sys-fs/e4rat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/e4rat
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e4rat/ChangeLog,v 1.8 2012/10/17 03:49:02 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e4rat/ChangeLog,v 1.9 2012/11/06 20:55:32 hwoarang Exp $
+
+*e4rat-0.2.3-r1 (06 Nov 2012)
+
+ 06 Nov 2012; Markos Chandras <hwoarang@gentoo.org> +e4rat-0.2.3-r1.ebuild,
+ +files/e4rat-0.2.3-boostfsv3.patch:
+ Apply patch to fix building with boost >= 1.50. Bug #425422, Thanks to Olivier
+ Huber <oli.huber@gmail.com>
17 Oct 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> e4rat-0.2.3.ebuild:
x86 stable wrt bug #436684
@@ -42,4 +49,3 @@
+metadata.xml:
Initial commit. Bug #363207. Thanks to Michael Orlitzky
<michael@orlitzky.com>
-
diff --git a/sys-fs/e4rat/e4rat-0.2.3-r1.ebuild b/sys-fs/e4rat/e4rat-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..79d6f14ce903
--- /dev/null
+++ b/sys-fs/e4rat/e4rat-0.2.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e4rat/e4rat-0.2.3-r1.ebuild,v 1.1 2012/11/06 20:55:32 hwoarang Exp $
+
+EAPI=4
+
+inherit cmake-utils linux-info
+
+DESCRIPTION="Toolset to accelerate the boot process and application startup"
+HOMEPAGE="http://e4rat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}_src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ >=dev-libs/boost-1.42
+ sys-fs/e2fsprogs
+ sys-process/audit"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~AUDITSYSCALL"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.2-shared-build.patch
+ "${FILESDIR}"/${PN}-0.2.2-libdir.patch
+ "${FILESDIR}"/${P}-boostfsv3.patch
+)
+
+pkg_setup() {
+ check_extra_config
+}
+
+src_install() {
+ cmake-utils_src_install
+ # relocate binaries to /sbin. If someone knows of a better way to do it
+ # please do tell me
+ dodir sbin
+ find "${D}"/usr/sbin -type f -exec mv {} "${D}"/sbin/. \; \
+ || die
+}
+
+pkg_postinst() {
+ elog
+ elog "Please consult the upstream wiki if you need help"
+ elog "configuring your system"
+ elog "http://e4rat.sourceforge.net/wiki/index.php/Main_Page"
+ elog
+ if has_version sys-apps/preload; then
+ elog "It appears you have sys-apps/preload installed. This may"
+ elog "has negative effects on ${PN}. You may want to disable preload"
+ elog "when using ${PN}."
+ elog "http://e4rat.sourceforge.net/wiki/index.php/Main_Page#Debian.2FUbuntu"
+ fi
+}
diff --git a/sys-fs/e4rat/files/e4rat-0.2.3-boostfsv3.patch b/sys-fs/e4rat/files/e4rat-0.2.3-boostfsv3.patch
new file mode 100644
index 000000000000..5450af1c2aa9
--- /dev/null
+++ b/sys-fs/e4rat/files/e4rat-0.2.3-boostfsv3.patch
@@ -0,0 +1,86 @@
+Bug #425422
+Fixes building against boost-1.50
+Port to boost FS v3
+
+--- CMakeLists.txt.orig 2012-09-07 03:17:55.515017487 +0200
++++ CMakeLists.txt 2012-09-13 19:54:18.160054076 +0200
+@@ -15,7 +15,6 @@
+ ENDIF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
+
+ set(Boost_USE_MULTITHREADED OFF)
+-add_definitions(-DBOOST_FILESYSTEM_VERSION=2)
+ find_package(Boost 1.41 COMPONENTS system filesystem regex REQUIRED)
+ set(${PROJECT_NAME}_LIBRARIES ${${PROJECT_NAME}_LIBRARIES}
+ ${Boost_LIBRARIES})
+--- src/config.cc.orig 2012-09-13 19:50:32.829871091 +0200
++++ src/config.cc 2012-09-13 19:55:37.023068153 +0200
+@@ -71,7 +71,7 @@
+ return;
+ }
+
+- tool_name = fs::path(argv[0]).filename();
++ tool_name = fs::path(argv[0]).filename().string();
+ found = tool_name.find_last_of("-");
+ if(found)
+ defaultSection = tool_name.substr(found+1);
+--- src/common.cc.orig 2012-09-13 19:58:06.187203344 +0200
++++ src/common.cc 2012-09-13 19:59:34.752096130 +0200
+@@ -157,7 +157,7 @@
+ p /= filesearch;
+ }
+ // Initialize regex filter - use * as default if nothing is given in filesearch
+- std::string f( p.has_filename() ? p.filename() : "*");
++ std::string f( p.has_filename() ? p.filename().string() : "*");
+
+ fs::path dir(system_complete(p).parent_path());
+ if( is_directory(dir) )
+@@ -166,8 +166,8 @@
+ it!=boost::filesystem::directory_iterator();
+ ++it )
+ {
+- if( boost::regex_match( it->leaf(), path2regex(f) ) )
+- fileset.push_back(it->string());
++ if( boost::regex_match( it->path().filename().string(), path2regex(f) ) )
++ fileset.push_back(it->path().filename().string());
+ }
+ return fileset;
+ }
+--- src/e4rat-collect.cc.orig 2012-09-13 20:03:40.185027797 +0200
++++ src/e4rat-collect.cc 2012-09-13 20:03:54.404850024 +0200
+@@ -396,7 +396,7 @@
+ * Parse application list given as arguments
+ */
+ for ( ; optind < argc; optind++)
+- project.observeApp(fs::path(argv[optind]).filename());
++ project.observeApp(fs::path(argv[optind]).filename().string());
+
+ /*
+ * Parse application list on stdin
+--- src/device.cc.orig 2012-09-13 20:00:40.232277516 +0200
++++ src/device.cc 2012-09-13 20:03:11.026392331 +0200
+@@ -196,13 +196,13 @@
+ it != end_itr;
+ ++it )
+ {
+- if(it->filename() == "root")
++ if(it->path().filename().string() == "root")
+ continue;
+- if(lstat(it->string().c_str(), &st))
++ if(lstat(it->path().filename().c_str(), &st))
+ continue;
+ if(st.st_rdev == get()->devno)
+ {
+- get()->deviceName = it->filename();
++ get()->deviceName = it->path().filename().string();
+ get()->devicePath = "/dev/" + get()->deviceName;
+ return 0;
+ }
+@@ -225,7 +225,7 @@
+ // the minor number of virtual filesystems are allocated dynamically in function set_anon_super() in fs/super.c
+ // for convenience set deviceName and devicePath to a common name
+ get()->deviceName = "virtual file system";
+- get()->devicePath = get()->mount_point.filename();
++ get()->devicePath = get()->mount_point.filename().string();
+ return 0;
+ case 2:
+ ss << "fd";