summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-06 00:30:56 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-06 00:30:56 +0000
commitba6e6c146775d894739560ceb4ccd09f94b67885 (patch)
tree5e9a702cef2968c6503b2ba0210c2c0051679ff7 /sys-fs/ecryptfs-utils
parentVersion bump (bug #283081). (diff)
downloadgentoo-2-ba6e6c146775d894739560ceb4ccd09f94b67885.tar.gz
gentoo-2-ba6e6c146775d894739560ceb4ccd09f94b67885.tar.bz2
gentoo-2-ba6e6c146775d894739560ceb4ccd09f94b67885.zip
Version bump. Fix building with >=app-crypt/gpgme-1.2.0 (bug #278494).
(Portage version: 14204-svn/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/ecryptfs-utils')
-rw-r--r--sys-fs/ecryptfs-utils/ChangeLog9
-rw-r--r--sys-fs/ecryptfs-utils/ecryptfs-utils-79.ebuild (renamed from sys-fs/ecryptfs-utils/ecryptfs-utils-75.ebuild)8
-rw-r--r--sys-fs/ecryptfs-utils/files/ecryptfs-utils-75-fix_warnings.patch110
3 files changed, 12 insertions, 115 deletions
diff --git a/sys-fs/ecryptfs-utils/ChangeLog b/sys-fs/ecryptfs-utils/ChangeLog
index 86f69c7b0c75..8fdf7f64a8eb 100644
--- a/sys-fs/ecryptfs-utils/ChangeLog
+++ b/sys-fs/ecryptfs-utils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/ecryptfs-utils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.25 2009/07/18 00:27:21 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.26 2009/09/06 00:30:56 arfrever Exp $
+
+*ecryptfs-utils-79 (06 Sep 2009)
+
+ 06 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -ecryptfs-utils-75.ebuild, -files/ecryptfs-utils-75-fix_warnings.patch,
+ +ecryptfs-utils-79.ebuild:
+ Version bump. Fix building with >=app-crypt/gpgme-1.2.0 (bug #278494).
*ecryptfs-utils-76 (18 Jul 2009)
diff --git a/sys-fs/ecryptfs-utils/ecryptfs-utils-75.ebuild b/sys-fs/ecryptfs-utils/ecryptfs-utils-79.ebuild
index 43bf93a57a07..477bae836886 100644
--- a/sys-fs/ecryptfs-utils/ecryptfs-utils-75.ebuild
+++ b/sys-fs/ecryptfs-utils/ecryptfs-utils-79.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-75.ebuild,v 1.1 2009/05/02 18:30:04 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-79.ebuild,v 1.1 2009/09/06 00:30:56 arfrever Exp $
EAPI="2"
-inherit eutils pam
+inherit flag-o-matic pam
DESCRIPTION="eCryptfs userspace utilities"
HOMEPAGE="http://launchpad.net/ecryptfs"
@@ -32,8 +32,8 @@ DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.9.0
python? ( dev-lang/swig )"
-src_prepare() {
- epatch "${FILESDIR}/${P}-fix_warnings.patch"
+pkg_setup() {
+ append-flags -D_FILE_OFFSET_BITS=64
}
src_configure() {
diff --git a/sys-fs/ecryptfs-utils/files/ecryptfs-utils-75-fix_warnings.patch b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-75-fix_warnings.patch
deleted file mode 100644
index 0a143455ba4a..000000000000
--- a/sys-fs/ecryptfs-utils/files/ecryptfs-utils-75-fix_warnings.patch
+++ /dev/null
@@ -1,110 +0,0 @@
---- src/key_mod/ecryptfs_key_mod_gpg.c
-+++ src/key_mod/ecryptfs_key_mod_gpg.c
-@@ -131,7 +131,7 @@
-
- int ecryptfs_gpg_encrypt(char *to, int size, char *from, unsigned char *blob)
- {
-- int rc;
-+ int rc = 0;
-
- /* gpg_op_encrypt(...); */
- out:
-@@ -251,7 +251,7 @@
- struct val_node **head, void **foo)
- {
- struct key_mod_gpg *key_mod_gpg = (struct key_mod_gpg *)(*foo);
-- int i;
-+ int i = 0;
- gpgme_error_t err;
- int rc = 0;
- gpgme_key_t key;
-@@ -283,10 +283,7 @@
-
- static int generate_name_val_list(struct ecryptfs_name_val_pair *head)
- {
-- struct stat buf;
-- int i = 0;
- uid_t id = getuid();
-- struct passwd *pw = getpwuid(id);
- int rc = 0;
-
- head->next = NULL;
-@@ -304,6 +301,7 @@
- destroy_key_mod_gpg(key_mod_gpg);
- free(key_mod_gpg);
- }
-+ return 0;
- }
-
-
-@@ -312,7 +310,6 @@
- {
- struct key_mod_gpg *key_mod_gpg;
- gpgme_error_t err;
-- gpgme_keylist_result_t keylist_res;
- int rc = 0;
-
- (*foo) = NULL;
-@@ -329,7 +326,7 @@
- if ((err = gpgme_op_keylist_start(key_mod_gpg->ctx, "", 0))) {
- printf("Error attempting to start keylist\n");
- rc = -EINVAL;
-- gpgme_release(ctx);
-+ gpgme_release(key_mod_gpg->ctx);
- free(key_mod_gpg);
- goto out;
- }
---- src/key_mod/ecryptfs_key_mod_pkcs11_helper.c
-+++ src/key_mod/ecryptfs_key_mod_pkcs11_helper.c
-@@ -592,7 +592,6 @@
- char dn[1024] = {0};
- char serial[1024] = {0};
- char *ser = NULL;
-- char *ssh_key = NULL;
- size_t ser_len = 0;
- int n;
-
-@@ -1538,7 +1537,6 @@
- struct ecryptfs_ctx *ctx = &_ctx;
- struct ecryptfs_name_val_pair nvp_head;
- struct val_node *dummy_mnt_params;
-- uid_t id;
- struct passwd *pw;
- char *rcfile_fullpath = NULL;
- int fd;
-@@ -1649,6 +1647,7 @@
- if (pkcs11h_key_param_nodes[PKCS11H_KEY_TOK_ID].suggested_val)
- free(pkcs11h_key_param_nodes[PKCS11H_KEY_TOK_ID].suggested_val);
- pkcs11h_terminate ();
-+ return 0;
- }
-
- static struct ecryptfs_key_mod_ops ecryptfs_pkcs11h_ops = {
---- src/libecryptfs/key_management.c
-+++ src/libecryptfs/key_management.c
-@@ -18,6 +18,7 @@
- * 02111-1307, USA.
- */
-
-+#include "config.h"
- #include <errno.h>
- #ifdef ENABLE_NSS
- #include <nss.h>
-@@ -39,7 +40,6 @@
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <pwd.h>
--#include "config.h"
- #include "../include/ecryptfs.h"
-
- #ifndef ENOKEY
---- src/utils/ecryptfs_unwrap_passphrase.c
-+++ src/utils/ecryptfs_unwrap_passphrase.c
-@@ -42,7 +42,6 @@
- char *wrapping_passphrase;
- char salt[ECRYPTFS_SALT_SIZE];
- char salt_hex[ECRYPTFS_SALT_SIZE_HEX];
-- struct passwd *pwd;
- int rc = 0;
-
- if (argc == 1) {