summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2005-03-19 17:32:19 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2005-03-19 17:32:19 +0000
commita177b260574144c46e0a2a96e319899ac9cca622 (patch)
treef5cc8eb818997cfc4f63d2e08ac1f0bb58b02c1f /sys-fs/gfs
parentAdded ~sparc keyword wrt bug #84791. (diff)
downloadgentoo-2-a177b260574144c46e0a2a96e319899ac9cca622.tar.gz
gentoo-2-a177b260574144c46e0a2a96e319899ac9cca622.tar.bz2
gentoo-2-a177b260574144c46e0a2a96e319899ac9cca622.zip
gfs added to portage
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-fs/gfs')
-rw-r--r--sys-fs/gfs/ChangeLog16
-rw-r--r--sys-fs/gfs/Manifest8
-rw-r--r--sys-fs/gfs/files/digest-gfs-6.1_pre211
-rwxr-xr-xsys-fs/gfs/files/gfs66
-rwxr-xr-xsys-fs/gfs/files/gfs-mount28
-rw-r--r--sys-fs/gfs/gfs-6.1_pre21.ebuild58
-rw-r--r--sys-fs/gfs/metadata.xml8
7 files changed, 185 insertions, 0 deletions
diff --git a/sys-fs/gfs/ChangeLog b/sys-fs/gfs/ChangeLog
new file mode 100644
index 000000000000..65653d2b2e8b
--- /dev/null
+++ b/sys-fs/gfs/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for sys-cluster/gfs
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/gfs/ChangeLog,v 1.1 2005/03/19 17:32:19 xmerlin Exp $
+
+*gfs-6.1_pre3 (19 Mar 2005)
+
+ 19 Mar 2005; Christian Zoffoli <xmerlin@gentoo.org> +gfs-6.1_pre21.ebuild,
+ -gfs-6.1_pre3.ebuild:
+ gfs added to portage
+
+*gfs-6.1_pre3 (19 Mar 2005)
+
+ 28 Jan 2005; Christian Zoffoli <xmerlin@gentoo.org> +metadata.xml,
+ +files/gfs, +files/gfs-mount, +gfs-6.1_pre3.ebuild:
+ new in portage
+
diff --git a/sys-fs/gfs/Manifest b/sys-fs/gfs/Manifest
new file mode 100644
index 000000000000..ab3c0bc22dfd
--- /dev/null
+++ b/sys-fs/gfs/Manifest
@@ -0,0 +1,8 @@
+MD5 a64b9a1937a5cfc2fbaf373521f65d47 metadata.xml 223
+MD5 76593f6596e842e93f6208c308f1d765 gfs-6.1_pre3.ebuild 1412
+MD5 582df59631b52ae5d1a6bdee81de0b9b ChangeLog 190
+MD5 061a99c1b62a5dd5bb56a63905f68136 gfs-6.1_pre21.ebuild 1502
+MD5 6b98be2b547ae40ec3cd04187c10d00c files/gfs 1834
+MD5 3dbc15e9a166cdbe149c8de5c15f0a56 files/gfs-mount 705
+MD5 9b1ffc4111b4e5834898d465a5bb8663 files/digest-gfs-6.1_pre3 64
+MD5 8b61a396206c23d7fb8e1adad649f8b7 files/digest-gfs-6.1_pre21 65
diff --git a/sys-fs/gfs/files/digest-gfs-6.1_pre21 b/sys-fs/gfs/files/digest-gfs-6.1_pre21
new file mode 100644
index 000000000000..5f642cd0ea14
--- /dev/null
+++ b/sys-fs/gfs/files/digest-gfs-6.1_pre21
@@ -0,0 +1 @@
+MD5 3e40be9da606f70dab0c190b9cbe54d9 gfs-6.1-pre21.tar.gz 164356
diff --git a/sys-fs/gfs/files/gfs b/sys-fs/gfs/files/gfs
new file mode 100755
index 000000000000..243171c26850
--- /dev/null
+++ b/sys-fs/gfs/files/gfs
@@ -0,0 +1,66 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/gfs/files/gfs,v 1.1 2005/03/19 17:32:19 xmerlin Exp $
+
+depend() {
+ provide cluster
+ need net
+ use dns logger
+}
+
+checkconfig() {
+ if [ ! -f /etc/ntp.conf ] ; then
+ eerror "Please create /etc/ntp.conf"
+ eerror "Sample conf: /usr/share/ntp/ntp.conf"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return $?
+
+ einfo "Starting gfs cluster:"
+
+ ebegin "Loading needed kernel modules"
+
+ if [ ! -f /proc/cluster/lock_dlm ]; then
+ modprobe lock_dlm
+ fi
+ if [ ! -f /proc/fs/gfs ]; then
+ modprobe gfs
+ fi
+ eend $? "Failed to load needed kernel modules"
+
+ ebegin "Starting ccsd"
+ start-stop-daemon --start --quiet --pidfile /var/run/ccsd.pid \
+ --startas /sbin/ccsd
+ sleep 2
+ eend $? "Failed to start ccsd"
+
+ ebegin "Joining the cluster"
+ /sbin/cman_tool join
+ eend $? "Failed to join the cluster"
+
+ ebegin "Joining the fence domain (in 120 seconds)"
+ /sbin/fence_tool join -t 120
+ eend $? "Failed to join the fence domain"
+}
+
+stop() {
+ einfo "Stopping gfs cluster:"
+
+ ebegin "Leaving the fence domain"
+ /sbin/fence_tool leave
+ eend $? "Failed to leave the fence domain"
+
+ ebegin "Leaving the cluster"
+ sleep 2
+ /sbin/cman_tool leave
+ eend $? "Failed to leave the cluster"
+
+ ebegin "Stopping ccsd"
+ killall -9 ccsd
+ eend $? "Failed to stop ccsd"
+}
diff --git a/sys-fs/gfs/files/gfs-mount b/sys-fs/gfs/files/gfs-mount
new file mode 100755
index 000000000000..739afd76cc5f
--- /dev/null
+++ b/sys-fs/gfs/files/gfs-mount
@@ -0,0 +1,28 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/gfs/files/gfs-mount,v 1.1 2005/03/19 17:32:19 xmerlin Exp $
+
+depend() {
+ need net
+ after gnbd-client gfs
+ use dns logger
+}
+
+start() {
+ GFS=`cat /etc/fstab | grep 'gfs'`
+ if [ -n "$GFS" ] ; then
+ ebegin "Mounting all gfs filesystems"
+ cat /etc/fstab | awk '/[\t\s]gfs[\t\s]/ { print $1,$2 }' | xargs mount -v -t gfs
+ eend $? "Failed to mount all gfs filesystems"
+ fi
+}
+
+stop() {
+ GFS=`cat /etc/fstab | grep 'gfs'`
+ if [ -n "$GFS" ] ; then
+ ebegin "Unmounting all gfs filesystems"
+ cat /etc/fstab | awk '/[\t\s]gfs[\t\s]/ { print $2 }' | xargs umount -v -t gfs
+ eend $? "Failed to umount all gfs filesystems"
+ fi
+}
diff --git a/sys-fs/gfs/gfs-6.1_pre21.ebuild b/sys-fs/gfs/gfs-6.1_pre21.ebuild
new file mode 100644
index 000000000000..d7fce1648fa4
--- /dev/null
+++ b/sys-fs/gfs/gfs-6.1_pre21.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/gfs/gfs-6.1_pre21.ebuild,v 1.1 2005/03/19 17:32:19 xmerlin Exp $
+
+inherit linux-mod
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Shared-disk cluster file system"
+HOMEPAGE="http://sources.redhat.com/cluster/"
+#SRC_URI="http://people.redhat.com/cfeist/cluster/tgz/${MY_P}.tar.gz"
+
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz
+ http://dev.gentoo.org/~xmerlin/gfs/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=sys-cluster/gfs-kernel-2.6.9-r1
+ >=sys-cluster/iddev-1.9
+ sys-fs/e2fsprogs"
+
+RDEPEND="sys-fs/e2fsprogs"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ check_KV
+ set_arch_to_kernel
+
+ ./configure --kernel_src=${KERNEL_DIR} || die
+ emake || die
+}
+
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/gfs
+ doexe ${FILESDIR}/gfs-mount
+}
+
+pkg_postinst() {
+ einfo "This package is a container package for all the GFS related utils/libs."
+ einfo "For more info see the following URLs:"
+ einfo "http://sources.redhat.com/cluster/doc/usage.txt"
+ einfo ""
+ einfo "Run the following commands on cluster nodes to get everything going:"
+ einfo "hint: you need to actually set things up before you do this, see the first URL above"
+ einfo "# ccsd"
+ einfo "# cman_tool join"
+ einfo "# fence_tool join"
+ einfo "# mount -t gfs /dev/sdd1 /mnt/gfs ...."
+}
diff --git a/sys-fs/gfs/metadata.xml b/sys-fs/gfs/metadata.xml
new file mode 100644
index 000000000000..e2b45fb75fca
--- /dev/null
+++ b/sys-fs/gfs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cluster</herd>
+<maintainer>
+ <email>cluster@gentoo.org</email>
+</maintainer>
+</pkgmetadata>