summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-10-21 00:59:06 +0000
committerRick Farina <zerochaos@gentoo.org>2013-10-21 00:59:06 +0000
commitc48cce21bffe22b19996577efaa47d59ad988e45 (patch)
treee7cb0a268dab2b1b8d8cd23f090f946bf873387d /sys-fs/go-mtpfs
parentgo-fuse initial commit. installs everything, likely improperly. addings as a... (diff)
downloadgentoo-2-c48cce21bffe22b19996577efaa47d59ad988e45.tar.gz
gentoo-2-c48cce21bffe22b19996577efaa47d59ad988e45.tar.bz2
gentoo-2-c48cce21bffe22b19996577efaa47d59ad988e45.zip
go-mtpfs initial commit. can't build yet, can't find go-fuse properly
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sys-fs/go-mtpfs')
-rw-r--r--sys-fs/go-mtpfs/ChangeLog9
-rw-r--r--sys-fs/go-mtpfs/go-mtpfs-9999.ebuild34
-rw-r--r--sys-fs/go-mtpfs/metadata.xml10
3 files changed, 53 insertions, 0 deletions
diff --git a/sys-fs/go-mtpfs/ChangeLog b/sys-fs/go-mtpfs/ChangeLog
new file mode 100644
index 000000000000..9eb34ffa4d6f
--- /dev/null
+++ b/sys-fs/go-mtpfs/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-fs/go-mtpfs
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/go-mtpfs/ChangeLog,v 1.1 2013/10/21 00:59:06 zerochaos Exp $
+
+*go-mtpfs-9999 (21 Oct 2013)
+
+ 21 Oct 2013; Rick Farina <zerochaos@gentoo.org> +go-mtpfs-9999.ebuild,
+ +metadata.xml:
+ go-mtpfs initial commit. can't build yet, can't find go-fuse properly
diff --git a/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild b/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild
new file mode 100644
index 000000000000..ae853d30a75d
--- /dev/null
+++ b/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/go-mtpfs/go-mtpfs-9999.ebuild,v 1.1 2013/10/21 00:59:06 zerochaos Exp $
+
+EAPI=5
+
+inherit git-r3
+
+DESCRIPTION="a simple FUSE filesystem for mounting Android devices as a MTP device"
+HOMEPAGE="https://github.com/hanwen/go-mtpfs"
+EGIT_REPO_URI="https://github.com/hanwen/go-mtpfs.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+COMMON_DEPEND="virtual/libusb"
+DEPEND="${COMMON_DEPEND}
+ dev-lang/go"
+RDEPEND="${COMMON_DEPEND}"
+
+GO_PN="github.com/hanwen/${PN}"
+EGIT_CHECKOUT_DIR="${S}/src/${GO_PN}"
+
+export GOPATH="${S}"
+
+src_compile() {
+ go build -v -x -work ${GO_PN} || die
+}
+
+src_install() {
+ go install -v -x -work ${GO_PN} || die
+}
diff --git a/sys-fs/go-mtpfs/metadata.xml b/sys-fs/go-mtpfs/metadata.xml
new file mode 100644
index 000000000000..4b6b68191d89
--- /dev/null
+++ b/sys-fs/go-mtpfs/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>