summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-04-08 21:23:17 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-04-08 21:23:17 +0000
commita8c15cb647964cc91d83e6bf2456bfe1179d87b9 (patch)
treebfdd6906327a40fe88717fb84b4b20de58a12f7b /sys-fs/lessfs
parentVersion bump (bug #507176). (diff)
downloadgentoo-2-a8c15cb647964cc91d83e6bf2456bfe1179d87b9.tar.gz
gentoo-2-a8c15cb647964cc91d83e6bf2456bfe1179d87b9.tar.bz2
gentoo-2-a8c15cb647964cc91d83e6bf2456bfe1179d87b9.zip
Allow snappy compression via the app-arch/snappy package. Sort dependencies. Make RDEPEND=DEPEND. Bug #502260. Patch by jannis <kripton@kripserver.net>
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'sys-fs/lessfs')
-rw-r--r--sys-fs/lessfs/ChangeLog7
-rw-r--r--sys-fs/lessfs/lessfs-1.7.0.ebuild22
-rw-r--r--sys-fs/lessfs/metadata.xml1
3 files changed, 19 insertions, 11 deletions
diff --git a/sys-fs/lessfs/ChangeLog b/sys-fs/lessfs/ChangeLog
index abc6ab7d194f..e4ad99ef4165 100644
--- a/sys-fs/lessfs/ChangeLog
+++ b/sys-fs/lessfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/lessfs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lessfs/ChangeLog,v 1.64 2014/01/17 14:37:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lessfs/ChangeLog,v 1.65 2014/04/08 21:23:17 hwoarang Exp $
+
+ 08 Apr 2014; Markos Chandras <hwoarang@gentoo.org> lessfs-1.7.0.ebuild,
+ metadata.xml:
+ Allow snappy compression via the app-arch/snappy package. Sort dependencies.
+ Make RDEPEND=DEPEND. Bug #502260. Patch by jannis <kripton@kripserver.net>
17 Jan 2014; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Spelling.
diff --git a/sys-fs/lessfs/lessfs-1.7.0.ebuild b/sys-fs/lessfs/lessfs-1.7.0.ebuild
index f617b9079efc..5f87f224ecf1 100644
--- a/sys-fs/lessfs/lessfs-1.7.0.ebuild
+++ b/sys-fs/lessfs/lessfs-1.7.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lessfs/lessfs-1.7.0.ebuild,v 1.1 2013/11/23 23:26:42 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lessfs/lessfs-1.7.0.ebuild,v 1.2 2014/04/08 21:23:17 hwoarang Exp $
EAPI="5"
inherit readme.gentoo
@@ -14,16 +14,17 @@ SRC_URI="mirror://sourceforge/${PN}/${PN}/${MY_P}/${MY_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="berkdb crypt debug filelog memtrace lzo"
+IUSE="berkdb crypt debug filelog memtrace lzo snappy"
DEPEND="berkdb? ( sys-libs/db )
- >=dev-db/tokyocabinet-1.4.42
- app-crypt/mhash
- >=sys-fs/fuse-2.8.0
- crypt? ( dev-libs/openssl )
- lzo? ( dev-libs/lzo )"
+ crypt? ( dev-libs/openssl )
+ lzo? ( dev-libs/lzo )
+ snappy? ( app-arch/snappy )
+ >=dev-db/tokyocabinet-1.4.42
+ app-crypt/mhash
+ >=sys-fs/fuse-2.8.0"
-RDEPEND=""
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -36,7 +37,8 @@ src_configure() {
$(use_enable debug) $(use_enable debug lckdebug) \
$(use_enable filelog) $(use_with crypt crypto) \
$(use_with lzo) $(use_enable memtrace) \
- $(use_with berkdb berkeleydb)
+ $(use_with berkdb berkeleydb) \
+ $(use_with snappy)
}
src_install () {
diff --git a/sys-fs/lessfs/metadata.xml b/sys-fs/lessfs/metadata.xml
index 3b9fe850a96e..61e0ada7d46e 100644
--- a/sys-fs/lessfs/metadata.xml
+++ b/sys-fs/lessfs/metadata.xml
@@ -8,6 +8,7 @@
<use>
<flag name="filelog">Enable the ability to log to a file instead of syslog</flag>
<flag name="memtrace">Enable leefs to create a report regarding the memory allocation. This feature should be used for debugging purposes to avoid performance degradation</flag>
+<flag name="snappy">Enable snappy compression using the <pkg>app-arch/snappy</pkg> library</flag>
</use>
<longdescription lang="en">
Data deduplication (often called “intelligent compression” or “single-instance storage”) is a method of reducing storage needs by eliminating redundant data. Data deduplication is often used for backup purposes and for virtual machine image storage. lessfs can determine if data is redundant by calculating a unique (192 bit) tiger hash of each block of data that is written. When lessfs has determined that a block of data needs to be stored it first compresses the block with LZO or QUICKLZ compression. The combination of these two techniques results in a very high overall compression rate for many types of data. Multimedia files like mp3, avi or jpg files can not be compressed by lessfs when they are only stored once on the filesystem.