summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-07-29 22:34:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-07-29 22:34:42 +0000
commit79359a65d901b497cd0b7463ece11ae2046a61b2 (patch)
tree5f16a9273d1c78cb34dfcd8209ad8b802c26e80d /sys-fs/lvm2
parentAdd ~amd64 for lvm2. It compiles for me. (diff)
downloadgentoo-2-79359a65d901b497cd0b7463ece11ae2046a61b2.tar.gz
gentoo-2-79359a65d901b497cd0b7463ece11ae2046a61b2.tar.bz2
gentoo-2-79359a65d901b497cd0b7463ece11ae2046a61b2.zip
Version bump per bug #183185.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'sys-fs/lvm2')
-rw-r--r--sys-fs/lvm2/ChangeLog7
-rw-r--r--sys-fs/lvm2/files/digest-lvm2-2.02.273
-rw-r--r--sys-fs/lvm2/lvm2-2.02.27.ebuild115
3 files changed, 124 insertions, 1 deletions
diff --git a/sys-fs/lvm2/ChangeLog b/sys-fs/lvm2/ChangeLog
index 51210108ae8c..f6ef21770149 100644
--- a/sys-fs/lvm2/ChangeLog
+++ b/sys-fs/lvm2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/lvm2
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.104 2007/05/31 14:34:11 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.105 2007/07/29 22:34:42 robbat2 Exp $
+
+*lvm2-2.02.27 (29 Jul 2007)
+
+ 29 Jul 2007; Robin H. Johnson <robbat2@gentoo.org> +lvm2-2.02.27.ebuild:
+ Version bump per bug #183185.
31 May 2007; Doug Goldstein <cardoe@gentoo.org> files/lvm2-start.sh:
Fix from Jimmy.Jazz@gmx.net in bug #180340 where we would fail to boot
diff --git a/sys-fs/lvm2/files/digest-lvm2-2.02.27 b/sys-fs/lvm2/files/digest-lvm2-2.02.27
new file mode 100644
index 000000000000..f8383e3a7737
--- /dev/null
+++ b/sys-fs/lvm2/files/digest-lvm2-2.02.27
@@ -0,0 +1,3 @@
+MD5 f3655af297a2b1ce6a3390ab1c264e68 LVM2.2.02.27.tgz 520415
+RMD160 a6b767800a211b91f180194a9103bb547bc7cc94 LVM2.2.02.27.tgz 520415
+SHA256 aa39bba902396e766c4573511f693235fc6ce132e716e2aea3ba2b9e18adb1a7 LVM2.2.02.27.tgz 520415
diff --git a/sys-fs/lvm2/lvm2-2.02.27.ebuild b/sys-fs/lvm2/lvm2-2.02.27.ebuild
new file mode 100644
index 000000000000..ca8fe7613b75
--- /dev/null
+++ b/sys-fs/lvm2/lvm2-2.02.27.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.27.ebuild,v 1.1 2007/07/29 22:34:42 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="User-land utilities for LVM2 (device-mapper) software."
+HOMEPAGE="http://sources.redhat.com/lvm2/"
+SRC_URI="ftp://sources.redhat.com/pub/lvm2/${PN/lvm/LVM}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="readline nolvmstatic clvm cman gulm nolvm1 nosnapshots nomirrors selinux"
+
+DEPEND=">=sys-fs/device-mapper-1.02.19
+ clvm? ( >=sys-cluster/dlm-1.01.00
+ cman? ( >=sys-cluster/cman-1.01.00 )
+ gulm? ( >=sys-cluster/gulm-1.00.00 ) )"
+
+RDEPEND="${DEPEND}
+ !sys-fs/lvm-user
+ !sys-fs/clvm"
+
+S="${WORKDIR}/${PN/lvm/LVM}.${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+ #epatch ${FILESDIR}/lvm2-2.02.04-vgid.patch
+}
+
+src_compile() {
+ # Static compile of lvm2 so that the install described in the handbook works
+ # http://www.gentoo.org/doc/en/lvm2.xml
+ # fixes http://bugs.gentoo.org/show_bug.cgi?id=84463
+ local myconf
+
+ if ! use nolvmstatic
+ then
+ myconf="${myconf} --enable-static_link"
+ use nosnapshots || myconf="${myconf} --with-snapshots=internal"
+ use nomirrors || myconf="${myconf} --with-mirrors=internal"
+ if use nolvm1
+ then
+ myconf="${myconf} --with-lvm1=none"
+ else
+ myconf="${myconf} --with-lvm1=internal"
+ fi
+ else
+ use nosnapshots || myconf="${myconf} --with-snapshots=shared"
+ use nomirrors || myconf="${myconf} --with-mirrors=shared"
+ if use nolvm1
+ then
+ myconf="${myconf} --with-lvm1=none"
+ else
+ myconf="${myconf} --with-lvm1=shared"
+ fi
+ fi
+
+ # disable O_DIRECT support on hppa, breaks pv detection (#99532)
+ use hppa && myconf="${myconf} --disable-o_direct"
+
+ if use clvm; then
+ if use nolvmstatic
+ then
+ myconf="${myconf} --with-cluster=shared"
+ else
+ myconf="${myconf} --with-cluster=internal"
+ fi
+ if useq cman && useq gulm; then
+ myconf="${myconf} --with-clvmd=all"
+ fi
+ if useq cman && ! useq gulm; then
+ myconf="${myconf} --with-clvmd=cman"
+ fi
+ if useq gulm && ! useq cman; then
+ myconf="${myconf} --with-clvmd=gulm"
+ fi
+ if ! useq gulm && ! useq cman; then
+ myconf="${myconf} --with-clvmd=none"
+ fi
+ fi
+
+ econf $(use_enable readline) $(use_enable selinux) ${myconf} || die
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall sbindir="${D}/sbin" staticdir="${D}/sbin" confdir="${D}/etc/lvm"
+ mv -f "${D}/sbin/lvm.static" "${D}/sbin/lvm"
+
+ dodoc COPYING* INSTALL README VERSION WHATS_NEW doc/*.{conf,c,txt}
+ insinto /lib/rcscripts/addons
+ newins ${FILESDIR}/lvm2-start.sh lvm-start.sh || die
+ newins ${FILESDIR}/lvm2-stop.sh lvm-stop.sh || die
+ newinitd ${FILESDIR}/lvm.rc lvm || die
+ if use clvm; then
+ newinitd ${FILESDIR}/clvmd.rc clvmd || die
+ fi
+
+ ewarn "use flag nocman is deprecated and replaced"
+ ewarn "with cman and gulm use flags."
+ ewarn ""
+ ewarn "use flags clvm,cman and gulm are masked"
+ ewarn "by default and need to be unmasked to use them"
+ ewarn ""
+ ewarn "Rebuild your genkernel initramfs if you are using lvm"
+}
+
+pkg_postinst() {
+ elog "lvm volumes are no longer automatically created for"
+ elog "baselayout-2 users. If you are using baselayout-2, be sure to"
+ elog "run: # rc-update add lvm boot"
+}