summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-07-17 07:03:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-07-17 07:03:55 +0000
commit70414f94b8e29ecf1c937545de7fde8eeb7e7474 (patch)
treee0f1797bd7c40ec53327b0b944eff60b15ffaf6e /sys-fs/mdadm
parentbug 506390, clean old, update to distutils-r1. proxy for SN (Enlik) (diff)
downloadgentoo-2-70414f94b8e29ecf1c937545de7fde8eeb7e7474.tar.gz
gentoo-2-70414f94b8e29ecf1c937545de7fde8eeb7e7474.tar.bz2
gentoo-2-70414f94b8e29ecf1c937545de7fde8eeb7e7474.zip
Fix corruption of udev rules and/or systemd service files because of parallel make wrt #517218 by splitting installation of targets "install" and "install-systemd" to separate lines. Thanks to Mark R. Pariente for reporting.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-fs/mdadm')
-rw-r--r--sys-fs/mdadm/ChangeLog9
-rw-r--r--sys-fs/mdadm/mdadm-3.3.1-r1.ebuild83
2 files changed, 91 insertions, 1 deletions
diff --git a/sys-fs/mdadm/ChangeLog b/sys-fs/mdadm/ChangeLog
index ce2fac91d57d..d53db85da5e9 100644
--- a/sys-fs/mdadm/ChangeLog
+++ b/sys-fs/mdadm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/mdadm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/ChangeLog,v 1.178 2014/07/14 18:08:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/ChangeLog,v 1.179 2014/07/17 07:03:55 ssuominen Exp $
+
+*mdadm-3.3.1-r1 (17 Jul 2014)
+
+ 17 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> +mdadm-3.3.1-r1.ebuild:
+ Fix corruption of udev rules and/or systemd service files because of parallel
+ make wrt #517218 by splitting installation of targets "install" and "install-
+ systemd" to separate lines. Thanks to Mark R. Pariente for reporting.
*mdadm-3.3.1 (14 Jul 2014)
diff --git a/sys-fs/mdadm/mdadm-3.3.1-r1.ebuild b/sys-fs/mdadm/mdadm-3.3.1-r1.ebuild
new file mode 100644
index 000000000000..59a4d83df4c4
--- /dev/null
+++ b/sys-fs/mdadm/mdadm-3.3.1-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-3.3.1-r1.ebuild,v 1.1 2014/07/17 07:03:55 ssuominen Exp $
+
+EAPI="4"
+inherit multilib flag-o-matic systemd toolchain-funcs udev
+
+DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
+HOMEPAGE="http://neil.brown.name/blog/mdadm"
+DEB_PR=2
+SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.xz
+ mirror://debian/pool/main/m/mdadm/${PN}_3.3-${DEB_PR}.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+DEPEND="virtual/pkgconfig
+ app-arch/xz-utils"
+RDEPEND=">=sys-apps/util-linux-2.16"
+
+# The tests edit values in /proc and run tests on software raid devices.
+# Thus, they shouldn't be run on systems with active software RAID devices.
+RESTRICT="test"
+
+mdadm_emake() {
+ emake \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ CC="$(tc-getCC)" \
+ CWFLAGS="-Wall" \
+ CXFLAGS="${CFLAGS}" \
+ MAP_DIR=/run/mdadm \
+ UDEVDIR="$(get_udevdir)" \
+ SYSTEMD_DIR="$(systemd_get_unitdir)" \
+ "$@"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ mdadm_emake all mdassemble
+}
+
+src_test() {
+ mdadm_emake test
+
+ sh ./test || die
+}
+
+src_install() {
+ # Use split lines because of bug #517218
+ mdadm_emake DESTDIR="${D}" install
+ mdadm_emake DESTDIR="${D}" install-systemd
+ into /
+ dosbin mdassemble
+ dodoc ChangeLog INSTALL TODO README* ANNOUNCE-${PV}
+
+ insinto /etc
+ newins mdadm.conf-example mdadm.conf
+ newinitd "${FILESDIR}"/mdadm.rc mdadm
+ newconfd "${FILESDIR}"/mdadm.confd mdadm
+ newinitd "${FILESDIR}"/mdraid.rc mdraid
+ newconfd "${FILESDIR}"/mdraid.confd mdraid
+
+ # From the Debian patchset
+ into /usr
+ dodoc "${WORKDIR}"/debian/README.checkarray
+ dosbin "${WORKDIR}"/debian/checkarray
+
+ insinto /etc/cron.weekly
+ newins "${FILESDIR}"/mdadm.weekly mdadm
+}
+
+pkg_postinst() {
+ if ! systemd_is_booted; then
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ # Only inform people the first time they install.
+ elog "If you're not relying on kernel auto-detect of your RAID"
+ elog "devices, you need to add 'mdraid' to your 'boot' runlevel:"
+ elog " rc-update add mdraid boot"
+ fi
+ fi
+}