summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2007-01-16 03:14:25 +0000
committerPatrick McLean <chutzpah@gentoo.org>2007-01-16 03:14:25 +0000
commit70b512174d72d18a155e1d1cb3b7ade43e742fee (patch)
tree99b5926fe599d8890aec660cbd2baae4b9dbd50e /sys-fs/ntfs3g
parentMarked ~hppa (bug #158377). (diff)
downloadgentoo-2-70b512174d72d18a155e1d1cb3b7ade43e742fee.tar.gz
gentoo-2-70b512174d72d18a155e1d1cb3b7ade43e742fee.tar.bz2
gentoo-2-70b512174d72d18a155e1d1cb3b7ade43e742fee.zip
Version bump.
(Portage version: 2.1.2)
Diffstat (limited to 'sys-fs/ntfs3g')
-rw-r--r--sys-fs/ntfs3g/ChangeLog8
-rw-r--r--sys-fs/ntfs3g/files/digest-ntfs3g-0.200701163
-rw-r--r--sys-fs/ntfs3g/ntfs3g-0.20070116.ebuild54
3 files changed, 64 insertions, 1 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index cf350460258a..aad7a9eeca78 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.18 2007/01/01 23:12:27 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.19 2007/01/16 03:14:24 chutzpah Exp $
+
+*ntfs3g-0.20070116 (16 Jan 2007)
+
+ 16 Jan 2007; Patrick McLean <chutzpah@gentoo.org>
+ +ntfs3g-0.20070116.ebuild:
+ Version bump.
*ntfs3g-0.20070102 (01 Jan 2007)
diff --git a/sys-fs/ntfs3g/files/digest-ntfs3g-0.20070116 b/sys-fs/ntfs3g/files/digest-ntfs3g-0.20070116
new file mode 100644
index 000000000000..07d0a1aa419d
--- /dev/null
+++ b/sys-fs/ntfs3g/files/digest-ntfs3g-0.20070116
@@ -0,0 +1,3 @@
+MD5 e936bc3570aa8fb183cd37b319e9f8a4 ntfs-3g-0.20070116-BETA.tgz 562334
+RMD160 fffa16eb4dbeede46a29ac8c61ba13a5724a3f1a ntfs-3g-0.20070116-BETA.tgz 562334
+SHA256 59f8e34ad5790c3ae1a315618621040006bdb62618c984e6f5d7a051440b3e1a ntfs-3g-0.20070116-BETA.tgz 562334
diff --git a/sys-fs/ntfs3g/ntfs3g-0.20070116.ebuild b/sys-fs/ntfs3g/ntfs3g-0.20070116.ebuild
new file mode 100644
index 000000000000..89da4f845b26
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-0.20070116.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-0.20070116.ebuild,v 1.1 2007/01/16 03:14:24 chutzpah Exp $
+
+inherit linux-info
+
+MY_PN="${PN/3g/-3g}"
+MY_PV="${PV}-BETA"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.ntfs-3g.org"
+SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/fuse-2.6.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="!FUSE_FS"
+ERR=" ${BAD}*${NORMAL} "
+ERROR_FUSE_FS="For this version of ntfs-3g to work properly, you need to use the
+$ERR kernel module included in the package, not the kernel version. To do this
+$ERR remove FUSE from your kernel, recompile it then remerge FUSE.
+$ERR
+$ERR emerge -a1 sys-fs/fuse
+$ERR
+$ERR You will need to reboot if you had FUSE in your kernel, if it was a module, this
+$ERR should be enough:
+$ERR
+$ERR modprobe -r fuse
+$ERR modprobe fuse
+$ERR
+$ERR If either of these commands have an error, you will need to reboot.
+$ERR"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # default makefile calls ldconfig
+ sed -ie '/ldconfig$/ d' src/Makefile.*
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog CREDITS NEWS README
+}