summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-01-06 08:17:49 +0000
committerTim Harder <radhermit@gentoo.org>2013-01-06 08:17:49 +0000
commita57713af67ff1a95b849a8e1acd5825c3005063d (patch)
tree7cc8c9d01aeb6c1b248a77a885b3e22146f5459a /sys-fs/s3ql
parentAdded unzip to DEPEND, picked up and thx to Arferever (diff)
downloadgentoo-2-a57713af67ff1a95b849a8e1acd5825c3005063d.tar.gz
gentoo-2-a57713af67ff1a95b849a8e1acd5825c3005063d.tar.bz2
gentoo-2-a57713af67ff1a95b849a8e1acd5825c3005063d.zip
Revision bump. Migrate to distutils-r1.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-fs/s3ql')
-rw-r--r--sys-fs/s3ql/ChangeLog9
-rw-r--r--sys-fs/s3ql/s3ql-1.12-r1.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/sys-fs/s3ql/ChangeLog b/sys-fs/s3ql/ChangeLog
index 0b37c1d2cbf3..3bbe3a7a95f5 100644
--- a/sys-fs/s3ql/ChangeLog
+++ b/sys-fs/s3ql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/s3ql
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3ql/ChangeLog,v 1.11 2012/10/29 16:39:50 mgorny Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3ql/ChangeLog,v 1.12 2013/01/06 08:17:49 radhermit Exp $
+
+*s3ql-1.12-r1 (06 Jan 2013)
+
+ 06 Jan 2013; Tim Harder <radhermit@gentoo.org> +s3ql-1.12-r1.ebuild:
+ Revision bump. Migrate to distutils-r1.
29 Oct 2012; Michał Górny <mgorny@gentoo.org> s3ql-1.11.1.ebuild,
s3ql-1.12.ebuild:
diff --git a/sys-fs/s3ql/s3ql-1.12-r1.ebuild b/sys-fs/s3ql/s3ql-1.12-r1.ebuild
new file mode 100644
index 000000000000..3c30c012b225
--- /dev/null
+++ b/sys-fs/s3ql/s3ql-1.12-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3ql/s3ql-1.12-r1.ebuild,v 1.1 2013/01/06 08:17:49 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A full-featured file system for online data storage"
+HOMEPAGE="http://code.google.com/p/s3ql/"
+SRC_URI="http://s3ql.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="contrib doc test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/apsw-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/llfuse-0.37[${PYTHON_USEDEP}]
+ dev-python/pycryptopp[${PYTHON_USEDEP}]
+ dev-python/pyliblzma[${PYTHON_USEDEP}]
+ sys-fs/fuse
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ net-misc/rsync[xattr]
+ dev-python/unittest2
+ )"
+
+python_test() {
+ if [[ ${EUID} -ne 0 ]] ; then
+ ewarn "Skipping tests: root privileges are required so userpriv must be disabled"
+ else
+ addwrite /dev/fuse
+ esetup.py test
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use contrib ; then
+ exeinto /usr/share/doc/${PF}/contrib
+ docompress -x /usr/share/doc/${PF}/contrib
+ doexe contrib/*.{py,sh}
+ doman contrib/*.1
+ fi
+
+ if use doc ; then
+ dodoc doc/manual.pdf
+ dohtml -r doc/html/*
+ fi
+}