summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-21 10:25:49 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-21 10:25:49 +0000
commitd60748047b98541c115bb2036f1e9ec736293d91 (patch)
treee3c2bf8f7cfc32e3b1b2904b1adf5af78785dbfd /sys-fs/squashfs-tools
parentVersion bump. Ebuild changes by Tomas Cech of SuSe to properly install docume... (diff)
downloadgentoo-2-d60748047b98541c115bb2036f1e9ec736293d91.tar.gz
gentoo-2-d60748047b98541c115bb2036f1e9ec736293d91.tar.bz2
gentoo-2-d60748047b98541c115bb2036f1e9ec736293d91.zip
sys-fs/squashfs-tools: Version bump, following Fedora, #479904
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-fs/squashfs-tools')
-rw-r--r--sys-fs/squashfs-tools/ChangeLog8
-rw-r--r--sys-fs/squashfs-tools/metadata.xml8
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.3_pre20130621.ebuild58
3 files changed, 69 insertions, 5 deletions
diff --git a/sys-fs/squashfs-tools/ChangeLog b/sys-fs/squashfs-tools/ChangeLog
index f0264018ea1e..d89adea989c1 100644
--- a/sys-fs/squashfs-tools/ChangeLog
+++ b/sys-fs/squashfs-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/squashfs-tools
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.90 2014/01/18 11:37:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.91 2014/01/21 10:25:49 jlec Exp $
+
+*squashfs-tools-4.3_pre20130621 (21 Jan 2014)
+
+ 21 Jan 2014; Justin Lecher <jlec@gentoo.org>
+ +squashfs-tools-4.3_pre20130621.ebuild, metadata.xml:
+ Version bump, following Fedora, #479904
18 Jan 2014; Mike Frysinger <vapier@gentoo.org> squashfs-tools-4.2-r1.ebuild,
squashfs-tools-4.2.ebuild, squashfs-tools-4.2_p20121216.ebuild:
diff --git a/sys-fs/squashfs-tools/metadata.xml b/sys-fs/squashfs-tools/metadata.xml
index 8a76920d75bf..e1c66a45635b 100644
--- a/sys-fs/squashfs-tools/metadata.xml
+++ b/sys-fs/squashfs-tools/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>livecd</herd>
- <use>
- <flag name="xz">Enable support for XZ ("LZMA2") compression using <pkg>app-arch/xz-utils</pkg></flag>
- </use>
+ <herd>livecd</herd>
+ <use>
+ <flag name="xz">Enable support for XZ ("LZMA2") compression using <pkg>app-arch/xz-utils</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.3_pre20130621.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.3_pre20130621.ebuild
new file mode 100644
index 000000000000..0a3419514566
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.3_pre20130621.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-4.3_pre20130621.ebuild,v 1.1 2014/01/21 10:25:49 jlec Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="http://squashfs.sourceforge.net"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE="+xz lzma lzo xattr"
+
+RDEPEND="
+ sys-libs/zlib
+ xz? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo )
+ lzma? ( app-arch/xz-utils )
+ !xz? ( !lzo? ( sys-libs/zlib ) )
+ xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}/squashfs-tools"
+
+use_sed() {
+ local u=$1 s="${2:-`echo $1 | tr '[:lower:]' '[:upper:]'`}_SUPPORT"
+ printf '/^#?%s =/%s\n' "${s}" \
+ "$( use $u && echo s:.*:${s} = 1: || echo d )"
+}
+
+_src_prepare() {
+ epatch "${WORKDIR}"/${P}.patch
+}
+
+src_configure() {
+ tc-export CC
+ sed -i -r \
+ -e "$(use_sed xz XZ)" \
+ -e "$(use_sed lzo)" \
+ -e "$(use_sed xattr)" \
+ -e "$(use_sed lzma LZMA_XZ)" \
+ Makefile || die
+}
+
+src_install() {
+ dobin mksquashfs unsquashfs
+ dodoc ../README
+}
+
+pkg_postinst() {
+ ewarn "This version of mksquashfs requires a 2.6.29 kernel or better"
+ use xz &&
+ ewarn "XZ support requires a 2.6.38 kernel or better"
+}