summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2008-03-11 20:24:29 +0000
committerStefan Schweizer <genstef@gentoo.org>2008-03-11 20:24:29 +0000
commit2f7975e5b8797ec2a92f46d40d1994fb70165f64 (patch)
treee4a3503657e7a2098c02fc535a968aea93e494be /sys-fs
parentStable on x86 wrt bug #212917 (diff)
downloadgentoo-2-2f7975e5b8797ec2a92f46d40d1994fb70165f64.tar.gz
gentoo-2-2f7975e5b8797ec2a92f46d40d1994fb70165f64.tar.bz2
gentoo-2-2f7975e5b8797ec2a92f46d40d1994fb70165f64.zip
2.6.23 compatibility thanks to René Rhéaume (a.k.a. repzilon, rener) <rene.rheaume@videotron.qc.ca> and Alexander Skwar <askwar@digitalprojects.com> in bug 196566
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cloop/cloop-2.624.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-fs/cloop/cloop-2.624.ebuild b/sys-fs/cloop/cloop-2.624.ebuild
new file mode 100644
index 000000000000..2d9e6776088f
--- /dev/null
+++ b/sys-fs/cloop/cloop-2.624.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-2.624.ebuild,v 1.1 2008/03/11 20:24:29 genstef Exp $
+
+inherit linux-mod
+
+DESCRIPTION="Compressed filesystem loopback kernel module"
+HOMEPAGE="http://packages.debian.org/unstable/source/cloop http://www.knopper.net/knoppix"
+SRC_URI="http://debian-knoppix.alioth.debian.org/sources/${PN}_${PV}-1.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+pkg_setup() {
+ kernel_is 2 4 && die "kernel 2.4 is not supported"
+ CONFIG_CHECK="ZLIB_INFLATE"
+ MODULE_NAMES="cloop(fs:)"
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KVERSION=${KV_FULL} KERNEL_DIR=${KV_DIR}"
+ linux-mod_pkg_setup
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dobin create_compressed_fs extract_compressed_fs
+ cp debian/create_compressed_fs.1 debian/extract_compressed_fs.1
+ doman debian/create_compressed_fs.1 debian/extract_compressed_fs.1
+ dodoc CHANGELOG README
+}