summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-05-06 21:56:09 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-05-06 21:56:09 +0000
commit554bf039ff34cadbbf9ad3e2523c3c866a5b0933 (patch)
tree5a1e44339eca649d2099b80dcc449df3816742d1 /sys-fs
parentversion bump (diff)
downloadgentoo-2-554bf039ff34cadbbf9ad3e2523c3c866a5b0933.tar.gz
gentoo-2-554bf039ff34cadbbf9ad3e2523c3c866a5b0933.tar.bz2
gentoo-2-554bf039ff34cadbbf9ad3e2523c3c866a5b0933.zip
Make avfs ready for worker thanks to dertobi123 in bug 177125
(Portage version: 2.1.2.5)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/avfs/ChangeLog7
-rw-r--r--sys-fs/avfs/avfs-0.9.7-r1.ebuild54
-rw-r--r--sys-fs/avfs/files/digest-avfs-0.9.7-r13
3 files changed, 63 insertions, 1 deletions
diff --git a/sys-fs/avfs/ChangeLog b/sys-fs/avfs/ChangeLog
index d614ec0c8a83..b615e9839f92 100644
--- a/sys-fs/avfs/ChangeLog
+++ b/sys-fs/avfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/avfs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/ChangeLog,v 1.8 2007/05/05 11:33:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/ChangeLog,v 1.9 2007/05/06 21:56:09 genstef Exp $
+
+*avfs-0.9.7-r1 (06 May 2007)
+
+ 06 May 2007; Stefan Schweizer <genstef@gentoo.org> +avfs-0.9.7-r1.ebuild:
+ Make avfs ready for worker thanks to dertobi123 in bug 177125
05 May 2007; Jeroen Roovers <jer@gentoo.org> avfs-0.9.7.ebuild:
Marked ~hppa (bug #172755).
diff --git a/sys-fs/avfs/avfs-0.9.7-r1.ebuild b/sys-fs/avfs/avfs-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..a13b216c5231
--- /dev/null
+++ b/sys-fs/avfs/avfs-0.9.7-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/avfs-0.9.7-r1.ebuild,v 1.1 2007/05/06 21:56:09 genstef Exp $
+
+inherit linux-info
+
+DESCRIPTION="AVFS is a virtual filesystem that allows browsing of compressed files."
+HOMEPAGE="http://sourceforge.net/projects/avf"
+SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~sparc ~x86"
+
+DEPEND=">=sys-fs/fuse-2.4"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ kernel_is lt 2 6 && die "Must have a version 2.6 kernel. Cannot continue. :("
+}
+
+src_compile() {
+ econf --enable-fuse --enable-library || die "Sorry, can't configure :("
+ emake || die "Sorry make failed :("
+}
+
+src_install() {
+ einstall || die "Sorry, make install failed :("
+ # remove cruft
+ dobin scripts/avfs-config
+ cd ${D}/usr
+ rm -f bin/davpass bin/ftppass
+ rm -fr sbin ../etc
+ cd ${S}
+ cd doc
+ dodoc api-overview background FORMAT INSTALL.* README.avfs-fuse
+ cd ..
+ dodoc AUTHORS ChangeLog COPYING* INSTALL NEWS README TODO
+ docinto scripts
+ dodoc scripts/avfs* scripts/*pass scripts/*mountavfs
+ dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
+}
+
+pkg_postinst() {
+ einfo "This version of AVFS includes FUSE support. It is user-based."
+ einfo "To execute:"
+ einfo "1) as user, mkdir ~/.avfs"
+ einfo "2) make sure fuse is either compiled into the kernel OR"
+ einfo " modprobe fuse or add to startup."
+ einfo "3) run mountavfs"
+ einfo "To unload daemon, type umountavfs"
+ echo
+ einfo "READ the documentation! Enjoy :)"
+}
diff --git a/sys-fs/avfs/files/digest-avfs-0.9.7-r1 b/sys-fs/avfs/files/digest-avfs-0.9.7-r1
new file mode 100644
index 000000000000..88bed1c7ef24
--- /dev/null
+++ b/sys-fs/avfs/files/digest-avfs-0.9.7-r1
@@ -0,0 +1,3 @@
+MD5 d1d6b33c56213618d158cde3507d9b3a avfs-0.9.7.tar.bz2 575400
+RMD160 5df6a81667e874987785fa2a932e449fcafb6913 avfs-0.9.7.tar.bz2 575400
+SHA256 5912997ab8b3f60674935db85891aecfc8cf3d86df593a5e115172d0b581d3aa avfs-0.9.7.tar.bz2 575400