summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-07-27 18:52:25 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-07-27 18:52:25 +0000
commit58639797db3a0498b13da90dfe631cd24752079e (patch)
tree5a94707e5018bf97f2e9cee5c6f1a19ff0f03f30 /sys-fs
parentamd64 stable, bug 264658 (diff)
downloadgentoo-2-58639797db3a0498b13da90dfe631cd24752079e.tar.gz
gentoo-2-58639797db3a0498b13da90dfe631cd24752079e.tar.bz2
gentoo-2-58639797db3a0498b13da90dfe631cd24752079e.zip
Bug #329991: Document that users of plain (non-LUKS) volumes from the 1.0 series MUST specify the cipher/keysize/hash, as the defaults have changed for security reasons.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptsetup/ChangeLog8
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.1.2.ebuild8
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.1.3.ebuild8
3 files changed, 21 insertions, 3 deletions
diff --git a/sys-fs/cryptsetup/ChangeLog b/sys-fs/cryptsetup/ChangeLog
index 760170f0d8b0..e395aa7e4480 100644
--- a/sys-fs/cryptsetup/ChangeLog
+++ b/sys-fs/cryptsetup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/cryptsetup
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.88 2010/07/27 18:46:32 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.89 2010/07/27 18:52:25 robbat2 Exp $
+
+ 27 Jul 2010; Robin H. Johnson <robbat2@gentoo.org>
+ cryptsetup-1.1.2.ebuild, cryptsetup-1.1.3.ebuild:
+ Bug #329991: Document that users of plain (non-LUKS) volumes from the 1.0
+ series MUST specify the cipher/keysize/hash, as the defaults have changed
+ for security reasons.
27 Jul 2010; Pacho Ramos <pacho@gentoo.org> cryptsetup-1.1.2.ebuild:
amd64 stable, bug 327689
diff --git a/sys-fs/cryptsetup/cryptsetup-1.1.2.ebuild b/sys-fs/cryptsetup/cryptsetup-1.1.2.ebuild
index 37571887957b..201defeee80f 100644
--- a/sys-fs/cryptsetup/cryptsetup-1.1.2.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-1.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.1.2.ebuild,v 1.3 2010/07/27 18:46:32 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.1.2.ebuild,v 1.4 2010/07/27 18:52:25 robbat2 Exp $
EAPI=2
@@ -91,4 +91,10 @@ pkg_postinst() {
elog "after 10 seconds add the following to your bootloader config:"
elog "key_timeout=10"
elog "A timeout of 0 will mean it will wait indefinitely."
+ elog
+ elog "Users using cryptsetup-1.0.x (dm-crypt plain) volumes must use"
+ elog "a compatibility mode when using cryptsetup-1.1.x. This can be"
+ elog "done by specifying the cipher (-c), key size (-s) and hash (-h)."
+ elog "For more info, see http://code.google.com/p/cryptsetup/wiki/FrequentlyAskedQuestions#6._Issues_with_Specific_Versions_of_cryptsetup"
+
}
diff --git a/sys-fs/cryptsetup/cryptsetup-1.1.3.ebuild b/sys-fs/cryptsetup/cryptsetup-1.1.3.ebuild
index ee65bb8010bb..1b9870d2f892 100644
--- a/sys-fs/cryptsetup/cryptsetup-1.1.3.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-1.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.1.3.ebuild,v 1.1 2010/07/21 19:31:27 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.1.3.ebuild,v 1.2 2010/07/27 18:52:25 robbat2 Exp $
EAPI=2
@@ -91,4 +91,10 @@ pkg_postinst() {
elog "after 10 seconds add the following to your bootloader config:"
elog "key_timeout=10"
elog "A timeout of 0 will mean it will wait indefinitely."
+ elog
+ elog "Users using cryptsetup-1.0.x (dm-crypt plain) volumes must use"
+ elog "a compatibility mode when using cryptsetup-1.1.x. This can be"
+ elog "done by specifying the cipher (-c), key size (-s) and hash (-h)."
+ elog "For more info, see http://code.google.com/p/cryptsetup/wiki/FrequentlyAskedQuestions#6._Issues_with_Specific_Versions_of_cryptsetup"
+
}