summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-03-07 21:34:40 +0000
committerMike Frysinger <vapier@gentoo.org>2015-03-07 21:34:40 +0000
commit5f827627f56f65bc5f84615414f4661275e78711 (patch)
tree9e598471d0ef4bbe25bdcd3d00f24b1c397c4ccd /sys-fs
parentVersion bump, drop old (diff)
downloadgentoo-2-5f827627f56f65bc5f84615414f4661275e78711.tar.gz
gentoo-2-5f827627f56f65bc5f84615414f4661275e78711.tar.bz2
gentoo-2-5f827627f56f65bc5f84615414f4661275e78711.zip
Add arm64 love.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/ChangeLog8
-rw-r--r--sys-fs/fuse/files/fuse-2.9.3-kernel-types.patch19
-rw-r--r--sys-fs/fuse/fuse-2.9.3.ebuild7
3 files changed, 29 insertions, 5 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 2859bd09935d..93c50c2282b0 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/fuse
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.200 2014/12/15 03:13:20 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.201 2015/03/07 21:34:40 vapier Exp $
+
+ 07 Mar 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/fuse-2.9.3-kernel-types.patch, fuse-2.9.3.ebuild:
+ Add arm64 love.
15 Dec 2014; Tim Harder <radhermit@gentoo.org> -fuse-2.9.2.ebuild:
Remove old.
diff --git a/sys-fs/fuse/files/fuse-2.9.3-kernel-types.patch b/sys-fs/fuse/files/fuse-2.9.3-kernel-types.patch
new file mode 100644
index 000000000000..5065392f09ec
--- /dev/null
+++ b/sys-fs/fuse/files/fuse-2.9.3-kernel-types.patch
@@ -0,0 +1,19 @@
+this is a minimal version of:
+http://sourceforge.net/p/fuse/fuse/ci/6b02a7082ae4c560427ff95b51aa8930bb4a6e1f/
+
+--- a/include/fuse_kernel.h
++++ b/include/fuse_kernel.h
+@@ -88,12 +88,7 @@
+ #ifndef _LINUX_FUSE_H
+ #define _LINUX_FUSE_H
+
+-#include <sys/types.h>
+-#define __u64 uint64_t
+-#define __s64 int64_t
+-#define __u32 uint32_t
+-#define __s32 int32_t
+-#define __u16 uint16_t
++#include <linux/types.h>
+
+ /*
+ * Version negotiation:
diff --git a/sys-fs/fuse/fuse-2.9.3.ebuild b/sys-fs/fuse/fuse-2.9.3.ebuild
index 5fe6181ac03f..227e9b3e3adf 100644
--- a/sys-fs/fuse/fuse-2.9.3.ebuild
+++ b/sys-fs/fuse/fuse-2.9.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.9.3.ebuild,v 1.13 2014/08/10 20:19:38 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.9.3.ebuild,v 1.14 2015/03/07 21:34:40 vapier Exp $
EAPI=5
inherit eutils libtool linux-info udev toolchain-funcs
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
IUSE="examples kernel_linux kernel_FreeBSD static-libs"
PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
@@ -32,6 +32,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-kernel-types.patch
# sandbox violation with mtab writability wrt #438250
# don't sed configure.in without eautoreconf because of maintainer mode
sed -i 's:umount --fake:true --fake:' configure || die