summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-11-01 18:26:23 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-11-01 18:26:23 +0000
commit63e490e78458b9486afe2b471c4cc1ef6a47e3e2 (patch)
tree266b1babb291a108e0e11e690b1dbb1434bb5898 /sys-fs
parentversion bump, bug fixes against wireshark 1.12.x (diff)
downloadgentoo-2-63e490e78458b9486afe2b471c4cc1ef6a47e3e2.tar.gz
gentoo-2-63e490e78458b9486afe2b471c4cc1ef6a47e3e2.tar.bz2
gentoo-2-63e490e78458b9486afe2b471c4cc1ef6a47e3e2.zip
Version bump, bug #510290
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/encfs/ChangeLog10
-rw-r--r--sys-fs/encfs/encfs-1.7.5.ebuild44
-rw-r--r--sys-fs/encfs/files/encfs-1.7.5-fix-pod.patch16
3 files changed, 68 insertions, 2 deletions
diff --git a/sys-fs/encfs/ChangeLog b/sys-fs/encfs/ChangeLog
index bf57e48e64e0..e3c237742b18 100644
--- a/sys-fs/encfs/ChangeLog
+++ b/sys-fs/encfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/encfs
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/ChangeLog,v 1.63 2012/10/31 23:14:20 flameeyes Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/ChangeLog,v 1.64 2014/11/01 18:26:23 blueness Exp $
+
+*encfs-1.7.5 (01 Nov 2014)
+
+ 01 Nov 2014; Anthony G. Basile <blueness@gentoo.org> +encfs-1.7.5.ebuild,
+ +files/encfs-1.7.5-fix-pod.patch:
+ Version bump, bug #510290
31 Oct 2012; Diego E. Pettenò <flameeyes@gentoo.org> encfs-1.7.2.ebuild,
encfs-1.7.4.ebuild:
diff --git a/sys-fs/encfs/encfs-1.7.5.ebuild b/sys-fs/encfs/encfs-1.7.5.ebuild
new file mode 100644
index 000000000000..fa2efa8b3200
--- /dev/null
+++ b/sys-fs/encfs/encfs-1.7.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/encfs-1.7.5.ebuild,v 1.1 2014/11/01 18:26:23 blueness Exp $
+
+EAPI=2
+inherit autotools eutils multilib
+
+DESCRIPTION="An implementation of encrypted filesystem in user-space using FUSE"
+HOMEPAGE="https://vgough.github.io/encfs/"
+SRC_URI="https://github.com/vgough/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="xattr"
+
+RDEPEND=">=dev-libs/boost-1.34
+ >=dev-libs/openssl-0.9.7
+ >=dev-libs/rlog-1.4
+ >=sys-fs/fuse-2.7.0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+ xattr? ( sys-apps/attr )
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}/encfs-1.7.5-fix-pod.patch"
+ eautoreconf
+}
+
+src_configure() {
+ use xattr || export ac_cv_header_attr_xattr_h=no
+
+ econf \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README
+ find "${D}" -name '*.la' -delete
+}
diff --git a/sys-fs/encfs/files/encfs-1.7.5-fix-pod.patch b/sys-fs/encfs/files/encfs-1.7.5-fix-pod.patch
new file mode 100644
index 000000000000..1089a92da286
--- /dev/null
+++ b/sys-fs/encfs/files/encfs-1.7.5-fix-pod.patch
@@ -0,0 +1,16 @@
+diff -Naur encfs-1.7.5.orig/encfs/encfsctl.pod encfs-1.7.5/encfs/encfsctl.pod
+--- encfs-1.7.5.orig/encfs/encfsctl.pod 2011-12-29 17:26:28.000000000 -0500
++++ encfs-1.7.5/encfs/encfsctl.pod 2014-11-01 14:24:48.636330176 -0400
+@@ -1,4 +1,3 @@
+-=cut
+ Copyright (c) 2003-2004, Valient Gough <vgough@pobox.com>
+ All rights reserved.
+
+diff -Naur encfs-1.7.5.orig/encfs/encfs.pod encfs-1.7.5/encfs/encfs.pod
+--- encfs-1.7.5.orig/encfs/encfs.pod 2011-12-29 17:26:28.000000000 -0500
++++ encfs-1.7.5/encfs/encfs.pod 2014-11-01 14:24:51.132330290 -0400
+@@ -1,4 +1,3 @@
+-=cut
+ Copyright (c) 2003-2008, Valient Gough <vgough@pobox.com>
+ All rights reserved.
+