summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-05 23:46:32 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-05 23:46:32 +0000
commit69fd717490eef93ce86be3b50b54b4d3e12f8b0c (patch)
tree86e50d069f6db4e41bff69caefafadad3e3e95a7 /sys-fs
parenttypo (diff)
downloadgentoo-2-69fd717490eef93ce86be3b50b54b4d3e12f8b0c.tar.gz
gentoo-2-69fd717490eef93ce86be3b50b54b4d3e12f8b0c.tar.bz2
gentoo-2-69fd717490eef93ce86be3b50b54b4d3e12f8b0c.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs-fuse/ChangeLog8
-rw-r--r--sys-fs/zfs-fuse/files/zfs-fuse.rc46
-rw-r--r--sys-fs/zfs-fuse/zfs-fuse-0.5.0.ebuild4
-rw-r--r--sys-fs/zfs-fuse/zfs-fuse-0.6.9.ebuild56
4 files changed, 112 insertions, 2 deletions
diff --git a/sys-fs/zfs-fuse/ChangeLog b/sys-fs/zfs-fuse/ChangeLog
index b30fef2dbfad..81bb3f3b4abf 100644
--- a/sys-fs/zfs-fuse/ChangeLog
+++ b/sys-fs/zfs-fuse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/zfs-fuse
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/ChangeLog,v 1.10 2010/06/05 22:21:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/ChangeLog,v 1.11 2010/06/05 23:46:32 ssuominen Exp $
+
+*zfs-fuse-0.6.9 (05 Jun 2010)
+
+ 05 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +zfs-fuse-0.6.9.ebuild, +files/zfs-fuse.rc:
+ Version bump.
05 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> zfs-fuse-0.5.0.ebuild,
-zfs-fuse-9999.ebuild:
diff --git a/sys-fs/zfs-fuse/files/zfs-fuse.rc b/sys-fs/zfs-fuse/files/zfs-fuse.rc
new file mode 100644
index 000000000000..415ea99fc429
--- /dev/null
+++ b/sys-fs/zfs-fuse/files/zfs-fuse.rc
@@ -0,0 +1,46 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/files/zfs-fuse.rc,v 1.3 2010/06/05 23:46:32 ssuominen Exp $
+
+depend() {
+ before net
+ need fuse
+}
+
+PIDFILE="/var/run/zfs/zfs-fuse.pid"
+EXEFILE="/usr/sbin/zfs-fuse"
+
+checksystem() {
+ return 0 # TODO
+}
+
+start() {
+ ebegin "Starting ZFS-FUSE"
+ checksystem || return 1
+ start-stop-daemon --start --exec ${EXEFILE} \
+ --user daemon --group disk -- --pidfile ${PIDFILE}
+ rv=$?
+ eend $rv
+
+ if [[ $rv -eq 0 ]]; then
+ ebegin "Mounting ZFS filesystems"
+ zfs mount -a
+ eend $?
+ fi
+}
+
+stop() {
+ ebegin "Unmounting ZFS filesystems"
+ sync
+ sleep 1
+ zfs umount -f -a
+ eend $?
+ sync
+
+ ebegin "Stopping ZFS-FUSE"
+ checksystem || return 2
+ start-stop-daemon --stop --pidfile ${PIDFILE} \
+ --exec ${EXEFILE} --retry TERM/1/TERM/2/TERM/4/TERM/8/KILL
+ eend $?
+}
diff --git a/sys-fs/zfs-fuse/zfs-fuse-0.5.0.ebuild b/sys-fs/zfs-fuse/zfs-fuse-0.5.0.ebuild
index 968861a00873..094c3ceb2758 100644
--- a/sys-fs/zfs-fuse/zfs-fuse-0.5.0.ebuild
+++ b/sys-fs/zfs-fuse/zfs-fuse-0.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/zfs-fuse-0.5.0.ebuild,v 1.3 2010/06/05 22:21:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/zfs-fuse-0.5.0.ebuild,v 1.4 2010/06/05 23:46:32 ssuominen Exp $
IUSE="doc debug"
@@ -73,6 +73,8 @@ src_install() {
if use doc; then
dodoc {INSTALL,TODO,STATUS,TESTING,HACKING,BUGS} || die
fi
+
+ dodir /etc/zfs
}
pkg_postinst() {
diff --git a/sys-fs/zfs-fuse/zfs-fuse-0.6.9.ebuild b/sys-fs/zfs-fuse/zfs-fuse-0.6.9.ebuild
new file mode 100644
index 000000000000..b28f73671f22
--- /dev/null
+++ b/sys-fs/zfs-fuse/zfs-fuse-0.6.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/zfs-fuse-0.6.9.ebuild,v 1.1 2010/06/05 23:46:32 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="An implementation of the ZFS filesystem for FUSE/Linux"
+HOMEPAGE="http://zfs-fuse.net/"
+SRC_URI="http://zfs-fuse.net/releases/${PV}/source-tar-ball -> ${P}.tar.bz2"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="sys-fs/fuse
+ sys-libs/zlib
+ dev-libs/libaio
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+S=${WORKDIR}/${P}/src
+
+src_prepare() {
+ sed -i \
+ -e '/LINKFLAGS/s:-s::' \
+ -e '/CCFLAGS/s:-s -O2::' \
+ SConstruct || die
+
+ sed -i \
+ -e 's:../zdb/zdb:/usr/sbin/zdb:' \
+ cmd/ztest/ztest.c || die
+}
+
+src_compile() {
+ local _debug=0
+ use debug && _debug=2
+
+ scons debug=${_debug} || die
+}
+
+src_install() {
+ scons \
+ install_dir="${D}/usr/sbin" \
+ man_dir="${D}/usr/share/man/man8" \
+ cfg_dir="${D}/etc/zfs" \
+ install || die
+
+ dodir /etc/zfs
+ keepdir /var/{lock,run}/zfs
+ fowners daemon.disk /var/{lock,run}/zfs
+ newinitd "${FILESDIR}"/${PN}.rc ${PN}
+
+ dodoc ../{BUGS,CHANGES,HACKING,README*,STATUS,TESTING,TODO}
+}