summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2006-11-15 03:23:23 +0000
committerPatrick McLean <chutzpah@gentoo.org>2006-11-15 03:23:23 +0000
commit8a5a860778bf8d2fe780309af3a891e448fe8f86 (patch)
tree92859fc7a20d38cabd0da35d7d938a282b42d10b /sys-fs
parentAdd a locking fix from upstream. Fixes more issues when xcb is enabled. (diff)
downloadgentoo-2-8a5a860778bf8d2fe780309af3a891e448fe8f86.tar.gz
gentoo-2-8a5a860778bf8d2fe780309af3a891e448fe8f86.tar.bz2
gentoo-2-8a5a860778bf8d2fe780309af3a891e448fe8f86.zip
Version bump, update FUSE depend to 2.6.0.
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g/ChangeLog8
-rw-r--r--sys-fs/ntfs3g/files/digest-ntfs3g-0.200611153
-rw-r--r--sys-fs/ntfs3g/ntfs3g-0.20061115.ebuild35
3 files changed, 45 insertions, 1 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 25dbaf999185..d37139db7012 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.14 2006/10/31 03:42:07 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.15 2006/11/15 03:23:23 chutzpah Exp $
+
+*ntfs3g-0.20061115 (15 Nov 2006)
+
+ 15 Nov 2006; Patrick McLean <chutzpah@gentoo.org>
+ +ntfs3g-0.20061115.ebuild:
+ Version bump, update FUSE depend to 2.6.0.
*ntfs3g-0.20061031 (31 Oct 2006)
diff --git a/sys-fs/ntfs3g/files/digest-ntfs3g-0.20061115 b/sys-fs/ntfs3g/files/digest-ntfs3g-0.20061115
new file mode 100644
index 000000000000..e6e2f692e6d2
--- /dev/null
+++ b/sys-fs/ntfs3g/files/digest-ntfs3g-0.20061115
@@ -0,0 +1,3 @@
+MD5 9a0c1a3d2a27deaeda6c39003e9f57c4 ntfs-3g-0.20061115-BETA.tgz 559073
+RMD160 01cc67da61b4405a7a136a7c429a58958b1d717b ntfs-3g-0.20061115-BETA.tgz 559073
+SHA256 07688def198062931fab960e3c44bfd083e109e5e15f4c9d429b824d7c83c2cb ntfs-3g-0.20061115-BETA.tgz 559073
diff --git a/sys-fs/ntfs3g/ntfs3g-0.20061115.ebuild b/sys-fs/ntfs3g/ntfs3g-0.20061115.ebuild
new file mode 100644
index 000000000000..45cba291000f
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-0.20061115.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-0.20061115.ebuild,v 1.1 2006/11/15 03:23:23 chutzpah Exp $
+
+MY_PN="${PN/3g/-3g}"
+MY_PV="${PV}-BETA"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.ntfs-3g.org"
+SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/fuse-2.6.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # default makefile calls ldconfig
+ sed -ie '/ldconfig$/ d' src/Makefile.*
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog CREDITS NEWS README
+}