summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2007-04-11 15:27:55 +0000
committerMike Auty <ikelos@gentoo.org>2007-04-11 15:27:55 +0000
commit92147264e762744363d4af5aee5ccfdf3bf9c2a0 (patch)
treee663494c8c1b28cfe4a49c09098c0be9e2f44ec1 /sys-fs
parentStable on x86 wrt bug #174124 (diff)
downloadgentoo-2-92147264e762744363d4af5aee5ccfdf3bf9c2a0.tar.gz
gentoo-2-92147264e762744363d4af5aee5ccfdf3bf9c2a0.tar.bz2
gentoo-2-92147264e762744363d4af5aee5ccfdf3bf9c2a0.zip
Version bump to fix masked baselayout issues (bug 157590), and minor QA.
(Portage version: 2.1.2.3)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptsetup-luks/ChangeLog8
-rw-r--r--sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild4
-rw-r--r--sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.4-r2.ebuild93
-rw-r--r--sys-fs/cryptsetup-luks/files/1.0.4-dm-crypt-start.sh236
-rw-r--r--sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.4-r23
5 files changed, 341 insertions, 3 deletions
diff --git a/sys-fs/cryptsetup-luks/ChangeLog b/sys-fs/cryptsetup-luks/ChangeLog
index 8f910644e940..d3bc21414f83 100644
--- a/sys-fs/cryptsetup-luks/ChangeLog
+++ b/sys-fs/cryptsetup-luks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/cryptsetup-luks
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/ChangeLog,v 1.48 2007/01/27 02:18:18 strerror Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/ChangeLog,v 1.49 2007/04/11 15:27:55 ikelos Exp $
+
+*cryptsetup-luks-1.0.4-r2 (11 Apr 2007)
+
+ 11 Apr 2007; Mike Auty <ikelos@gentoo.org> +files/1.0.4-dm-crypt-start.sh,
+ +cryptsetup-luks-1.0.4-r2.ebuild:
+ Version bump to fix masked baselayout issues (bug 157590), and minor QA.
27 Jan 2007; Benjamin Smee <strerror@gentoo.org>
cryptsetup-luks-1.0.4-r1.ebuild:
diff --git a/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild
index 78d4f363d64b..6c6e3ffa3956 100644
--- a/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild
+++ b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild,v 1.15 2006/09/26 20:06:14 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.3-r2.ebuild,v 1.16 2007/04/11 15:27:55 ikelos Exp $
inherit autotools linux-info eutils flag-o-matic multilib
diff --git a/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.4-r2.ebuild b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..32e36e709692
--- /dev/null
+++ b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.4-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.4-r2.ebuild,v 1.1 2007/04/11 15:27:55 ikelos Exp $
+
+inherit linux-info eutils flag-o-matic multilib
+
+DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
+HOMEPAGE="http://luks.endorphin.org/"
+SRC_URI="http://luks.endorphin.org/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="build dynamic nls selinux"
+RESTRICT="confcache"
+
+DEPEND=">=sys-fs/device-mapper-1.00.07-r1
+ >=dev-libs/libgcrypt-1.1.42
+ >=dev-libs/libgpg-error-1.0-r1
+ >=dev-libs/popt-1.7
+ selinux? ( sys-libs/libselinux )
+ !sys-fs/cryptsetup"
+
+dm-crypt_check() {
+ local CONFIG_CHECK="~DM_CRYPT"
+ local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup-luks)"
+ check_extra_config
+ echo
+}
+
+crypto_check() {
+ local CONFIG_CHECK="~CRYPTO"
+ local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup-luks)"
+ check_extra_config
+ echo
+}
+
+cbc_check() {
+ local CONFIG_CHECK="~CRYPTO_CBC"
+ local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for Kernel 2.6.19)"
+ check_extra_config
+ echo
+}
+
+pkg_setup() {
+ # Bug 148390
+ if ! use build ; then
+ linux-info_pkg_setup
+ dm-crypt_check
+ crypto_check
+ cbc_check
+ fi
+}
+
+src_compile() {
+ if use dynamic ; then
+ ewarn "If you need cryptsetup for an initrd or initramfs then you"
+ ewarn "should NOT use the dynamic USE flag"
+ epause 5
+ fi
+
+ econf \
+ --sbindir=/sbin \
+ $(use_enable !dynamic static) \
+ --libdir=/usr/$(get_libdir) \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ rmdir "${D}"/usr/$(get_libdir)/cryptsetup
+ insinto /lib/rcscripts/addons
+ dosym /sbin/cryptsetup /bin/cryptsetup
+ newins "${FILESDIR}"/1.0.4-dm-crypt-start.sh dm-crypt-start.sh || die
+ newins "${FILESDIR}"/1.0.3-dm-crypt-stop.sh dm-crypt-stop.sh || die
+ newconfd "${FILESDIR}"/1.0.3-cryptfs.confd cryptfs || die
+}
+
+pkg_postinst() {
+ ewarn "This ebuild introduces a new set of scripts and configuration"
+ ewarn "then the previous system. If you are currently using /etc/conf.d/crypfs"
+ ewarn "then you *MUST* read the new /etc/conf.d/cryptfs for instructions"
+ ewarn "on how to convert your previous cryptfs to the new syntax or your"
+ ewarn "encrypted partitions will *NOT* work."
+ einfo
+ einfo "Please see the example for configuring a LUKS mountpoint"
+ einfo "in /etc/conf.d/cryptfs"
+ einfo
+}
diff --git a/sys-fs/cryptsetup-luks/files/1.0.4-dm-crypt-start.sh b/sys-fs/cryptsetup-luks/files/1.0.4-dm-crypt-start.sh
new file mode 100644
index 000000000000..01ff7905a076
--- /dev/null
+++ b/sys-fs/cryptsetup-luks/files/1.0.4-dm-crypt-start.sh
@@ -0,0 +1,236 @@
+# /lib/rcscripts/addons/dm-crypt-start.sh
+
+# For backwards compatability with baselayout < 1.13.0
+dm_crypt_execute_checkfs() {
+ dm_crypt_execute_volumes
+}
+
+# Setup mappings for an individual target/swap
+# Note: This relies on variables localized in the main body below.
+dm_crypt_execute_volumes() {
+ local dev ret mode
+ # some colors
+ local red='\x1b[31;01m' green='\x1b[32;01m' off='\x1b[0;0m'
+
+ if [ -n "$target" ]; then
+ # let user set options, otherwise leave empty
+ : ${options:=' '}
+ elif [ -n "$swap" ]; then
+ target=${swap}
+ # swap contents do not need to be preserved between boots, luks not required.
+ # suspend2 users should have initramfs's init handling their swap partition either way.
+ : ${options:='-c aes -h sha1 -d /dev/urandom'}
+ : ${pre_mount:='mkswap ${dev}'}
+ else
+ return
+ fi
+ if [ -z "$source" ] && [ ! -e "$source" ]; then
+ ewarn "source \"${source}\" for ${target} missing, skipping..."
+ return
+ fi
+
+ if [[ -n ${loop_file} ]] ; then
+ dev="/dev/mapper/${target}"
+ ebegin " Setting up loop device ${source}"
+ /sbin/losetup ${source} ${loop_file}
+ fi
+
+ # cryptsetup:
+ # luksOpen <device> <name> # <device> is $source
+ # create <name> <device> # <name> is $target
+ local arg1="create" arg2="$target" arg3="$source" luks=0
+
+ cryptsetup isLuks ${source} 2>/dev/null && { arg1="luksOpen"; arg2="$source"; arg3="$target"; luks=1; }
+
+ if /bin/cryptsetup status ${target} | egrep -q '\<active:' ; then
+ einfo "dm-crypt mapping ${target} is already configured"
+ return
+ fi
+ # Handle keys
+ if [ -n "$key" ]; then
+ # Notes: sed not used to avoid case where /usr partition is encrypted.
+ mode=${key/*:/} && ( [ "$mode" == "$key" ] || [ -z "$mode" ] ) && mode=reg
+ key=${key/:*/}
+ case "$mode" in
+ gpg|reg)
+ # handle key on removable device
+ if [ -n "$remdev" ]; then
+ # temp directory to mount removable device
+ local mntrem=/mnt/remdev
+ local c=0 ans
+ for (( i = 0 ; i < 10 ; i++ ))
+ do
+ [ ! -d "$mntrem" ] && mkdir -p ${mntrem} 2>/dev/null >/dev/null
+ if mount -n -o ro ${remdev} ${mntrem} 2>/dev/null >/dev/null ; then
+ sleep 2
+ # keyfile exists?
+ if [ ! -e "${mntrem}${key}" ]; then
+ umount -n ${mntrem} 2>/dev/null >/dev/null
+ rmdir ${mntrem} 2>/dev/null >/dev/null
+ einfo "Cannot find ${key} on removable media."
+ echo -n -e " ${green}*${off} Abort?(${red}yes${off}/${green}no${off})" >/dev/console
+ read ans </dev/console
+ echo >/dev/console
+ [ "$ans" != "yes" ] && { i=0; c=0; } || return
+ else
+ key="${mntrem}${key}"
+ break
+ fi
+ else
+ [ "$c" -eq 0 ] && einfo "Please insert removable device for ${target}"
+ c=1
+ sleep 2
+ # let user abort
+ if [ "$i" -eq 9 ]; then
+ rmdir ${mntrem} 2>/dev/null >/dev/null
+ einfo "Removable device for ${target} not present."
+ echo -n -e " ${green}*${off} Abort?(${red}yes${off}/${green}no${off})" >/dev/console
+ read ans </dev/console
+ echo >/dev/console
+ [ "$ans" != "yes" ] && { i=0; c=0; } || return
+ fi
+ fi
+ done
+ else # keyfile ! on removable device
+ if [ ! -e "$key" ]; then
+ ewarn "${source} will not be decrypted ..."
+ einfo "Reason: keyfile ${key} does not exist."
+ return
+ fi
+ fi
+ ;;
+ *)
+ ewarn "${source} will not be decrypted ..."
+ einfo "Reason: mode ${mode} is invalid."
+ return
+ ;;
+ esac
+ else
+ mode=none
+ fi
+ splash svc_input_begin ${SVCNAME} >/dev/null 2>&1
+ ebegin "dm-crypt map ${target}"
+ einfo "cryptsetup will be called with : ${options} ${arg1} ${arg2} ${arg3}"
+ if [ "$mode" == "gpg" ]; then
+ : ${gpg_options:='-q -d'}
+ # gpg available ?
+ if type -p gpg >/dev/null ; then
+ for (( i = 0 ; i < 3 ; i++ ))
+ do
+ # paranoid, don't store key in a variable, pipe it so it stays very little in ram unprotected.
+ # save stdin stdout stderr "values"
+ exec 3>&0 4>&1 6>&2 # ABS says fd 5 is reserved
+ exec &>/dev/console </dev/console
+ gpg ${gpg_options} ${key} 2>/dev/null | cryptsetup ${options} ${arg1} ${arg2} ${arg3}
+ ret="$?"
+ # restore values and close file descriptors
+ exec 0>&3 1>&4 2>&6
+ exec 3>&- 4>&- 6>&-
+ [ "$ret" -eq 0 ] && break
+ done
+ eend "${ret}" "failure running cryptsetup"
+ else
+ ewarn "${source} will not be decrypted ..."
+ einfo "Reason: cannot find gpg application."
+ einfo "You have to install app-crypt/gnupg first."
+ einfo "If you have /usr on its own partition, try copying gpg to /bin ."
+ fi
+ else
+ if [ "$mode" == "reg" ]; then
+ cryptsetup ${options} -d ${key} ${arg1} ${arg2} ${arg3} >/dev/console </dev/console
+ ret="$?"
+ eend "${ret}" "failure running cryptsetup"
+ else
+ cryptsetup ${options} ${arg1} ${arg2} ${arg3} >/dev/console </dev/console
+ ret="$?"
+ eend "${ret}" "failure running cryptsetup"
+ fi
+ fi
+ if [ -d "$mntrem" ]; then
+ umount -n ${mntrem} 2>/dev/null >/dev/null
+ rmdir ${mntrem} 2>/dev/null >/dev/null
+ fi
+ splash svc_input_end ${SVCNAME} >/dev/null 2>&1
+
+ if [[ ${ret} != 0 ]] ; then
+ cryptfs_status=1
+ else
+ if [[ -n ${pre_mount} ]] ; then
+ dev="/dev/mapper/${target}"
+ ebegin " Running pre_mount commands for ${target}"
+ eval "${pre_mount}" > /dev/null
+ ewend $? || cryptfs_status=1
+ fi
+ fi
+}
+
+# Run any post_mount commands for an individual mount
+#
+# Note: This relies on variables localized in the main body below.
+dm_crypt_execute_localmount() {
+ local mount_point
+
+ [ -z "$target" ] && [ -z "$post_mount" ] && return
+
+ if ! /bin/cryptsetup status ${target} | egrep -q '\<active:' ; then
+ ewarn "Skipping unmapped target ${target}"
+ cryptfs_status=1
+ return
+ fi
+
+ mount_point=$(grep "/dev/mapper/${target}" /proc/mounts | cut -d' ' -f2)
+ if [[ -z ${mount_point} ]] ; then
+ ewarn "Failed to find mount point for ${target}, skipping"
+ cryptfs_status=1
+ fi
+
+ if [[ -n ${post_mount} ]] ; then
+ ebegin "Running post_mount commands for target ${target}"
+ eval "${post_mount}" >/dev/null
+ eend $? || cryptfs_status=1
+ fi
+}
+
+local cryptfs_status=0
+local gpg_options key loop_file target targetline options pre_mount post_mount source swap remdev
+
+if [[ -f /etc/conf.d/cryptfs ]] && [[ -x /bin/cryptsetup ]] ; then
+ ebegin "Setting up dm-crypt mappings"
+
+ while read targetline ; do
+ # skip comments and blank lines
+ [[ ${targetline}\# == \#* ]] && continue
+
+ # check for the start of a new target/swap
+ case ${targetline} in
+ target=*|swap=*)
+ # If we have a target queued up, then execute it
+ dm_crypt_execute_${SVCNAME}
+
+ # Prepare for the next target/swap by resetting variables
+ unset gpg_options key loop_file target options pre_mount post_mount source swap remdev
+ ;;
+
+ gpg_options=*|remdev=*|key=*|loop_file=*|options=*|pre_mount=*|post_mount=*|source=*)
+ if [[ -z ${target} && -z ${swap} ]] ; then
+ ewarn "Ignoring setting outside target/swap section: ${targetline}"
+ continue
+ fi
+ ;;
+
+ *)
+ ewarn "Skipping invalid line in /etc/conf.d/cryptfs: ${targetline}"
+ ;;
+ esac
+
+ # Queue this setting for the next call to dm_crypt_execute_${SVCNAME}
+ eval "${targetline}"
+ done < /etc/conf.d/cryptfs
+
+ # If we have a target queued up, then execute it
+ dm_crypt_execute_${SVCNAME}
+
+ ewend ${cryptfs_status} "Failed to setup dm-crypt devices"
+fi
+
+# vim:ts=4
diff --git a/sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.4-r2 b/sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.4-r2
new file mode 100644
index 000000000000..5941fa96ba5e
--- /dev/null
+++ b/sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.4-r2
@@ -0,0 +1,3 @@
+MD5 156ae6b618438ee9feeddc6c2bdc4e94 cryptsetup-luks-1.0.4.tar.bz2 306907
+RMD160 47737ab9302152a64f0e13b405c219d0166d8217 cryptsetup-luks-1.0.4.tar.bz2 306907
+SHA256 5ba6066d79443fce157b8b6081be466b4c04759cf5cd020b51a8f6cfc996e2a6 cryptsetup-luks-1.0.4.tar.bz2 306907