summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-20 18:02:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-20 18:02:28 +0000
commitb9a5a071f74d8839b50cd7ca32d7b2169491acc2 (patch)
tree1303fbba7b843d9f1ff497bbf1c6f4f99dcc22c8 /sys-fs
parentpunt old, no longer can connect to MSN (diff)
downloadgentoo-2-b9a5a071f74d8839b50cd7ca32d7b2169491acc2.tar.gz
gentoo-2-b9a5a071f74d8839b50cd7ca32d7b2169491acc2.tar.bz2
gentoo-2-b9a5a071f74d8839b50cd7ca32d7b2169491acc2.zip
Version bump wrt #395853 by "teidakankan"
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/bleachbit/ChangeLog9
-rw-r--r--sys-fs/bleachbit/bleachbit-0.9.1.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/sys-fs/bleachbit/ChangeLog b/sys-fs/bleachbit/ChangeLog
index ff07b8b0edd1..9a69255215f4 100644
--- a/sys-fs/bleachbit/ChangeLog
+++ b/sys-fs/bleachbit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/bleachbit
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/bleachbit/ChangeLog,v 1.4 2011/10/30 20:29:11 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/bleachbit/ChangeLog,v 1.5 2012/01/20 18:02:28 ssuominen Exp $
+
+*bleachbit-0.9.1 (20 Jan 2012)
+
+ 20 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +bleachbit-0.9.1.ebuild:
+ Version bump wrt #395853 by "teidakankan"
30 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> -bleachbit-0.9.0.ebuild:
old
diff --git a/sys-fs/bleachbit/bleachbit-0.9.1.ebuild b/sys-fs/bleachbit/bleachbit-0.9.1.ebuild
new file mode 100644
index 000000000000..3eedae6f9ec3
--- /dev/null
+++ b/sys-fs/bleachbit/bleachbit-0.9.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/bleachbit/bleachbit-0.9.1.ebuild,v 1.1 2012/01/20 18:02:28 ssuominen Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="Clean junk to free disk space and to maintain privacy"
+HOMEPAGE="http://bleachbit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-python/pygtk-2"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+DOCS="README"
+
+src_prepare() {
+ python_convert_shebangs 2 ${PN}.py
+
+ # warning: key "Encoding" in group "Desktop Entry" is deprecated
+ sed -i -e '/Encoding/d' ${PN}.desktop || die
+
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+ use nls && emake -C po
+}
+
+src_install() {
+ distutils_src_install
+ use nls && emake -C po DESTDIR="${D}" install
+
+ # http://bugs.gentoo.org/388999
+ insinto /usr/share/${PN}/cleaners
+ doins cleaners/*.xml
+
+ newbin ${PN}.py ${PN}
+
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+}