summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-07 11:49:11 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-07 11:49:11 +0000
commitcbc045bc0343b45ec41251a55bd4582b5cffb3f6 (patch)
tree80db8508450670558169db08b1214087217a0a82 /sys-fs
parentMask all app-emulation/emul-linux-x86-* on hardened/linux/uclibc/amd64 (diff)
downloadgentoo-2-cbc045bc0343b45ec41251a55bd4582b5cffb3f6.tar.gz
gentoo-2-cbc045bc0343b45ec41251a55bd4582b5cffb3f6.tar.bz2
gentoo-2-cbc045bc0343b45ec41251a55bd4582b5cffb3f6.zip
sys-fs/aufs3: Pass raw ldflags if ld is called directly, #432398; use KV_OUT_DIR instead of KV_DIR, #432346 thanks Dennis Schride for the patches
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/aufs3/ChangeLog6
-rw-r--r--sys-fs/aufs3/aufs3-3_p20120813.ebuild10
2 files changed, 10 insertions, 6 deletions
diff --git a/sys-fs/aufs3/ChangeLog b/sys-fs/aufs3/ChangeLog
index 2cca835c7fd3..6d48112f929b 100644
--- a/sys-fs/aufs3/ChangeLog
+++ b/sys-fs/aufs3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/aufs3
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.23 2012/10/07 11:37:44 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.24 2012/10/07 11:49:11 jlec Exp $
+
+ 07 Oct 2012; Justin Lecher <jlec@gentoo.org> aufs3-3_p20120813.ebuild:
+ Pass raw ldflags if ld is called directly, #432398; use KV_OUT_DIR instead of
+ KV_DIR, #432346 thanks Dennis Schride for the patches
*aufs3-3_p20120813-r1 (07 Oct 2012)
diff --git a/sys-fs/aufs3/aufs3-3_p20120813.ebuild b/sys-fs/aufs3/aufs3-3_p20120813.ebuild
index db3397f60f4f..fbde606fb750 100644
--- a/sys-fs/aufs3/aufs3-3_p20120813.ebuild
+++ b/sys-fs/aufs3/aufs3-3_p20120813.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20120813.ebuild,v 1.1 2012/08/13 07:50:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20120813.ebuild,v 1.2 2012/10/07 11:49:11 jlec Exp $
EAPI=4
-inherit linux-mod multilib toolchain-funcs eutils
+inherit eutils flag-o-matic linux-mod multilib toolchain-funcs
AUFS_VERSION="${PV%%_p*}"
# highest branch version
@@ -126,10 +126,10 @@ src_prepare() {
src_compile() {
local ARCH=x86
- emake CC=$(tc-getCC) CONFIG_AUFS_FS=m KDIR=${KV_DIR}
+ emake CC=$(tc-getCC) LDFLAGS="$(raw-ldflags)" CONFIG_AUFS_FS=m KDIR=${KV_OUT_DIR}
cd "${WORKDIR}"/${PN/3}-util
- emake CC=$(tc-getCC) AR=$(tc-getAR) KDIR=${KV_DIR} C_INCLUDE_PATH="${S}"/include
+ emake CC=$(tc-getCC) AR=$(tc-getAR) KDIR=${KV_OUT_DIR} C_INCLUDE_PATH="${S}"/include
}
src_install() {
@@ -142,7 +142,7 @@ src_install() {
dodoc Documentation/filesystems/aufs/README
cd "${WORKDIR}"/${PN/3}-util
- emake DESTDIR="${D}" KDIR=${KV_DIR} install
+ emake DESTDIR="${D}" KDIR=${KV_OUT_DIR} install
newdoc README README-utils
}