summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2003-02-26 22:44:37 +0000
committerZack Welch <zwelch@gentoo.org>2003-02-26 22:44:37 +0000
commitb0d594ea7b3f065e5c46cb50c3d87f3afc36c090 (patch)
tree3a5e38ae48686918a7fc1afab5306d1d78326a48 /sys-kernel/arm-headers
parentupdate apcupsd to fix bugs 9942 and 16392 (diff)
downloadgentoo-2-b0d594ea7b3f065e5c46cb50c3d87f3afc36c090.tar.gz
gentoo-2-b0d594ea7b3f065e5c46cb50c3d87f3afc36c090.tar.bz2
gentoo-2-b0d594ea7b3f065e5c46cb50c3d87f3afc36c090.zip
add new ARM headers ebuild, may need some work
Diffstat (limited to 'sys-kernel/arm-headers')
-rw-r--r--sys-kernel/arm-headers/ChangeLog9
-rw-r--r--sys-kernel/arm-headers/arm-headers-2.4.19.ebuild103
-rw-r--r--sys-kernel/arm-headers/files/digest-arm-headers-2.4.193
3 files changed, 115 insertions, 0 deletions
diff --git a/sys-kernel/arm-headers/ChangeLog b/sys-kernel/arm-headers/ChangeLog
new file mode 100644
index 000000000000..73cb9cd64863
--- /dev/null
+++ b/sys-kernel/arm-headers/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-kernel/arm-headers
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/arm-headers/ChangeLog,v 1.1 2003/02/26 22:44:37 zwelch Exp $
+
+*arm-headers-2.4.19 (25 Feb 2003)
+
+ 26 Feb 2003; Zach Welch <zwelch@gentoo.org> arm-headers-2.4.19.ebuild files/digest-arm-headers-2.4.19 :
+ New ebuild for ARM kernel headers, supports Netwinder only for now
+
diff --git a/sys-kernel/arm-headers/arm-headers-2.4.19.ebuild b/sys-kernel/arm-headers/arm-headers-2.4.19.ebuild
new file mode 100644
index 000000000000..ec8735429d16
--- /dev/null
+++ b/sys-kernel/arm-headers/arm-headers-2.4.19.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/arm-headers/arm-headers-2.4.19.ebuild,v 1.1 2003/02/26 22:44:37 zwelch Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+IUSE=""
+DEPEND=""
+
+ETYPE="headers"
+inherit kernel eutils
+
+#####
+# move to arm profile
+
+# this specifies the main ARM kernel patch level
+ARM_PATCH_SUFFIX="rmk5"
+
+######
+# move to ${PORTDIR}/subarch.eclass
+# then move to ${PORTDIR}/profiles/profile-arm-1.4/netwinder/subarch.conf
+
+# the current target platform
+ARCH_PROFILE=netwinder
+
+# this specifies the SUBARCH kernel patch level and download location
+# currently, only netwinder supported
+SUBARCH_KERNEL_SUFFIX="-nw1"
+SUBARCH_KERNEL_URLBASE="\
+ http://netwinder.oregonstate.edu/users/r/ralphs/kernel/beta"
+SUBARCH_KERNEL_HOMEPAGE="http://www.netwinder.org/"
+
+#####
+
+# set the kernel version now
+OKV=2.4.19
+EXTRAVERSION="${ARM_PATCH_SUFFIX}${SUBARCH_KERNEL_SUFFIX}"
+KV="${OKV}-${EXTRAVERSION}"
+
+S=${WORKDIR}/linux-${KV}
+
+# this is the main rmk ARM Kernel Patch
+ARM_KERNEL_PATCH="patch-${OKV}-${ARM_PATCH_SUFFIX}"
+# this is the kernel patch for SUBARCH
+[ -n "${SUBARCH_KERNEL_SUFFIX}" ] && \
+ SUBARCH_KERNEL_PATCH="${ARM_KERNEL_PATCH}${SUBARCH_KERNEL_SUFFIX}" || \
+ SUBARCH_KERNEL_PATCH=""
+
+# What's in this kernel?
+# INCLUDED:
+# stock 2.4.19 kernel sources
+# rmk patches for armlinux support
+# subarch patch (optional)
+
+DESCRIPTION="Full sources for the ARM/Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 \
+ ftp://ftp.arm.linux.org.uk/pub/armlinux/source/kernel-patches/v2.4/${ARM_KERNEL_PATCH}.bz2"
+
+# note: this code is only safe because there is only one subarch
+if [ -n "${SUBARCH_KERNEL_PATCH}" ]; then
+ if [ -n "${SUBARCH_KERNEL_URLBASE}" ]; then
+ SRC_URI="${SRC_URI} \
+ ${SUBARCH_KERNEL_URLBASE}/${SUBARCH_KERNEL_PATCH}.gz"
+ else
+ die "${SUBARCH}: ${SUBARCH_KERNEL_PATCH} does not have a URLBASE"
+ fi
+fi
+
+HOMEPAGE="${SUBARCH_KERNEL_HOMEPAGE} http://www.arm.linux.org.uk/ \
+ http://www.kernel.org/ http://www.gentoo.org/"
+KEYWORDS="arm -hppa -x86 -ppc -sparc -alpha -mips"
+SLOT="${KV}"
+
+src_unpack() {
+ # base vanilla source
+ unpack "linux-${OKV}.tar.bz2" || die
+ [ "${OKV}" != "${KV}" ] && \
+ mv "${WORKDIR}/linux-${OKV}" "${WORKDIR}/linux-${KV}"
+
+ # plus the Russell M. King kernel patches
+ unpack "${ARM_KERNEL_PATCH}.bz2" || die
+
+ # plus an optional SUBARCH kernel patch
+ [ -n "${SUBARCH_KERNEL_PATCH}" ] && \
+ { unpack "${SUBARCH_KERNEL_PATCH}.gz" || die; }
+
+ # do the actual patching
+ cd ${S} || die
+ einfo "Applying ${ARM_KERNEL_PATCH}"
+ epatch "${WORKDIR}/${ARM_KERNEL_PATCH}" || die
+ [ -n "${SUBARCH_KERNEL_PATCH}" ] && \
+ { epatch "${WORKDIR}/${SUBARCH_KERNEL_PATCH}" || die; }
+
+ kernel_universal_unpack
+}
+
+src_compile() {
+ # before doing the typical make oldconfig,
+ # load the specific platform configuration
+ make ${ARCH_PROFILE}_config
+
+ kernel_src_compile
+}
+
diff --git a/sys-kernel/arm-headers/files/digest-arm-headers-2.4.19 b/sys-kernel/arm-headers/files/digest-arm-headers-2.4.19
new file mode 100644
index 000000000000..edabec08f66d
--- /dev/null
+++ b/sys-kernel/arm-headers/files/digest-arm-headers-2.4.19
@@ -0,0 +1,3 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 075edc3045f38eb3a4fe24efaa5a4242 patch-2.4.19-rmk5.bz2 622014
+MD5 68d350dbabf44d7ff2042df79807cc0c patch-2.4.19-rmk5-nw1.gz 148995