summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-04-27 10:17:00 +0000
committerMichael Imhof <tantive@gentoo.org>2003-04-27 10:17:00 +0000
commit7233bd1e835d04dfb9a7b64267ce1ba50c2af599 (patch)
treeaf2490668c09551a78c9a46fcacd4ca3ea031a14 /sys-kernel/openmosix-sources
parentmoved vlad's entry up (diff)
downloadgentoo-2-7233bd1e835d04dfb9a7b64267ce1ba50c2af599.tar.gz
gentoo-2-7233bd1e835d04dfb9a7b64267ce1ba50c2af599.tar.bz2
gentoo-2-7233bd1e835d04dfb9a7b64267ce1ba50c2af599.zip
Added 2.4.20-ptrace.patch. Should close #19140
Diffstat (limited to 'sys-kernel/openmosix-sources')
-rw-r--r--sys-kernel/openmosix-sources/ChangeLog7
-rw-r--r--sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.20-r43
-rw-r--r--sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r4.ebuild109
3 files changed, 118 insertions, 1 deletions
diff --git a/sys-kernel/openmosix-sources/ChangeLog b/sys-kernel/openmosix-sources/ChangeLog
index cfd7dff89d0a..bf82b77b8f86 100644
--- a/sys-kernel/openmosix-sources/ChangeLog
+++ b/sys-kernel/openmosix-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/openmosix-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/ChangeLog,v 1.18 2003/04/16 22:44:48 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/ChangeLog,v 1.19 2003/04/27 10:17:00 tantive Exp $
+
+*openmosix-sources-2.4.20-r4 (27 Apr 2003)
+
+ 27 Apr 2003; Michael Imhof <tantive@gentoo.org>
+ Added 2.4.20-ptrace.patch
*openmosix-sources-2.4.20-r3 (18 Apr 2003)
diff --git a/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.20-r4 b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.20-r4
new file mode 100644
index 000000000000..072fea3e21da
--- /dev/null
+++ b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.20-r4
@@ -0,0 +1,3 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 d56d5af11dc03be858210b086708e723 openMosix-2.4.20-2.gz 296657
+MD5 1dc29257a45172eea7e8f11056f89bd8 openmosix-2.4.20-ptrace.patch 24651
diff --git a/sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r4.ebuild b/sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r4.ebuild
new file mode 100644
index 000000000000..e09dfc6e2e9e
--- /dev/null
+++ b/sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r4.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.20-r4.ebuild,v 1.1 2003/04/27 10:17:00 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.20
+[ "${PR}" == "r0" ] && KV=${OKV}-openmosix || KV=${OKV}-openmosix-${PR}
+EXTRAVERSION="`echo ${KV}|sed -e 's:[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\):\1:'`"
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.20, plus:
+# 2.4.20 openmosix-2.4.20-2
+# 2.4.20 ptrace patch
+
+DESCRIPTION="Full sources for the Gentoo openMosix Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 mirror://sourceforge/openmosix/openMosix-2.4.20-2.gz
+http://www.css.tayloru.edu/~elorimer/openmosix-2.4.20-ptrace.patch"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/ http://www.openmosix.org/"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="~x86 -ppc -sparc -alpha"
+
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl virtual/modutils sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ cat ${DISTDIR}/openMosix-2.4.20-2.gz | gzip -d | patch -p1 || die
+ cat ${DISTDIR}/openmosix-2.4.20-ptrace.patch | patch -p1 || die
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
+ Makefile.orig > Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+ rm Makefile~
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R root:root *
+ chmod -R a+r-w+X,u+w *
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}