summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-12-28 15:48:33 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2013-12-28 15:48:33 +0000
commit061ad0df4bf5387901940f52df3c1bd4f97cb569 (patch)
tree748f0880776bfe11399d80e8996089c884e2047b /sys-kernel
parentDo not hardcode library version in sed. (diff)
downloadgentoo-2-061ad0df4bf5387901940f52df3c1bd4f97cb569.tar.gz
gentoo-2-061ad0df4bf5387901940f52df3c1bd4f97cb569.tar.bz2
gentoo-2-061ad0df4bf5387901940f52df3c1bd4f97cb569.zip
Committing on behalf of Alexander Tsoy <alexander@tsoy.me>.
Fixes bug #494188. LUKS devices couldn't be decrypted with eudev because of missing rules file. (Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/dracut/ChangeLog11
-rw-r--r--sys-kernel/dracut/dracut-034-r2.ebuild3
-rw-r--r--sys-kernel/dracut/dracut-034-r3.ebuild325
-rw-r--r--sys-kernel/dracut/files/034-0014-udev-rules-add-eudev-rules.patch29
4 files changed, 366 insertions, 2 deletions
diff --git a/sys-kernel/dracut/ChangeLog b/sys-kernel/dracut/ChangeLog
index cf57551b97ab..2496b9866c6f 100644
--- a/sys-kernel/dracut/ChangeLog
+++ b/sys-kernel/dracut/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-kernel/dracut
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.143 2013/12/14 17:17:50 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.144 2013/12/28 15:48:33 aidecoe Exp $
+
+*dracut-034-r3 (28 Dec 2013)
+
+ 28 Dec 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> dracut-034-r2.ebuild,
+ +dracut-034-r3.ebuild, +files/034-0014-udev-rules-add-eudev-rules.patch:
+ Committing on behalf of Alexander Tsoy <alexander@tsoy.me>.
+ Fixes bug #494188.
+
+ LUKS devices couldn't be decrypted with eudev because of missing rules file.
14 Dec 2013; Amadeusz Żołnowski <aidecoe@gentoo.org> dracut-034-r2.ebuild:
Added epatch_user call. Rels bug #487410.
diff --git a/sys-kernel/dracut/dracut-034-r2.ebuild b/sys-kernel/dracut/dracut-034-r2.ebuild
index bb834075c2e6..089d53440030 100644
--- a/sys-kernel/dracut/dracut-034-r2.ebuild
+++ b/sys-kernel/dracut/dracut-034-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/dracut-034-r2.ebuild,v 1.2 2013/12/14 17:17:50 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/dracut-034-r2.ebuild,v 1.3 2013/12/28 15:48:33 aidecoe Exp $
EAPI=4
@@ -170,6 +170,7 @@ src_prepare() {
epatch "${FILESDIR}/${PV}-0011-lvm-fix-thin-recognition.patch"
epatch "${FILESDIR}/${PV}-0012-lvm-always-install-thin-utils-for-lvm.patch"
epatch "${FILESDIR}/${PV}-0013-usrmount-always-install.patch"
+ epatch "${FILESDIR}/${PV}-0014-udev-rules-add-eudev-rules.patch"
local libdirs
diff --git a/sys-kernel/dracut/dracut-034-r3.ebuild b/sys-kernel/dracut/dracut-034-r3.ebuild
new file mode 100644
index 000000000000..d7ea64f90409
--- /dev/null
+++ b/sys-kernel/dracut/dracut-034-r3.ebuild
@@ -0,0 +1,325 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/dracut-034-r3.ebuild,v 1.1 2013/12/28 15:48:33 aidecoe Exp $
+
+EAPI=4
+
+inherit bash-completion-r1 eutils linux-info multilib systemd
+
+add_req_use_for() {
+ local dep="$1"; shift
+ local f
+
+ for f in "$@"; do
+ REQUIRED_USE+="${f}? ( ${dep} )
+"
+ done
+}
+
+DESCRIPTION="Generic initramfs generation tool"
+HOMEPAGE="http://dracut.wiki.kernel.org"
+SRC_URI="mirror://kernel/linux/utils/boot/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+REQUIRED_USE="
+ dracut_modules_bootchart? ( !dracut_modules_systemd )
+ dracut_modules_crypt-gpg? ( dracut_modules_crypt )
+ dracut_modules_crypt-loop? ( dracut_modules_crypt )
+ dracut_modules_livenet? ( dracut_modules_dmsquash-live )
+ "
+COMMON_MODULES="
+ dracut_modules_biosdevname
+ dracut_modules_bootchart
+ dracut_modules_btrfs
+ dracut_modules_caps
+ dracut_modules_crypt-gpg
+ dracut_modules_crypt-loop
+ dracut_modules_dash
+ dracut_modules_gensplash
+ dracut_modules_mdraid
+ dracut_modules_multipath
+ dracut_modules_plymouth
+ dracut_modules_syslog
+ dracut_modules_systemd
+ "
+DM_MODULES="
+ dracut_modules_crypt
+ dracut_modules_dmraid
+ dracut_modules_dmsquash-live
+ dracut_modules_livenet
+ dracut_modules_lvm
+ "
+NETWORK_MODULES="
+ dracut_modules_cifs
+ dracut_modules_iscsi
+ dracut_modules_livenet
+ dracut_modules_nbd
+ dracut_modules_nfs
+ dracut_modules_ssh-client
+ "
+add_req_use_for device-mapper ${DM_MODULES}
+add_req_use_for net ${NETWORK_MODULES}
+IUSE_DRACUT_MODULES="${COMMON_MODULES} ${DM_MODULES} ${NETWORK_MODULES}"
+IUSE="debug device-mapper net selinux ${IUSE_DRACUT_MODULES}"
+
+RESTRICT="test"
+
+CDEPEND="virtual/udev
+ dracut_modules_systemd? ( >=sys-apps/systemd-199 )
+ selinux? ( sec-policy/selinux-dracut )
+ "
+RDEPEND="${CDEPEND}
+ app-arch/cpio
+ >=app-shells/bash-4.0
+ >=sys-apps/baselayout-1.12.14-r1
+ >sys-apps/kmod-5[tools]
+ || ( >=sys-apps/sysvinit-2.87-r3 sys-apps/systemd-sysv-utils )
+ >=sys-apps/util-linux-2.21
+ virtual/pkgconfig
+
+ debug? ( dev-util/strace )
+ device-mapper? ( >=sys-fs/lvm2-2.02.33 )
+ net? ( net-misc/curl >=net-misc/dhcp-4.2.4_p2-r1[client] sys-apps/iproute2 )
+ selinux? ( sys-libs/libselinux sys-libs/libsepol )
+ dracut_modules_biosdevname? ( sys-apps/biosdevname )
+ dracut_modules_bootchart? ( app-benchmarks/bootchart2 sys-apps/usleep
+ sys-process/acct )
+ dracut_modules_btrfs? ( sys-fs/btrfs-progs )
+ dracut_modules_caps? ( sys-libs/libcap )
+ dracut_modules_cifs? ( net-fs/cifs-utils )
+ dracut_modules_crypt? ( sys-fs/cryptsetup )
+ dracut_modules_crypt-gpg? ( app-crypt/gnupg )
+ dracut_modules_dash? ( >=app-shells/dash-0.5.4.11 )
+ dracut_modules_dmraid? ( sys-fs/dmraid sys-fs/multipath-tools )
+ dracut_modules_gensplash? ( media-gfx/splashutils )
+ dracut_modules_iscsi? ( >=sys-block/open-iscsi-2.0.871.3 )
+ dracut_modules_lvm? ( >=sys-fs/lvm2-2.02.33 )
+ dracut_modules_mdraid? ( >=sys-fs/mdadm-3.2.6-r1 )
+ dracut_modules_multipath? ( sys-fs/multipath-tools )
+ dracut_modules_nbd? ( sys-block/nbd )
+ dracut_modules_nfs? ( net-fs/nfs-utils net-nds/rpcbind )
+ dracut_modules_plymouth? ( >=sys-boot/plymouth-0.8.3-r1 )
+ dracut_modules_ssh-client? ( dev-libs/openssl )
+ dracut_modules_syslog? ( || ( app-admin/syslog-ng app-admin/rsyslog ) )
+ "
+DEPEND="${CDEPEND}
+ app-text/asciidoc
+ >=dev-libs/libxslt-1.1.26
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75.2
+ "
+
+DOCS=( AUTHORS HACKING NEWS README README.generic README.kernel README.modules
+ README.testsuite TODO )
+MY_LIBDIR=/usr/lib
+
+#
+# Helper functions
+#
+
+# Returns true if any of specified modules is enabled by USE flag and false
+# otherwise.
+# $1 = list of modules (which have corresponding USE flags of the same name)
+any_module() {
+ local m modules=" $@ "
+
+ for m in ${modules}; do
+ ! use $m && modules=${modules/ $m / }
+ done
+
+ shopt -s extglob
+ modules=${modules%%+( )}
+ shopt -u extglob
+
+ [[ ${modules} ]]
+}
+
+# Removes module from modules.d.
+# $1 = module name
+# Module name can be specified without number prefix.
+rm_module() {
+ local force m
+ [[ $1 = -f ]] && force=-f
+
+ for m in $@; do
+ if [[ $m =~ ^[0-9][0-9][^\ ]*$ ]]; then
+ rm ${force} --interactive=never -r "${modules_dir}"/$m
+ else
+ rm ${force} --interactive=never -r "${modules_dir}"/[0-9][0-9]$m
+ fi
+ done
+}
+
+#
+# ebuild functions
+#
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-0001-dracut.sh-do-not-bail-out-if-kernel-mo.patch"
+ epatch "${FILESDIR}/${PV}-0002-dracut-functions.sh-support-for-altern.patch"
+ epatch "${FILESDIR}/${PV}-0003-gentoo.conf-let-udevdir-be-handled-by-.patch"
+ epatch "${FILESDIR}/${PV}-0004-Use-the-same-paths-in-dracut.sh-as-tho.patch"
+ epatch "${FILESDIR}/${PV}-0005-Install-dracut-install-into-libexec-di.patch"
+ epatch "${FILESDIR}/${PV}-0006-resume-fix-swap-detection-in-hostonly.patch"
+ epatch "${FILESDIR}/${PV}-0007-dracut.sh-also-mkdir-run-lock-which-is.patch"
+ epatch "${FILESDIR}/${PV}-0008-dracut.sh-no-need-to-make-subdirs-in-r.patch"
+ epatch "${FILESDIR}/${PV}-0009-lvm-install-thin-utils-for-non-hostonl.patch"
+ epatch "${FILESDIR}/${PV}-0010-module-setup.sh-add-comments-for-dracu.patch"
+ epatch "${FILESDIR}/${PV}-0011-lvm-fix-thin-recognition.patch"
+ epatch "${FILESDIR}/${PV}-0012-lvm-always-install-thin-utils-for-lvm.patch"
+ epatch "${FILESDIR}/${PV}-0013-usrmount-always-install.patch"
+ epatch "${FILESDIR}/${PV}-0014-udev-rules-add-eudev-rules.patch"
+
+ local libdirs
+
+ #local ldir
+ #for ldir in $(get_all_libdirs); do
+ # libdirs+=" /$ldir /usr/$ldir"
+ #done
+ #libdirs="${libdirs# }"
+
+ libdirs="/$(get_libdir) /usr/$(get_libdir)"
+ [[ $libdirs =~ /lib\ ]] || libdirs+=" /lib /usr/lib"
+ einfo "Setting libdirs to \"${libdirs}\" ..."
+ sed -e "3alibdirs=\"${libdirs}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+
+ if use dracut_modules_systemd; then
+ local systemdutildir="$(systemd_get_utildir)"
+ local systemdsystemunitdir="$(systemd_get_unitdir)"
+ einfo "Setting systemdutildir to ${systemdutildir} and ..."
+ sed -e "5asystemdutildir=\"${systemdutildir}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+ einfo "Setting systemdsystemunitdir to ${systemdsystemunitdir}..."
+ sed -e "6asystemdsystemunitdir=\"${systemdsystemunitdir}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+ fi
+
+ epatch_user
+}
+
+src_configure() {
+ local myconf="--libdir=${MY_LIBDIR}"
+ myconf+=" --bashcompletiondir=$(get_bashcompdir)"
+
+ if use dracut_modules_systemd; then
+ myconf+=" --systemdsystemunitdir='$(systemd_get_unitdir)'"
+ fi
+
+ econf ${myconf}
+}
+
+src_compile() {
+ tc-export CC
+ emake doc install/dracut-install
+}
+
+src_install() {
+ default
+
+ local my_libdir="${MY_LIBDIR}"
+ local dracutlibdir="${my_libdir#/}/dracut"
+
+ echo "DRACUT_VERSION=$PVR" > "${D%/}/${dracutlibdir}/dracut-version.sh"
+
+ insinto "${dracutlibdir}/dracut.conf.d/"
+ newins dracut.conf.d/gentoo.conf.example gentoo.conf
+
+ insinto /etc/logrotate.d
+ newins dracut.logrotate dracut
+
+ dodir /var/lib/dracut/overlay
+
+ dohtml dracut.html
+
+ #
+ # Modules
+ #
+ local module
+ modules_dir="${D%/}/${dracutlibdir}/modules.d"
+
+ # Remove modules not enabled by USE flags
+ for module in ${IUSE_DRACUT_MODULES} ; do
+ ! use ${module} && rm_module -f ${module#dracut_modules_}
+ done
+
+ # Those flags are specific, and even are corresponding to modules, they need
+ # to be declared as regular USE flags.
+ use debug || rm_module 95debug
+ use selinux || rm_module 98selinux
+
+ # Following flags define set of helper modules which are base dependencies
+ # for others and as so have no practical use, so remove these modules.
+ use device-mapper || rm_module 90dm
+ use net || rm_module 40network 45ifcfg 45url-lib
+
+ if use dracut_modules_systemd; then
+ # With systemd following modules do not make sense
+ rm_module 96securityfs 98selinux
+ else
+ # Without systemd following modules do not make sense
+ rm_module 00systemd-bootchart
+ fi
+
+ # Remove S/390 modules which are not tested at all
+ rm_module 80cms 95dasd 95dasd_mod 95zfcp 95znet
+
+ # Remove modules which won't work for sure
+ rm_module 95fcoe # no tools
+ # fips module depends on masked app-crypt/hmaccalc
+ rm_module 01fips 02fips-aesni
+
+ # Remove extra modules which go to future dracut-extras
+ rm_module 05busybox 97masterkey 98ecryptfs 98integrity
+}
+
+pkg_postinst() {
+ if linux-info_get_any_version && linux_config_src_exists; then
+ ewarn ""
+ ewarn "If the following test report contains a missing kernel"
+ ewarn "configuration option, you should reconfigure and rebuild your"
+ ewarn "kernel before booting image generated with this Dracut version."
+ ewarn ""
+
+ local CONFIG_CHECK="~BLK_DEV_INITRD ~DEVTMPFS"
+
+ # Kernel configuration options descriptions:
+ local desc_DEVTMPFS="Maintain a devtmpfs filesystem to mount at /dev"
+ local desc_BLK_DEV_INITRD="Initial RAM filesystem and RAM disk "\
+"(initramfs/initrd) support"
+
+ local opt desc
+
+ # Generate ERROR_* variables for check_extra_config.
+ for opt in ${CONFIG_CHECK}; do
+ opt=${opt#\~}
+ desc=desc_${opt}
+ eval "local ERROR_${opt}='CONFIG_${opt}: \"${!desc}\"" \
+ "is missing and REQUIRED'"
+ done
+
+ check_extra_config
+ echo
+ else
+ ewarn ""
+ ewarn "Your kernel configuration couldn't be checked. Do you have"
+ ewarn "/usr/src/linux/.config file there? Please check manually if"
+ ewarn "following options are enabled:"
+ ewarn ""
+ ewarn " CONFIG_BLK_DEV_INITRD"
+ ewarn " CONFIG_DEVTMPFS"
+ ewarn ""
+ fi
+
+ if use dracut_modules_crypt || use dracut_modules_dmraid || use \
+ dracut_modules_mdraid || use dracut_modules_lvm; then
+
+ if ! [[ $(</proc/cmdline) =~ rd.auto[\ =] ]]; then
+ ewarn "Autoassembly of special devices like cryptoLUKS, dmraid, "
+ ewarn "mdraid or lvm is off for default as of >=dracut-024."
+ ewarn "Use rd.auto option to turn it on."
+ fi
+ fi
+}
diff --git a/sys-kernel/dracut/files/034-0014-udev-rules-add-eudev-rules.patch b/sys-kernel/dracut/files/034-0014-udev-rules-add-eudev-rules.patch
new file mode 100644
index 000000000000..0b3fc39d2f9e
--- /dev/null
+++ b/sys-kernel/dracut/files/034-0014-udev-rules-add-eudev-rules.patch
@@ -0,0 +1,29 @@
+From 29f735ac0e54421d1518b8d0f730523ebb7e6d5a Mon Sep 17 00:00:00 2001
+From: Alexander Tsoy <alexander@tsoy.me>
+Date: Wed, 25 Dec 2013 14:00:26 +0400
+Subject: [PATCH] udev-rules: add eudev rules
+
+eudev configured with "--enable-modules --disable-libkmod" installs
+80-drivers-modprobe.rules instead of 80-drivers.rules
+
+https://bugs.gentoo.org/show_bug.cgi?id=494188
+---
+ modules.d/95udev-rules/module-setup.sh | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/modules.d/95udev-rules/module-setup.sh b/modules.d/95udev-rules/module-setup.sh
+index 88c3da2..ebc4447 100755
+--- a/modules.d/95udev-rules/module-setup.sh
++++ b/modules.d/95udev-rules/module-setup.sh
+@@ -39,6 +39,8 @@ install() {
+ prepare_udev_rules 59-persistent-storage.rules 61-persistent-storage.rules
+ # debian udev rules
+ inst_rules 91-permissions.rules
++ # eudev rules
++ inst_rules 80-drivers-modprobe.rules
+
+ {
+ for i in cdrom tape dialout floppy; do
+--
+1.8.3.2
+