summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-28 01:08:43 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-28 01:08:43 +0000
commit129670e7a60b3b0f1a3f823c90e66ca5ccac4445 (patch)
treeca14a34c8711ef745d052bffe03d04e94a563d20 /sys-kernel
parentAdded missing inherit. (diff)
downloadgentoo-2-129670e7a60b3b0f1a3f823c90e66ca5ccac4445.tar.gz
gentoo-2-129670e7a60b3b0f1a3f823c90e66ca5ccac4445.tar.bz2
gentoo-2-129670e7a60b3b0f1a3f823c90e66ca5ccac4445.zip
add back in pic patch and fix syscall6 #100659 Peter Beutner
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-headers/files/unistd.h-i386-pic.patch8
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.26-r1.ebuild5
2 files changed, 7 insertions, 6 deletions
diff --git a/sys-kernel/linux-headers/files/unistd.h-i386-pic.patch b/sys-kernel/linux-headers/files/unistd.h-i386-pic.patch
index ab0b8ee31d0d..26559769e7c4 100644
--- a/sys-kernel/linux-headers/files/unistd.h-i386-pic.patch
+++ b/sys-kernel/linux-headers/files/unistd.h-i386-pic.patch
@@ -1,5 +1,5 @@
---- ./include/asm-i386/unistd.h.orig 2005-01-29 12:15:26.000000000 +0100
-+++ ./include/asm-i386/unistd.h 2005-01-29 14:41:17.445762872 +0100
+--- include/asm-i386/unistd.h
++++ include/asm-i386/unistd.h
@@ -314,6 +314,21 @@
__syscall_return(type,__res); \
}
@@ -136,10 +136,10 @@
+long __res; \
+__asm__ volatile (\
+ "pushl %%ebp\n\t" \
-+ "movl %%eax,%%ebp\n\t" \
-+ "movl %1,%%eax\n\t" \
+ "pushl %%ebx\n\t" \
+ "movl %2,%%ebx\n\t" \
++ "movl %%eax,%%ebp\n\t" \
++ "movl %1,%%eax\n\t" \
+ "int $0x80\n\t" \
+ "popl %%ebx\n\t" \
+ "popl %%ebp\n\t" \
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.26-r1.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.26-r1.ebuild
index fe307f335430..0139c87573fd 100644
--- a/sys-kernel/linux-headers/linux-headers-2.4.26-r1.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.4.26-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.26-r1.ebuild,v 1.8 2005/10/26 17:28:57 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.26-r1.ebuild,v 1.9 2005/10/28 01:08:43 vapier Exp $
ETYPE="headers"
H_SUPPORTEDARCH="arm m68k sh sparc x86"
@@ -11,4 +11,5 @@ SRC_URI="${KERNEL_URI}"
KEYWORDS="-* arm m68k sh ~sparc ~x86"
UNIPATCH_LIST="${FILESDIR}/linux-headers-2.4-armeb-stat.patch
- ${FILESDIR}/linux-headers-2.4-arm-cris-ELF_DATA.patch"
+ ${FILESDIR}/linux-headers-2.4-arm-cris-ELF_DATA.patch
+ ${FILESDIR}/unistd.h-i386-pic.patch"