summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-06-02 13:52:14 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-06-02 13:52:14 +0000
commit19d75ed3298bc171e4805695fe22d15943bc15b9 (patch)
treeeaf55c6c524afc2df9796be7ad04029130d35a55 /sys-kernel
parentstable on x86; cleanups (Manifest recommit) (diff)
downloadgentoo-2-19d75ed3298bc171e4805695fe22d15943bc15b9.tar.gz
gentoo-2-19d75ed3298bc171e4805695fe22d15943bc15b9.tar.bz2
gentoo-2-19d75ed3298bc171e4805695fe22d15943bc15b9.zip
Added patches for the CAN-2004-0181, CAN-2004-0394, and CAN-2004-0427 vulnerabilities. Bug #47881.
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/planet-ccrma-sources/ChangeLog12
-rw-r--r--sys-kernel/planet-ccrma-sources/files/digest-planet-ccrma-sources-2.4.21-r8 (renamed from sys-kernel/planet-ccrma-sources/files/digest-planet-ccrma-sources-2.4.21-r7)0
-rw-r--r--sys-kernel/planet-ccrma-sources/files/planet-ccrma-sources.CAN-2004-0181.patch38
-rw-r--r--sys-kernel/planet-ccrma-sources/files/planet-ccrma-sources.CAN-2004-0394.patch11
-rw-r--r--sys-kernel/planet-ccrma-sources/files/planet-ccrma-sources.CAN-2004-0427.patch14
-rw-r--r--sys-kernel/planet-ccrma-sources/planet-ccrma-sources-2.4.21-r8.ebuild (renamed from sys-kernel/planet-ccrma-sources/planet-ccrma-sources-2.4.21-r7.ebuild)7
6 files changed, 79 insertions, 3 deletions
diff --git a/sys-kernel/planet-ccrma-sources/ChangeLog b/sys-kernel/planet-ccrma-sources/ChangeLog
index d1e85b367724..48e9729f56cc 100644
--- a/sys-kernel/planet-ccrma-sources/ChangeLog
+++ b/sys-kernel/planet-ccrma-sources/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-kernel/planet-ccrma-sources
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/planet-ccrma-sources/ChangeLog,v 1.14 2004/05/30 23:53:42 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/planet-ccrma-sources/ChangeLog,v 1.15 2004/06/02 13:52:14 plasmaroo Exp $
+
+*planet-ccrma-sources-2.4.21-r8 (02 Jun 2004)
+
+ 02 Jun 2004; <plasmaroo@gentoo.org> -planet-ccrma-sources-2.4.21-r7.ebuild,
+ +planet-ccrma-sources-2.4.21-r8.ebuild,
+ +files/planet-ccrma-sources.CAN-2004-0181.patch,
+ +files/planet-ccrma-sources.CAN-2004-0394.patch,
+ +files/planet-ccrma-sources.CAN-2004-0427.patch:
+ Added patches for the CAN-2004-0181, CAN-2004-0394, and CAN-2004-0427
+ vulnerabilities. Bug #47881.
31 May 2004; Pieter Van den Abeele <pvdabeel@gentoo.org>
planet-ccrma-sources-2.4.21-r7.ebuild:
diff --git a/sys-kernel/planet-ccrma-sources/files/digest-planet-ccrma-sources-2.4.21-r7 b/sys-kernel/planet-ccrma-sources/files/digest-planet-ccrma-sources-2.4.21-r8
index d42092c1bc83..d42092c1bc83 100644
--- a/sys-kernel/planet-ccrma-sources/files/digest-planet-ccrma-sources-2.4.21-r7
+++ b/sys-kernel/planet-ccrma-sources/files/digest-planet-ccrma-sources-2.4.21-r8
diff --git a/sys-kernel/planet-ccrma-sources/files/planet-ccrma-sources.CAN-2004-0181.patch b/sys-kernel/planet-ccrma-sources/files/planet-ccrma-sources.CAN-2004-0181.patch
new file mode 100644
index 000000000000..5f7f1441b268
--- /dev/null
+++ b/sys-kernel/planet-ccrma-sources/files/planet-ccrma-sources.CAN-2004-0181.patch
@@ -0,0 +1,38 @@
+--- linux-2.4.22/fs/jfs/jfs_logmgr.c.jfs-sec 2004-03-23 12:30:35.000000000 -0700
++++ linux-2.4.22/fs/jfs/jfs_logmgr.c 2004-03-23 13:01:51.000000000 -0700
+@@ -1693,7 +1693,7 @@
+ if (lbuf == 0)
+ goto error;
+ lbuf->l_bh.b_data = lbuf->l_ldata =
+- (char *) __get_free_page(GFP_KERNEL);
++ (char *) get_zeroed_page(GFP_KERNEL);
+ if (lbuf->l_ldata == 0) {
+ kfree(lbuf);
+ goto error;
+--- linux-2.4.22/fs/jfs/jfs_metapage.c.jfs-sec 2004-03-23 12:30:48.000000000 -0700
++++ linux-2.4.22/fs/jfs/jfs_metapage.c 2004-03-23 13:01:51.000000000 -0700
+@@ -375,6 +375,10 @@
+ }
+ mp->data = kmap(mp->page) + page_offset;
+ }
++
++ if (new)
++ memset(mp->data, 0, PSIZE);
++
+ jfs_info("__get_metapage: returning = 0x%p", mp);
+ return mp;
+
+--- linux-2.4.22/fs/jfs/super.c.jfs-sec 2004-03-23 12:31:10.000000000 -0700
++++ linux-2.4.22/fs/jfs/super.c 2004-03-23 13:01:51.000000000 -0700
+@@ -423,10 +423,10 @@
+
+ if ((flags & (SLAB_CTOR_VERIFY | SLAB_CTOR_CONSTRUCTOR)) ==
+ SLAB_CTOR_CONSTRUCTOR) {
++ memset(jfs_ip, 0, sizeof(struct jfs_inode_info));
+ INIT_LIST_HEAD(&jfs_ip->anon_inode_list);
+ init_rwsem(&jfs_ip->rdwrlock);
+ init_MUTEX(&jfs_ip->commit_sem);
+- jfs_ip->atlhead = 0;
+ jfs_ip->active_ag = -1;
+ }
+ }
diff --git a/sys-kernel/planet-ccrma-sources/files/planet-ccrma-sources.CAN-2004-0394.patch b/sys-kernel/planet-ccrma-sources/files/planet-ccrma-sources.CAN-2004-0394.patch
new file mode 100644
index 000000000000..273f1a52046f
--- /dev/null
+++ b/sys-kernel/planet-ccrma-sources/files/planet-ccrma-sources.CAN-2004-0394.patch
@@ -0,0 +1,11 @@
+--- linux-2.4.22-oM3-orig/kernel/panic.c Tue Mar 30 15:37:18 2004
++++ linux-2.4.22-oM3-mod/kernel/panic.c Mon May 17 18:44:01 2004
+@@ -51,7 +51,7 @@
+
+ bust_spinlocks(1);
+ va_start(args, fmt);
+- vsprintf(buf, fmt, args);
++ vsnprintf(buf, sizeof(buf), fmt, args);
+ va_end(args);
+ printk(KERN_EMERG "Kernel panic: %s\n",buf);
+ if (in_interrupt())
diff --git a/sys-kernel/planet-ccrma-sources/files/planet-ccrma-sources.CAN-2004-0427.patch b/sys-kernel/planet-ccrma-sources/files/planet-ccrma-sources.CAN-2004-0427.patch
new file mode 100644
index 000000000000..ddc9610f67f8
--- /dev/null
+++ b/sys-kernel/planet-ccrma-sources/files/planet-ccrma-sources.CAN-2004-0427.patch
@@ -0,0 +1,14 @@
+diff -Nar -U 4 linux-2.4.25/kernel/fork.c linux-2.4.25-new/kernel/fork.c
+--- linux-2.4.25/kernel/fork.c 2004-02-18 05:36:32.000000000 -0800
++++ linux-2.4.25-new/kernel/fork.c 2004-04-07 17:43:29.000000000 -0700
+@@ -825,8 +825,10 @@
+ bad_fork_cleanup_namespace:
+ exit_namespace(p);
+ bad_fork_cleanup_mm:
+ exit_mm(p);
++ if (p->active_mm)
++ mmdrop(p->active_mm);
+ bad_fork_cleanup_sighand:
+ exit_sighand(p);
+ bad_fork_cleanup_fs:
+ exit_fs(p); /* blocking */
diff --git a/sys-kernel/planet-ccrma-sources/planet-ccrma-sources-2.4.21-r7.ebuild b/sys-kernel/planet-ccrma-sources/planet-ccrma-sources-2.4.21-r8.ebuild
index 570baf08d9f3..f7422e54c870 100644
--- a/sys-kernel/planet-ccrma-sources/planet-ccrma-sources-2.4.21-r7.ebuild
+++ b/sys-kernel/planet-ccrma-sources/planet-ccrma-sources-2.4.21-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/planet-ccrma-sources/planet-ccrma-sources-2.4.21-r7.ebuild,v 1.2 2004/05/30 23:53:42 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/planet-ccrma-sources/planet-ccrma-sources-2.4.21-r8.ebuild,v 1.1 2004/06/02 13:52:14 plasmaroo Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
ETYPE="sources"
@@ -54,9 +54,12 @@ src_unpack() {
epatch ${FILESDIR}/${PN}.rtc_fix.patch || die "Failed to patch RTC vulnerabilities!"
epatch ${FILESDIR}/${PN}.CAN-2003-0985.patch || die "Failed to patch mremap() vulnerability!"
epatch ${FILESDIR}/${PN}.CAN-2004-0010.patch || die "Failed to add the CAN-2004-0010 patch!"
- epatch ${FILESDIR}/${PN}.CAN-2004-0109.patch || die "Failed to patch CAN-2004-0109 vulnerability!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0109.patch || die "Failed to add the CAN-2004-0109 patch!"
epatch ${FILESDIR}/${PN}.CAN-2004-0177.patch || die "Failed to add the CAN-2004-0177 patch!"
epatch ${FILESDIR}/${PN}.CAN-2004-0178.patch || die "Failed to add the CAN-2004-0178 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0181.patch || die "Failed to add the CAN-2004-0181 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0394.patch || die "Failed to add the CAN-2004-0394 patch!"
+ epatch ${FILESDIR}/${PN}.CAN-2004-0427.patch || die "Failed to add the CAN-2004-0427 patch!"
EXTRAVERSION="$EXTRAVERSION-${PR}" kernel_universal_unpack
}