summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-06-06 00:24:43 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-06-06 00:24:43 +0000
commit3114e2155b965685b53822d46979be6321d97c97 (patch)
treeff548ef38579e605ef12d749ae7b971b2b45ad80 /sys-kernel
parentDrop CVE-2014-0196 mask, its ebuilds are dropped; introduce preliminary CVE-2... (diff)
downloadgentoo-2-3114e2155b965685b53822d46979be6321d97c97.tar.gz
gentoo-2-3114e2155b965685b53822d46979be6321d97c97.tar.bz2
gentoo-2-3114e2155b965685b53822d46979be6321d97c97.zip
vanilla-3.14.4 + genpatches-3.14-7 + grsecurity-3.0-3.14.5-201406051310 bug #512526, CVE-2014-3153
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog3
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-3.14.5-r2.ebuild45
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index c0a90b7ff655..c0bfcce7ab9a 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,12 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.1060 2014/06/06 00:21:39 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.1061 2014/06/06 00:24:43 blueness Exp $
*hardened-sources-3.2.59-r4 (06 Jun 2014)
06 Jun 2014; Anthony G. Basile <blueness@gentoo.org>
+hardened-sources-3.2.59-r4.ebuild:
vanilla-3.2.59 + genpatches-3.2.16 + grsecurity-3.0-3.2.59-201406051309
+ bug #512526, CVE-2014-3153
05 Jun 2014; Anthony G. Basile <blueness@gentoo.org>
-hardened-sources-3.11.7-r2.ebuild, -hardened-sources-3.13.10-r1.ebuild,
diff --git a/sys-kernel/hardened-sources/hardened-sources-3.14.5-r2.ebuild b/sys-kernel/hardened-sources/hardened-sources-3.14.5-r2.ebuild
new file mode 100644
index 000000000000..8622cc603338
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-3.14.5-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.14.5-r2.ebuild,v 1.1 2014/06/06 00:24:43 blueness Exp $
+
+EAPI="5"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base"
+K_GENPATCHES_VER="8"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-4"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="
+ 1500_XATTR_USER_PREFIX.patch
+ 2900_dev-root-proc-mount-fix.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-3.0*"
+
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}