summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-07-09 17:58:20 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-07-09 17:58:20 +0000
commit7b67684a9cc8f8dfc91bd6273520e25d47f12e8a (patch)
tree15cde370a9fdf4e44ed81e9f9a6025b01fab16e7 /sys-kernel
parentx86 stable wrt bug #513378 (diff)
downloadgentoo-2-7b67684a9cc8f8dfc91bd6273520e25d47f12e8a.tar.gz
gentoo-2-7b67684a9cc8f8dfc91bd6273520e25d47f12e8a.tar.bz2
gentoo-2-7b67684a9cc8f8dfc91bd6273520e25d47f12e8a.zip
vanilla-3.2.60 + genpatches-3.2.16 + grsecurity-3.0-3.2.60-201407081916
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-3.2.60-r8.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 164ed3f21e0b..68a48042f55a 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.1086 2014/07/06 22:48:03 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.1087 2014/07/09 17:58:20 blueness Exp $
+
+*hardened-sources-3.2.60-r8 (09 Jul 2014)
+
+ 09 Jul 2014; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-3.2.60-r8.ebuild:
+ vanilla-3.2.60 + genpatches-3.2.16 + grsecurity-3.0-3.2.60-201407081916
*hardened-sources-3.15.3-r2 (06 Jul 2014)
diff --git a/sys-kernel/hardened-sources/hardened-sources-3.2.60-r8.ebuild b/sys-kernel/hardened-sources/hardened-sources-3.2.60-r8.ebuild
new file mode 100644
index 000000000000..e04dcf8a3437
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-3.2.60-r8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.60-r8.ebuild,v 1.1 2014/07/09 17:58:20 blueness Exp $
+
+EAPI="5"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="16"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-9"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-3.0*"
+
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}