summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-03-14 12:00:58 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-03-14 12:00:58 +0000
commit94b79b26a671ee2dbcff3374876677517ffd9310 (patch)
tree4f7aaec3fe55a93764739cbd3969ce6b5a26f288 /sys-kernel
parentclosing bug 44515 (Manifest recommit) (diff)
downloadgentoo-2-94b79b26a671ee2dbcff3374876677517ffd9310.tar.gz
gentoo-2-94b79b26a671ee2dbcff3374876677517ffd9310.tar.bz2
gentoo-2-94b79b26a671ee2dbcff3374876677517ffd9310.zip
Version bumps; closes bugs #42700 and #44623.
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ck-sources/ChangeLog8
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.4.25-r1.ebuild62
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.4-r1.ebuild30
-rw-r--r--sys-kernel/ck-sources/files/digest-ck-sources-2.4.25-r12
-rw-r--r--sys-kernel/ck-sources/files/digest-ck-sources-2.6.4-r12
5 files changed, 103 insertions, 1 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index 9d0e6f909174..76c81c1e5a77 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.23 2004/02/27 10:10:49 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.24 2004/03/14 12:00:58 plasmaroo Exp $
+
+*ck-sources-2.6.4-r1 (14 Mar 2004)
+
+ 14 Mar 2004; Tim Yamin <plasmaroo@gentoo.org> ck-sources-2.4.25-r1.ebuild,
+ ck-sources-2.6.4-r1.ebuild:
+ Version bumps; closes bugs #42700 and #44623.
*ck-sources-2.6.3-r2 (27 Feb 2004)
diff --git a/sys-kernel/ck-sources/ck-sources-2.4.25-r1.ebuild b/sys-kernel/ck-sources/ck-sources-2.4.25-r1.ebuild
new file mode 100644
index 000000000000..cf9cf243ce99
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.4.25-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.4.25-r1.ebuild,v 1.1 2004/03/14 12:00:58 plasmaroo Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version.
+
+ETYPE="sources"
+
+inherit kernel
+
+# CKV=con kolivas release version
+CKV=lck${PR/r/}
+# KV=patched kernel version
+KV="${PV/_/-}-${CKV}"
+# OKV=original kernel version as provided by ebuild
+OKV="`echo ${KV} | cut -d- -f1`"
+# OKVLAST=(working) last digit of OKV
+OKVLAST="`echo ${OKV} | cut -d. -f3`"
+# OKVLASTPR=the previous kernel version (for a marcelo pre/rc release)
+OKVLASTPR="`expr ${OKVLAST} - 1`"
+# If _ isn't there, then it's a stable+ac, otherwise last-stable+pre/rc+ac
+PRERC="`echo ${PV}|grep \_`"
+
+# Other working variables
+S=${WORKDIR}/linux-${KV}
+EXTRAVERSION="`echo ${KV}|sed -e 's:[^-]*\(-.*$\):\1:'`"
+BASE="`echo ${KV}|sed -e s:${EXTRAVERSION}::`"
+
+# If it's a last-stable+pre/rc+ac (marcelo), we need to handle it differently
+# ourkernel is the stable kernel we'll be working with (previous or current)
+if [ ${PRERC} ]; then
+ OURKERNEL="2.4.${OKVLASTPR}"
+ SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OURKERNEL}.tar.bz2
+ http://www.plumlocosoft.com/kernel/patches/2.4/${PV}/${KV}/patch-${KV}.bz2
+ mirror://kernel/linux/kernel/v2.4/testing/patch-${PV/_/-}.bz2"
+else
+ OURKERNEL="2.4.${OKVLAST}"
+ SRC_URI="mirror://kernel//linux/kernel/v2.4/linux-${OURKERNEL}.tar.bz2
+ http://www.plumlocosoft.com/kernel/patches/2.4/${PV}/${KV}/patch-${KV}.bz2"
+fi
+
+DESCRIPTION="Full sources for the Stock Linux kernel Con Kolivas's high performance patchset"
+HOMEPAGE="http://members.optusnet.com.au/ckolivas/kernel/"
+
+KEYWORDS="~x86 -ppc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack linux-${OURKERNEL}.tar.bz2
+ mv linux-${OURKERNEL} linux-${KV} || die
+ cd linux-${KV}
+
+ # if we need a pre/rc patch, then use it
+ if [ ${PRERC} ]; then
+ bzcat ${DISTDIR}/patch-${PV/_/-}.bz2|patch -p1 || die "-marcelo patch failed"
+ fi
+
+ bzcat ${DISTDIR}/patch-${KV}.bz2|patch -p1 || die "-lck patch failed!"
+ kernel_universal_unpack
+}
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.4-r1.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.4-r1.ebuild
new file mode 100644
index 000000000000..b908901bad38
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.6.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.4-r1.ebuild,v 1.1 2004/03/14 12:00:58 plasmaroo Exp $
+
+UNIPATCH_LIST="${DISTDIR}/patch-${KV}.bz2"
+K_PREPATCHED="yes"
+UNIPATCH_STRICTORDER="yes"
+
+K_NOUSENAME="yes"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="Full sources for the Stock Linux kernel Con Kolivas's high performance patchset"
+HOMEPAGE="http://members.optusnet.com.au/ckolivas/kernel/"
+SRC_URI="${KERNEL_URI} http://ck.kolivas.org/patches/2.6/${KV/-ck*/}/${KV}/patch-${KV}.bz2"
+
+KEYWORDS="~x86"
+
+pkg_postinst() {
+ postinst_sources
+
+ ewarn "IMPORTANT:"
+ ewarn "ptyfs support has now been dropped from devfs and as a"
+ ewarn "result you are now required to compile this support into"
+ ewarn "the kernel. You can do so by enabling the following options"
+ ewarn " Device Drivers -> Character devices -> Unix98 PTY Support"
+ ewarn " File systems -> Pseudo filesystems -> /dev/pts filesystem."
+ echo
+}
diff --git a/sys-kernel/ck-sources/files/digest-ck-sources-2.4.25-r1 b/sys-kernel/ck-sources/files/digest-ck-sources-2.4.25-r1
new file mode 100644
index 000000000000..c6098c13eb45
--- /dev/null
+++ b/sys-kernel/ck-sources/files/digest-ck-sources-2.4.25-r1
@@ -0,0 +1,2 @@
+MD5 5fc8e9f43fa44ac29ddf9a9980af57d8 linux-2.4.25.tar.bz2 30626548
+MD5 54e5c367956dd68873d548f075f38db8 patch-2.4.25-lck1.bz2 404994
diff --git a/sys-kernel/ck-sources/files/digest-ck-sources-2.6.4-r1 b/sys-kernel/ck-sources/files/digest-ck-sources-2.6.4-r1
new file mode 100644
index 000000000000..2836694e86eb
--- /dev/null
+++ b/sys-kernel/ck-sources/files/digest-ck-sources-2.6.4-r1
@@ -0,0 +1,2 @@
+MD5 335f06eba1e5372ba38a0d2b253629bd linux-2.6.4.tar.bz2 34386912
+MD5 cc95f57ef5e58489c0d850b0809dd173 patch-2.6.4-ck1.bz2 678248