summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2013-07-29 17:49:27 +0000
committerMike Pagano <mpagano@gentoo.org>2013-07-29 17:49:27 +0000
commit9e99e84a1cb839d36f4f9d0f60b85d8423623ca7 (patch)
treef9501622d98142caf6185830d4327635b77e8db8 /sys-kernel
parentFix SRC_URI. (diff)
downloadgentoo-2-9e99e84a1cb839d36f4f9d0f60b85d8423623ca7.tar.gz
gentoo-2-9e99e84a1cb839d36f4f9d0f60b85d8423623ca7.tar.bz2
gentoo-2-9e99e84a1cb839d36f4f9d0f60b85d8423623ca7.zip
Linux patch 3.0.88. Support for namespace user.pax.* on tmpfs. Patch to initialize satype in key_notify_policy_flush(). Patch to fix zcache build error. ALPS Touchpad patches: Add PSMOUSE_CMD_RESET_WRAP; Move the protocol information to Documentation for the ALPS Touchpad; Add protocol version field in alps_model_info; Remove assumptions about packet size; Add support for protocol versions 3 and 4; Add documentation for protocol versions 3 and 4; Add semi-MT support for v3 protocol and dump raw packet data. ACPI patch to disable Windows 8 compatibility for some Lenovo ThinkPads. fbcondecor console decoration patch.
(Portage version: 2.2.0_alpha190/cvs/Linux x86_64, signed Manifest commit with key B576E4E3)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/gentoo-sources/ChangeLog16
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.0.88.ebuild29
2 files changed, 44 insertions, 1 deletions
diff --git a/sys-kernel/gentoo-sources/ChangeLog b/sys-kernel/gentoo-sources/ChangeLog
index 425d9e909172..cac89e23abd4 100644
--- a/sys-kernel/gentoo-sources/ChangeLog
+++ b/sys-kernel/gentoo-sources/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for sys-kernel/gentoo-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.1164 2013/07/29 16:44:04 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.1165 2013/07/29 17:49:27 mpagano Exp $
+
+*gentoo-sources-3.0.88 (29 Jul 2013)
+
+ 29 Jul 2013; Michael Pagano <mpagano@gentoo.org>
+ +gentoo-sources-3.0.88.ebuild:
+ Linux patch 3.0.88. Support for namespace user.pax.* on tmpfs. Patch to
+ initialize satype in key_notify_policy_flush(). Patch to fix zcache build
+ error. ALPS Touchpad patches: Add PSMOUSE_CMD_RESET_WRAP; Move the protocol
+ information to Documentation for the ALPS Touchpad; Add protocol version
+ field in alps_model_info; Remove assumptions about packet size; Add support
+ for protocol versions 3 and 4; Add documentation for protocol versions 3 and
+ 4; Add semi-MT support for v3 protocol and dump raw packet data. ACPI patch
+ to disable Windows 8 compatibility for some Lenovo ThinkPads. fbcondecor
+ console decoration patch.
*gentoo-sources-3.4.55 (29 Jul 2013)
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.0.88.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.0.88.ebuild
new file mode 100644
index 000000000000..dacbb4a17374
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.0.88.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.0.88.ebuild,v 1.1 2013/07/29 17:49:27 mpagano Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="59"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}