summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-07-06 14:20:54 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-07-06 14:20:54 +0000
commite30b70fe4c00321382de22dc0330cc14f5d2c833 (patch)
treede843929f85952aac42a24a1fd6ed8cc574e41cc /sys-kernel
parentBased on 2.6.32.42 + genpatches-2.6.32-39 + grsecurity-2.2.2-2.6.32.42-201107... (diff)
downloadgentoo-2-e30b70fe4c00321382de22dc0330cc14f5d2c833.tar.gz
gentoo-2-e30b70fe4c00321382de22dc0330cc14f5d2c833.tar.bz2
gentoo-2-e30b70fe4c00321382de22dc0330cc14f5d2c833.zip
Based on 2.6.39.2 + genpatches-2.6.39-4 + grsecurity-2.2.2-2.6.39.2-201107011911
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.39-r5.ebuild48
2 files changed, 56 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index cd5b2d2b1c2e..faa7d180d30e 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.436 2011/07/06 14:17:13 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.437 2011/07/06 14:20:54 blueness Exp $
+
+*hardened-sources-2.6.39-r5 (06 Jul 2011)
+
+ 06 Jul 2011; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.39-r5.ebuild:
+ Based on 2.6.39.2 + genpatches-2.6.39-4 +
+ grsecurity-2.2.2-2.6.39.2-201107011911
*hardened-sources-2.6.32-r55 (06 Jul 2011)
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.39-r5.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.39-r5.ebuild
new file mode 100644
index 000000000000..ab2ad004bb9b
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.39-r5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.39-r5.ebuild,v 1.1 2011/07/06 14:20:54 blueness Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="4"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-6"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.2*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
+ ewarn "[server], [workstation], and [virtualization]."
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}