summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-05-25 11:19:39 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-05-25 11:19:39 +0000
commit1951ce23e256539bc72bab4e063e21d72134c75a (patch)
treee7514fa32664b3eb96abe573db7e4844951d2e00 /sys-libs/argp-standalone/argp-standalone-1.3.ebuild
parentFix passing of O3 to cflags. Thanks to ago. (diff)
downloadgentoo-2-1951ce23e256539bc72bab4e063e21d72134c75a.tar.gz
gentoo-2-1951ce23e256539bc72bab4e063e21d72134c75a.tar.bz2
gentoo-2-1951ce23e256539bc72bab4e063e21d72134c75a.zip
Initial commit, thanks Ed Wildgoose, bug #292189
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/argp-standalone/argp-standalone-1.3.ebuild')
-rw-r--r--sys-libs/argp-standalone/argp-standalone-1.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-libs/argp-standalone/argp-standalone-1.3.ebuild b/sys-libs/argp-standalone/argp-standalone-1.3.ebuild
new file mode 100644
index 000000000000..7e617cae1398
--- /dev/null
+++ b/sys-libs/argp-standalone/argp-standalone-1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/argp-standalone/argp-standalone-1.3.ebuild,v 1.1 2012/05/25 11:19:38 blueness Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Standalone argp library for use with uclibc"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/misc/"
+SRC_URI="http://www.lysator.liu.se/~nisse/misc/argp-standalone-1.3.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-throw-in-funcdef.patch"
+}
+
+src_install() {
+ dolib.a libargp.a
+
+ insinto /usr/include
+ doins argp.h
+}