summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-01-15 07:44:39 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-01-15 07:44:39 +0000
commit00fb23d187619ae7ca76c329491d92567f9b1d18 (patch)
treea77b4263c738b3f65f3c31fd1bd831e842338163 /sys-libs/db
parentsci-chemistry/pymol: Version Bump (diff)
downloadgentoo-2-00fb23d187619ae7ca76c329491d92567f9b1d18.tar.gz
gentoo-2-00fb23d187619ae7ca76c329491d92567f9b1d18.tar.bz2
gentoo-2-00fb23d187619ae7ca76c329491d92567f9b1d18.zip
Version bump. Removed EAPI-5 ebuild. Converted some ebuilds to EAPI-4.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/ChangeLog9
-rw-r--r--sys-libs/db/db-4.8.30.ebuild37
-rw-r--r--sys-libs/db/db-5.3.28.ebuild (renamed from sys-libs/db/db-6.0.20.ebuild)47
-rw-r--r--sys-libs/db/db-6.0.20-r1.ebuild44
4 files changed, 70 insertions, 67 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 5153746f3dae..decb59d7a574 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.342 2014/01/05 22:02:40 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.343 2014/01/15 07:44:39 polynomial-c Exp $
+
+*db-5.3.28 (15 Jan 2014)
+
+ 15 Jan 2014; Lars Wendler <polynomial-c@gentoo.org> db-4.8.30.ebuild,
+ +db-5.3.28.ebuild, -db-6.0.20.ebuild, db-6.0.20-r1.ebuild:
+ Version bump. Removed EAPI-5 ebuild (not allowed for base-system packages).
+ Converted some ebuilds to EAPI-4.
05 Jan 2014; Robin H. Johnson <robbat2@gentoo.org> -db-4.2.52_p5.ebuild,
-db-4.3.29_p1.ebuild, -db-4.4.20_p4.ebuild, -db-4.5.20_p2.ebuild,
diff --git a/sys-libs/db/db-4.8.30.ebuild b/sys-libs/db/db-4.8.30.ebuild
index 372ffad91ee1..c614a274366e 100644
--- a/sys-libs/db/db-4.8.30.ebuild
+++ b/sys-libs/db/db-4.8.30.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.8.30.ebuild,v 1.16 2013/09/23 19:21:24 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.8.30.ebuild,v 1.17 2014/01/15 07:44:39 polynomial-c Exp $
+
+EAPI=4
inherit eutils db flag-o-matic java-pkg-opt-2 autotools multilib
@@ -39,7 +41,10 @@ RDEPEND="tcl? ( dev-lang/tcl )
src_unpack() {
unpack "${MY_P}".tar.gz
- cd "${WORKDIR}"/"${MY_P}"
+}
+
+src_prepare() {
+ cd "${WORKDIR}"/"${MY_P}" || die
for (( i=1 ; i<=${PATCHNO} ; i++ ))
do
epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
@@ -52,22 +57,23 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
epatch "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
- sed -e "/^DB_RELEASE_DATE=/s/%B %e, %Y/%Y-%m-%d/" -i dist/RELEASE
+ sed -e "/^DB_RELEASE_DATE=/s/%B %e, %Y/%Y-%m-%d/" -i dist/RELEASE \
+ || die
# Include the SLOT for Java JAR files
# This supersedes the unused jarlocation patches.
sed -r -i \
-e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
- "${S}"/../dist/Makefile.in
+ "${S}"/../dist/Makefile.in || die
- cd "${S}"/../dist
+ cd "${S}"/../dist || die
rm -f aclocal/libtool.m4
sed -i \
-e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
- configure.ac
+ configure.ac || die
sed -i \
-e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
- aclocal/programs.m4
+ aclocal/programs.m4 || die
AT_M4DIR="aclocal aclocal_java" eautoreconf
# Upstream sucks - they do autoconf and THEN replace the version variables.
. ./RELEASE
@@ -77,10 +83,10 @@ src_unpack() {
-e "s/__EDIT_DB_VERSION_PATCH__/$DB_VERSION_PATCH/g" \
-e "s/__EDIT_DB_VERSION_STRING__/$DB_VERSION_STRING/g" \
-e "s/__EDIT_DB_VERSION_UNIQUE_NAME__/$DB_VERSION_UNIQUE_NAME/g" \
- -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" configure
+ -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" configure || die
}
-src_compile() {
+src_configure() {
local myconf=''
# compilation with -O0 fails on amd64, see bug #171231
@@ -111,7 +117,6 @@ src_compile() {
myconf="${myconf} --disable-tcl"
fi
- cd "${S}"
ECONF_SOURCE="${S}"/../dist \
STRIP="true" \
econf \
@@ -126,12 +131,10 @@ src_compile() {
${myconf} \
$(use_enable test) \
"$@"
-
- emake || die "make failed"
}
src_install() {
- emake install DESTDIR="${D}" || die
+ emake install DESTDIR="${D}"
db_src_install_usrbinslot
@@ -143,8 +146,10 @@ src_install() {
dodir /usr/sbin
# This file is not always built, and no longer exists as of db-4.8
- [[ -f "${D}"/usr/bin/berkeley_db_svc ]] && \
- mv "${D}"/usr/bin/berkeley_db_svc "${D}"/usr/sbin/berkeley_db"${SLOT/./}"_svc
+ if [[ -f "${D}"/usr/bin/berkeley_db_svc ]] ; then
+ mv "${D}"/usr/bin/berkeley_db_svc \
+ "${D}"/usr/sbin/berkeley_db"${SLOT/./}"_svc || die
+ fi
if use java; then
java-pkg_regso "${D}"/usr/"$(get_libdir)"/libdb_java*.so
diff --git a/sys-libs/db/db-6.0.20.ebuild b/sys-libs/db/db-5.3.28.ebuild
index ed74cf3e0182..ffddbfa79873 100644
--- a/sys-libs/db/db-6.0.20.ebuild
+++ b/sys-libs/db/db-5.3.28.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-6.0.20.ebuild,v 1.1 2013/07/10 08:57:04 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-5.3.28.ebuild,v 1.1 2014/01/15 07:44:39 polynomial-c Exp $
-EAPI=5
+EAPI=4
inherit eutils db flag-o-matic java-pkg-opt-2 autotools multilib
#Number of official patches
@@ -26,8 +26,8 @@ for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
done
-LICENSE="AGPL-3"
-SLOT="6.0"
+LICENSE="Sleepycat"
+SLOT="5.3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="doc java cxx tcl test"
@@ -49,14 +49,18 @@ src_prepare() {
do
epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
done
+
# use the includes from the prefix
epatch "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
epatch "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
# sqlite configure call has an extra leading ..
# upstreamed:5.2.36, missing in 5.3.x
- # still needs to be patched in 6.0.19
- epatch "${FILESDIR}"/${PN}-6.0.19-sqlite-configure-path.patch
+ epatch "${FILESDIR}"/${PN}-5.2.28-sqlite-configure-path.patch
+
+ # The upstream testsuite copies .lib and the binaries for each parallel test
+ # core, ~300MB each. This patch uses links instead, saves a lot of space.
+ epatch "${FILESDIR}"/${PN}-6.0.20-test-link.patch
# Upstream release script grabs the dates when the script was run, so lets
# end-run them to keep the date the same.
@@ -65,22 +69,22 @@ src_prepare() {
"${S_BASE}"/dist/configure)"
sed -r -i \
-e "/^DB_RELEASE_DATE=/s~=.*~='${REAL_DB_RELEASE_DATE}'~g" \
- "${S_BASE}"/dist/RELEASE
+ "${S_BASE}"/dist/RELEASE || die
# Include the SLOT for Java JAR files
# This supersedes the unused jarlocation patches.
sed -r -i \
-e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
- "${S_BASE}"/dist/Makefile.in
+ "${S_BASE}"/dist/Makefile.in || die
- cd "${S_BASE}"/dist
+ cd "${S_BASE}"/dist || die
rm -f aclocal/libtool.m4
sed -i \
-e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
- configure.ac
+ configure.ac || die
sed -i \
-e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
- aclocal/programs.m4
+ aclocal/programs.m4 || die
AT_M4DIR="aclocal aclocal_java" eautoreconf
# Upstream sucks - they do autoconf and THEN replace the version variables.
. ./RELEASE
@@ -90,7 +94,7 @@ src_prepare() {
DB_VERSION \
DB_RELEASE_DATE ; do
local ev="__EDIT_${v}__"
- sed -i -e "s/${ev}/${!v}/g" configure
+ sed -i -e "s/${ev}/${!v}/g" configure || die
done
}
@@ -127,7 +131,6 @@ src_configure() {
# sql_compat will cause a collision with sqlite3
# --enable-sql_compat
- cd "${S}"
ECONF_SOURCE="${S_BASE}"/dist \
STRIP="true" \
econf \
@@ -148,12 +151,8 @@ src_configure() {
"$@"
}
-src_compile() {
- emake || die "make failed"
-}
-
src_install() {
- emake install DESTDIR="${D}" || die
+ emake install DESTDIR="${D}"
db_src_install_usrbinslot
@@ -165,8 +164,10 @@ src_install() {
dodir /usr/sbin
# This file is not always built, and no longer exists as of db-4.8
- [[ -f "${D}"/usr/bin/berkeley_db_svc ]] && \
- mv "${D}"/usr/bin/berkeley_db_svc "${D}"/usr/sbin/berkeley_db"${SLOT/./}"_svc
+ if [[ -f "${D}"/usr/bin/berkeley_db_svc ]] ; then
+ mv "${D}"/usr/bin/berkeley_db_svc \
+ "${D}"/usr/sbin/berkeley_db"${SLOT/./}"_svc || die
+ fi
if use java; then
java-pkg_regso "${D}"/usr/"$(get_libdir)"/libdb_java*.so
@@ -193,7 +194,7 @@ src_test() {
# "${S_BASE}/test/testparams.tcl"
sed -ri \
-e '/multi_repmgr/d' \
- "${S_BASE}/test/tcl/test.tcl"
+ "${S_BASE}/test/tcl/test.tcl" || die
# This is the only failure in 5.2.28 so far, and looks like a false positive.
# Repmgr018 (btree): Test of repmgr stats.
@@ -206,7 +207,7 @@ src_test() {
sed -ri \
-e '/set parms.*repmgr018/d' \
-e 's/repmgr018//g' \
- "${S_BASE}/test/tcl/test.tcl"
+ "${S_BASE}/test/tcl/test.tcl" || die
db_src_test
}
diff --git a/sys-libs/db/db-6.0.20-r1.ebuild b/sys-libs/db/db-6.0.20-r1.ebuild
index 122b389a3ab4..0d3b5d7d3dc8 100644
--- a/sys-libs/db/db-6.0.20-r1.ebuild
+++ b/sys-libs/db/db-6.0.20-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-6.0.20-r1.ebuild,v 1.1 2013/07/10 17:10:41 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-6.0.20-r1.ebuild,v 1.2 2014/01/15 07:44:39 polynomial-c Exp $
-EAPI=2
+EAPI=4
inherit eutils db flag-o-matic java-pkg-opt-2 autotools multilib
#Number of official patches
@@ -49,21 +49,14 @@ src_prepare() {
do
epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
done
- #epatch "${FILESDIR}"/${PN}-4.8-libtool.patch
- # upstreamed:5.2.36
- #epatch "${FILESDIR}"/${PN}-4.8.24-java-manifest-location.patch
# use the includes from the prefix
epatch "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
epatch "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
- # upstream autoconf fails to build DBM when it's supposed to
- # merged upstream in 5.0.26
- #epatch "${FILESDIR}"/${PN}-5.0.21-enable-dbm-autoconf.patch
-
# sqlite configure call has an extra leading ..
# upstreamed:5.2.36, missing in 5.3.x/6.x
- # still needs to be patched in 6.0.19
+ # still needs to be patched in 6.0.20
epatch "${FILESDIR}"/${PN}-6.0.19-sqlite-configure-path.patch
# The upstream testsuite copies .lib and the binaries for each parallel test
@@ -77,22 +70,22 @@ src_prepare() {
"${S_BASE}"/dist/configure)"
sed -r -i \
-e "/^DB_RELEASE_DATE=/s~=.*~='${REAL_DB_RELEASE_DATE}'~g" \
- "${S_BASE}"/dist/RELEASE
+ "${S_BASE}"/dist/RELEASE || die
# Include the SLOT for Java JAR files
# This supersedes the unused jarlocation patches.
sed -r -i \
-e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
- "${S_BASE}"/dist/Makefile.in
+ "${S_BASE}"/dist/Makefile.in || die
- cd "${S_BASE}"/dist
+ cd "${S_BASE}"/dist || die
rm -f aclocal/libtool.m4
sed -i \
-e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
- configure.ac
+ configure.ac || die
sed -i \
-e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
- aclocal/programs.m4
+ aclocal/programs.m4 || die
AT_M4DIR="aclocal aclocal_java" eautoreconf
# Upstream sucks - they do autoconf and THEN replace the version variables.
. ./RELEASE
@@ -102,7 +95,7 @@ src_prepare() {
DB_VERSION \
DB_RELEASE_DATE ; do
local ev="__EDIT_${v}__"
- sed -i -e "s/${ev}/${!v}/g" configure
+ sed -i -e "s/${ev}/${!v}/g" configure || die
done
}
@@ -139,7 +132,6 @@ src_configure() {
# sql_compat will cause a collision with sqlite3
# --enable-sql_compat
- cd "${S}"
ECONF_SOURCE="${S_BASE}"/dist \
STRIP="true" \
econf \
@@ -160,12 +152,8 @@ src_configure() {
"$@"
}
-src_compile() {
- emake || die "make failed"
-}
-
src_install() {
- emake install DESTDIR="${D}" || die
+ emake install DESTDIR="${D}"
db_src_install_usrbinslot
@@ -177,8 +165,10 @@ src_install() {
dodir /usr/sbin
# This file is not always built, and no longer exists as of db-4.8
- [[ -f "${D}"/usr/bin/berkeley_db_svc ]] && \
- mv "${D}"/usr/bin/berkeley_db_svc "${D}"/usr/sbin/berkeley_db"${SLOT/./}"_svc
+ if [[ -f "${D}"/usr/bin/berkeley_db_svc ]] ; then
+ mv "${D}"/usr/bin/berkeley_db_svc \
+ "${D}"/usr/sbin/berkeley_db"${SLOT/./}"_svc || die
+ fi
if use java; then
java-pkg_regso "${D}"/usr/"$(get_libdir)"/libdb_java*.so
@@ -205,7 +195,7 @@ src_test() {
# "${S_BASE}/test/testparams.tcl"
sed -ri \
-e '/multi_repmgr/d' \
- "${S_BASE}/test/tcl/test.tcl"
+ "${S_BASE}/test/tcl/test.tcl" || die
# This is the only failure in 5.2.28 so far, and looks like a false positive.
# Repmgr018 (btree): Test of repmgr stats.
@@ -218,7 +208,7 @@ src_test() {
sed -ri \
-e '/set parms.*repmgr018/d' \
-e 's/repmgr018//g' \
- "${S_BASE}/test/tcl/test.tcl"
+ "${S_BASE}/test/tcl/test.tcl" || die
db_src_test
}