summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-03-07 02:33:29 +0000
committerMike Frysinger <vapier@gentoo.org>2010-03-07 02:33:29 +0000
commit8da2539eb404792daedf502cdb7c1acd2aea34d9 (patch)
tree1871b25eb9f35822439e050dd3507c6a5721bc42 /sys-libs/e2fsprogs-libs
parentVersion bumped. (diff)
downloadgentoo-2-8da2539eb404792daedf502cdb7c1acd2aea34d9.tar.gz
gentoo-2-8da2539eb404792daedf502cdb7c1acd2aea34d9.tar.bz2
gentoo-2-8da2539eb404792daedf502cdb7c1acd2aea34d9.zip
old
Diffstat (limited to 'sys-libs/e2fsprogs-libs')
-rw-r--r--sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.3-r1.ebuild64
-rw-r--r--sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.6.ebuild53
-rw-r--r--sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.8.ebuild60
3 files changed, 0 insertions, 177 deletions
diff --git a/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.3-r1.ebuild b/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.3-r1.ebuild
deleted file mode 100644
index f0efd13b07b0..000000000000
--- a/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.3-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.3-r1.ebuild,v 1.4 2009/12/01 04:49:06 vapier Exp $
-
-EAPI="2"
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="e2fsprogs libraries (common error, subsystem, uuid, block id)"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls"
-
-RDEPEND="!sys-libs/com_err
- !sys-libs/ss
- !<sys-fs/e2fsprogs-1.41"
-DEPEND="nls? ( sys-devel/gettext )
- dev-util/pkgconfig
- sys-devel/bc"
-
-src_configure() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --enable-${libtype}-shlibs \
- $(tc-has-tls || echo --disable-tls) \
- $(use_enable nls) \
- || die
-
-}
-
-src_compile() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- emake STRIP=/bin/true || die
-}
-
-src_install() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
-
- emake STRIP=/bin/true DESTDIR="${D}" install || die
-
- dodir /$(get_libdir)
- local lib slib
- for lib in "${D}"/usr/$(get_libdir)/*.a ; do
- slib=${lib##*/}
- mv "${lib%.a}"$(get_libname)* "${D}"/$(get_libdir)/ || die "moving lib ${slib}"
- gen_usr_ldscript ${slib%.a}$(get_libname)
- done
-}
diff --git a/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.6.ebuild b/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.6.ebuild
deleted file mode 100644
index 6e30cf0d3206..000000000000
--- a/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.6.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.6.ebuild,v 1.3 2009/12/01 04:49:06 vapier Exp $
-
-EAPI="2"
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="e2fsprogs libraries (common error, subsystem, uuid, block id)"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls"
-
-RDEPEND="elibc_glibc? ( >=sys-libs/glibc-2.6 )
- !sys-libs/com_err
- !sys-libs/ss
- !<sys-fs/e2fsprogs-1.41"
-DEPEND="nls? ( sys-devel/gettext )
- dev-util/pkgconfig
- sys-devel/bc"
-
-src_prepare() {
- # stupid configure script clobbers CC for us
- sed -i '/if test -z "$CC" ; then CC=cc; fi/d' configure
-}
-
-src_configure() {
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- ac_cv_path_LDCONFIG=: \
- econf \
- --enable-${libtype}-shlibs \
- $(tc-has-tls || echo --disable-tls) \
- $(use_enable nls)
-}
-
-src_install() {
- emake STRIP=: DESTDIR="${D}" install || die
-
- set -- "${D}"/usr/$(get_libdir)/*.a
- set -- ${@/*\/lib}
- gen_usr_ldscript -a "${@/.a}"
-}
diff --git a/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.8.ebuild b/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.8.ebuild
deleted file mode 100644
index 106f29084a4b..000000000000
--- a/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.8.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.41.8.ebuild,v 1.8 2009/12/01 04:49:06 vapier Exp $
-
-EAPI="2"
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="e2fsprogs libraries (common error and subsystem)"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls"
-
-RDEPEND="elibc_glibc? ( >=sys-libs/glibc-2.6 )
- !sys-libs/com_err
- !sys-libs/ss
- !<sys-fs/e2fsprogs-1.41.8"
-DEPEND="nls? ( sys-devel/gettext )
- dev-util/pkgconfig
- sys-devel/bc"
-
-export VARTEXFONTS=${T}/fonts #281390
-
-src_prepare() {
- # stupid configure script clobbers CC for us
- sed -i '/if test -z "$CC" ; then CC=cc; fi/d' configure
-}
-
-src_configure() {
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- # we use blkid/uuid from util-linux now
- ac_cv_lib_uuid_uuid_generate=yes \
- ac_cv_lib_blkid_blkid_get_cache=yes \
- ac_cv_path_LDCONFIG=: \
- econf \
- --disable-libblkid \
- --disable-libuuid \
- --enable-${libtype}-shlibs \
- $(tc-has-tls || echo --disable-tls) \
- $(use_enable nls)
-}
-
-src_install() {
- emake STRIP=: DESTDIR="${D}" install || die
-
- set -- "${D}"/usr/$(get_libdir)/*.a
- set -- ${@/*\/lib}
- gen_usr_ldscript -a "${@/.a}"
-}